diff mbox series

[meta-python] python3-daemon: upgrade 2.3.2 -> 3.0.1

Message ID 1679545214-20015-3-git-send-email-wangmy@fujitsu.com
State Under Review
Headers show
Series [meta-python] python3-daemon: upgrade 2.3.2 -> 3.0.1 | expand

Commit Message

Mingyu Wang (Fujitsu) March 23, 2023, 4:20 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
==========
Bugs Fixed:
* Migrate to use the explicitly-maintained 'packaging' library.
  The package bundled in 'setuptools.extern.packaging' is to help make that
  package self-contained, but is not a supported API.
* Declare dependency on Setuptools >= 62.4.0.
  This is necessary for establishing the version information via Setuptools. We
  use 'setuptools.command.build', 'introduced in Setuptools version 62.4.0
* Refactor calculation of file descriptor ranges to close.
	
Added:
* Document a 'ServiceRunner' class as an example of using 'DaemonContext'.
* PyPA recommended Project URLs for the distribution.
	
Changed:
* Raise a TypeError if any 'exclude' values are not valid file descriptors.
* Migrate package version handling to use Setuptools API.
	
Removed:
* Remove redundant 'wheel' from the requirements specification.
* Remove Setuptools 'test' command support.
* Remove Setuptools 'register' and 'upload' command support.
* Remove the obsolete 'runner' module.
	
Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../{python3-daemon_2.3.2.bb => python3-daemon_3.0.1.bb}       | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-daemon_2.3.2.bb => python3-daemon_3.0.1.bb} (77%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-daemon_2.3.2.bb b/meta-python/recipes-devtools/python/python3-daemon_3.0.1.bb
similarity index 77%
rename from meta-python/recipes-devtools/python/python3-daemon_2.3.2.bb
rename to meta-python/recipes-devtools/python/python3-daemon_3.0.1.bb
index 49b094fce..79507bdce 100644
--- a/meta-python/recipes-devtools/python/python3-daemon_2.3.2.bb
+++ b/meta-python/recipes-devtools/python/python3-daemon_3.0.1.bb
@@ -13,7 +13,6 @@  LIC_FILES_CHKSUM = "file://README;md5=a3a94c615dc969a70525f1eebbacf235"
 
 inherit pypi setuptools3
 
-SRC_URI[md5sum] = "b7397fe73d516dc14921500a1245b41c"
-SRC_URI[sha256sum] = "3deeb808e72b6b89f98611889e11cc33754f5b2c1517ecfa1aaf25f402051fb5"
+SRC_URI[sha256sum] = "6c57452372f7eaff40934a1c03ad1826bf5e793558e87fef49131e6464b4dae5"
 
 PYPI_PACKAGE = "python-daemon"