diff mbox series

[meta-python] python3-gcovr: upgrade 5.2 -> 6.0

Message ID 1678889082-20604-4-git-send-email-wangmy@fujitsu.com
State Under Review
Headers show
Series [meta-python] python3-gcovr: upgrade 5.2 -> 6.0 | expand

Commit Message

Mingyu Wang (Fujitsu) March 15, 2023, 2:04 p.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

License-Update: Copyright year updated to 2023.

Changelog:
==========
Breaking changes:
------------------
    Remove not allowed attributes function-rate, functions-covered and functions-valid from cobertura report. (:issue:'671')
    Remove "noncode" entries in JSON reports. (:issue:'663')
    New :option:'--exclude-noncode-lines' to exclude noncode lines. Noncode lines are not excluded by default anymore. (:issue:'704', :issue:'705')
    Changed :option:'--gcov-ignore-parse-errors' to accept list of errors to ignore. (:issue:'701')
    The default filename for :option:'--cobertura' is changed from coverage.xml to cobertura.xml (:issue:'721')
    Handling of gcov errors:
        Do not ignore return code of gcov. (:issue:'653')
        New :option:'--gcov-ignore-errors' to ignore gcov errors. Old behavior was to print a warning and continue. (:issue:'718')
    Revert changes from :issue:'623' and add documentation entry :ref:'support keil uvision format'. (:issue:'727')

New features and notable changes:
---------------------------------
    New :option:'--html-nested' for reports that summarize subdirectories with aggregated statistics per directory. (:issue:'687')
    Accept NAN % which is used in GCOV 7.5.0 instead of an invalid value. (:issue:'651')
    New :option:'--json-base' to define a base bath used in JSON reports. (:issue:'656')
    New :option:'--calls' to report call coverage: function calls invoked/total (:issue:'666')
    New nox session to generate a portable application with pyinstaller, see :ref:'standalone application'. (:issue:'661')
    Print a warning if root directory contains symlinks. (:issue:'652')
    Change :option:'--keep' when calling gcov internaly. (:issue:'703')
    Allow annotations for never executed branches. (:issue:'711')
    Add function merge mode for same function defined in different lines. (:issue:'700')
    Update link to gcovr documentation in HTML report to point to the documentation of the used version. (:issue:'723')
    Add environment SOURCE_DATE_EPOCH to set default for :option:'--timestamp'. (:issue:'729')

Bug fixes and small improvements:
--------------------------------
    Fix :option:'--html-tab-size' feature. (:issue:'650')
    Fix alphabetical sort of html report, for when there are symlinks. (:issue:'685')
    Handle :option:'--version' before parsing the configuration file. (:issue:'696')
    Fix reports of excluded coverage. (:issue:'409', :issue:'503', :issue:'663')
    Fix handling for nonexistent source code for HTML-details and Coveralls reports. (:issue:'663')
    Exclude functions with :ref:'Exclusion markers'. (:issue:'713')
    Fix problem in decision parser if open block brace is on same line. (:issue:'681')
    Add Python 3.11 to test matrix. (:issue:'717')
    Fix casing of files if filesystem is case insensitive. (:issue:'694')
    Fix deadlock if :option:'-j' is used and there are errors from gcov execution. (:issue:'719')
    Fix problem in decision parser if case is not on a single line with the break statement. (:issue:'738')
    Do not use realpath for DirectoryPrefixFilter to support symlinks in root directory. (:issue:'712')

Documentation:
-------------
    Add detailed reference for the JSON output format. (:issue:'663')

Internal changes:
-----------------
    Select the :option:'--html-theme' using CSS classes. (:issue:'650')
    Change and extend cmake tests. (:issue:'676')
    Detect gcc version for running tests. (:issue:'686')
    Use scrubbed data for --update_reference option. (:issue:'698')
    Install ninja with package manager instead of GitHub action. (:issue:'699')
    Rename the reference files coverage.xml to cobertura.xml and the test from xml to cobertura (:issue:'721')
    Add support for clang-14 in our test suite and improve startup performance of docker image. (:issue:'731')
    Compare files by extension in test suite. (:issue:'733')
    Split HTML templates into one file for each part of the page. (:issue:'735')
    Change docker image to be able to use it like the nox command itself. (:issue:'734')

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../python/{python3-gcovr_5.2.bb => python3-gcovr_6.0.bb}     | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-gcovr_5.2.bb => python3-gcovr_6.0.bb} (76%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-gcovr_5.2.bb b/meta-python/recipes-devtools/python/python3-gcovr_6.0.bb
similarity index 76%
rename from meta-python/recipes-devtools/python/python3-gcovr_5.2.bb
rename to meta-python/recipes-devtools/python/python3-gcovr_6.0.bb
index 03231f926..901d0017d 100644
--- a/meta-python/recipes-devtools/python/python3-gcovr_5.2.bb
+++ b/meta-python/recipes-devtools/python/python3-gcovr_6.0.bb
@@ -2,10 +2,10 @@  DESCRIPTION = "generate GCC code coverage reports"
 HOMEPAGE = "https://gcovr.com"
 SECTION = "devel/python"
 LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e59af597b3484fa3b52c0fbfd5d17611"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=6542fc4ce5904ffb741ef56f8fe33452"
 
 SRC_URI = "git://github.com/gcovr/gcovr.git;branch=master;protocol=https"
-SRCREV = "1040a85ecfb3ef0d01635df9d50a3cae5059d566"
+SRCREV = "1221ef62ff0de15bbeaf79e68e08a65d62c73ff4"
 
 S = "${WORKDIR}/git"