diff mbox series

[meta-python] python3-simpleeval: upgrade 0.9.12 -> 0.9.13

Message ID 1677485523-11699-4-git-send-email-wangmy@fujitsu.com
State Under Review
Headers show
Series [meta-python] python3-simpleeval: upgrade 0.9.12 -> 0.9.13 | expand

Commit Message

Mingyu Wang (Fujitsu) Feb. 27, 2023, 8:12 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
===========
 Better handling of empty strings passed as input.
 Fix the shift safe number issue from 0.9.12
 More minor pylint / etc fixes / cleanups (general code quality)
 separate .parse from #115
 Allow setting up completely empty {} operators / functions ( #75 via #123 )
 Add extra bit-ops from #87
 Add @daxamin to contributors ?
 Version bump stuff.
 other readme tweaks
 star expressions, eg x = {"a": 1, "b": 2, **c}

no-build.patch
removed since it's included in 0.9.13

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../python/python3-simpleeval/no-build.patch  | 24 -------------------
 ...0.9.12.bb => python3-simpleeval_0.9.13.bb} |  7 ++----
 2 files changed, 2 insertions(+), 29 deletions(-)
 delete mode 100644 meta-python/recipes-devtools/python/python3-simpleeval/no-build.patch
 rename meta-python/recipes-devtools/python/{python3-simpleeval_0.9.12.bb => python3-simpleeval_0.9.13.bb} (75%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-simpleeval/no-build.patch b/meta-python/recipes-devtools/python/python3-simpleeval/no-build.patch
deleted file mode 100644
index 8302c3b29..000000000
--- a/meta-python/recipes-devtools/python/python3-simpleeval/no-build.patch
+++ /dev/null
@@ -1,24 +0,0 @@ 
-Upstream-Status: Backport [https://github.com/danthedeckie/simpleeval/pull/119]
-Signed-off-by: Ross Burton <ross.burton@arm.com>
-
-From 08bc99211aec32882d5f1c83896eb5d72b9fb125 Mon Sep 17 00:00:00 2001
-From: Ross Burton <ross.burton@arm.com>
-Date: Mon, 23 May 2022 11:35:00 +0100
-Subject: [PATCH] pyproject.toml: remove build as a build-dependency
-
-pypa/build is one possible build tool, but not the only build tool.  Forcing build to be present as a build dependency is meaningless: either the user is using build so obviously have build, or are using something else so having build is irrelevant.
----
- pyproject.toml | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/pyproject.toml b/pyproject.toml
-index 052a55a..416482b 100644
---- a/pyproject.toml
-+++ b/pyproject.toml
-@@ -1,5 +1,5 @@
- [build-system]
--requires = ["setuptools>=30.3.0", "wheel", "build"]
-+requires = ["setuptools>=30.3.0", "wheel"]
- build-backend = "setuptools.build_meta"
- 
- [tool.black]
diff --git a/meta-python/recipes-devtools/python/python3-simpleeval_0.9.12.bb b/meta-python/recipes-devtools/python/python3-simpleeval_0.9.13.bb
similarity index 75%
rename from meta-python/recipes-devtools/python/python3-simpleeval_0.9.12.bb
rename to meta-python/recipes-devtools/python/python3-simpleeval_0.9.13.bb
index c9cf33d02..35cd19ffe 100644
--- a/meta-python/recipes-devtools/python/python3-simpleeval_0.9.12.bb
+++ b/meta-python/recipes-devtools/python/python3-simpleeval_0.9.13.bb
@@ -3,16 +3,13 @@  HOMEPAGE = "https://pypi.org/project/simpleeval/"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENCE;md5=dc9277482effe59b734b004cbcc1fee7"
 
-SRC_URI[sha256sum] = "3e0be507486d4e21cf9d08847c7e57dd61a1603950399985f7c5a0be7fd33e36"
+SRC_URI[sha256sum] = "4a30f9cc01825fe4c719c785e3762623e350c4840d5e6855c2a8496baaa65fac"
 
 inherit pypi python_setuptools_build_meta ptest
 
 BBCLASSEXTEND = "native nativesdk"
 
-SRC_URI += " \
-	file://no-build.patch \
-	file://run-ptest \
-"
+SRC_URI += "file://run-ptest"
 
 RDEPENDS:${PN} += " \
 	${PYTHON_PN}-math \