diff mbox series

[meta-python] python3-qrcode: upgrade 7.3.1 -> 7.4.2

Message ID 1676192839-13378-2-git-send-email-wangmy@fujitsu.com
State Under Review
Headers show
Series [meta-python] python3-qrcode: upgrade 7.3.1 -> 7.4.2 | expand

Commit Message

Mingyu Wang (Fujitsu) Feb. 12, 2023, 9:07 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changelog:
==========
- Allow pypng factory to allow for saving to a string
  (like qr.save("some_file.png")) in addition to file-like objects.
- Fix bad over-optimization in v7.4 that broke large QR codes. Thanks to
  mattiasj-axis!
- Restructure the factory drawers, allowing different shapes in SVG image
  factories as well.
- Add a --factory-drawer option to the qr console script.
- Optimize the output for the SVGPathImage factory (more than 30% reduction in
  file sizes).
- Add a pypng image factory as a pure Python PNG solution. If pillow is not
  installed, then this becomes the default factory.
- The pymaging image factory has been removed, but its factory shortcut and the
  actual PymagingImage factory class now just link to the PyPNGImage factory.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../python/{python3-qrcode_7.3.1.bb => python3-qrcode_7.4.2.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-qrcode_7.3.1.bb => python3-qrcode_7.4.2.bb} (73%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-qrcode_7.3.1.bb b/meta-python/recipes-devtools/python/python3-qrcode_7.4.2.bb
similarity index 73%
rename from meta-python/recipes-devtools/python/python3-qrcode_7.3.1.bb
rename to meta-python/recipes-devtools/python/python3-qrcode_7.4.2.bb
index f6de60e1a..8c0429bbb 100644
--- a/meta-python/recipes-devtools/python/python3-qrcode_7.3.1.bb
+++ b/meta-python/recipes-devtools/python/python3-qrcode_7.4.2.bb
@@ -4,7 +4,7 @@  LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=4b802d2a65df4626623c79757f486af9"
 
 PYPI_PACKAGE = "qrcode"
-SRC_URI[sha256sum] = "375a6ff240ca9bd41adc070428b5dfc1dcfbb0f2507f1ac848f6cded38956578"
+SRC_URI[sha256sum] = "9dd969454827e127dbd93696b20747239e6d540e082937c90f14ac95b30f5845"
 
 inherit pypi setuptools3