diff mbox series

[meta-python] python3-portion: Upgrade 2.3.0 -> 2.3.1

Message ID 1676122405-5945-1-git-send-email-wangmy@fujitsu.com
State Under Review
Headers show
Series [meta-python] python3-portion: Upgrade 2.3.0 -> 2.3.1 | expand

Commit Message

Mingyu Wang (Fujitsu) Feb. 11, 2023, 1:33 p.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changed
=======
 Speed up lookups in IntervalDict for non-interval keys.
 Speed up iterate by no longer creating singleton instances under the hood.
 Drop official support for Python 3.6.

Fixed
=====
 Infinite recursion when a subclass of an Interval is compared using > with an Interval instance (see #75).

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../{python3-portion_2.3.0.bb => python3-portion_2.3.1.bb}      | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-portion_2.3.0.bb => python3-portion_2.3.1.bb} (80%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-portion_2.3.0.bb b/meta-python/recipes-devtools/python/python3-portion_2.3.1.bb
similarity index 80%
rename from meta-python/recipes-devtools/python/python3-portion_2.3.0.bb
rename to meta-python/recipes-devtools/python/python3-portion_2.3.1.bb
index 1638d64c3..d998db01d 100644
--- a/meta-python/recipes-devtools/python/python3-portion_2.3.0.bb
+++ b/meta-python/recipes-devtools/python/python3-portion_2.3.1.bb
@@ -7,7 +7,7 @@  LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=05f1e16a8e59ce3e9a979e881816c2ab"
 
 inherit pypi setuptools3
 
-SRC_URI[sha256sum] = "0e9d42838099263201b25517e4c1bd57042b5fe44432d6df38cef72d84d1eb1f"
+SRC_URI[sha256sum] = "247471718131d41fb82137ab7b6466cdf4b785d047e38d309ebf34c84101a3a6"
 
 RDEPENDS:${PN} = "\
     ${PYTHON_PN}-sortedcontainers \