diff mbox series

[meta-python] python3-lazy-object-proxy: upgrade 1.8.0 -> 1.9.0

Message ID 1673414646-13721-2-git-send-email-wangmy@fujitsu.com
State Under Review
Headers show
Series [meta-python] python3-lazy-object-proxy: upgrade 1.8.0 -> 1.9.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Jan. 11, 2023, 5:24 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

License-Update: Copyright year updated to 2023.

Changelog:
==========
- Added support for matrix multiplication operator (@).
- Should have all the wheels now (including the manylinux ones).
- Bumped minimum version requirements for setuptools and setuptools-scm.
- Switched the default pure python fallback implementation to the "simple" one
  (when you from lazy_object_proxy import Proxy and the C extension is not
  available). Previously the "slots" implementation was used but as it turns
  out it is slower on Python 3.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 ...ject-proxy_1.8.0.bb => python3-lazy-object-proxy_1.9.0.bb} | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-lazy-object-proxy_1.8.0.bb => python3-lazy-object-proxy_1.9.0.bb} (61%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-lazy-object-proxy_1.8.0.bb b/meta-python/recipes-devtools/python/python3-lazy-object-proxy_1.9.0.bb
similarity index 61%
rename from meta-python/recipes-devtools/python/python3-lazy-object-proxy_1.8.0.bb
rename to meta-python/recipes-devtools/python/python3-lazy-object-proxy_1.9.0.bb
index 46ef296262..74c5e9b520 100644
--- a/meta-python/recipes-devtools/python/python3-lazy-object-proxy_1.8.0.bb
+++ b/meta-python/recipes-devtools/python/python3-lazy-object-proxy_1.9.0.bb
@@ -2,10 +2,10 @@  SUMMARY = "A fast and thorough lazy object proxy"
 HOMEPAGE = "https://python-lazy-object-proxy.readthedocs.io/"
 LICENSE = "BSD-2-Clause"
 SECTION = "devel/python"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=c7d2e9d24c2b5bad57ca894da972e22e"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d606e94f56c21c8e0cdde0b622dcdf57"
 
 DEPENDS += "${PYTHON_PN}-setuptools-scm-native ${PYTHON_PN}-pip-native"
 
-SRC_URI[sha256sum] = "c219a00245af0f6fa4e95901ed28044544f50152840c5b6a3e7b2568db34d156"
+SRC_URI[sha256sum] = "659fb5809fa4629b8a1ac5106f669cfc7bef26fbb389dda53b3e010d1ac4ebae"
 
 inherit pypi setuptools3