diff mbox series

[meta-python] python3-pyjwt: upgrade 2.5.0 -> 2.6.0

Message ID 1666595897-29808-1-git-send-email-wangmy@fujitsu.com
State New
Headers show
Series [meta-python] python3-pyjwt: upgrade 2.5.0 -> 2.6.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Oct. 24, 2022, 7:18 a.m. UTC
From: Wang Mingyu <wangmy@fujitsu.com>

Changed
--------
    bump up cryptography >= 3.4.0 by @jpadilla in #807
    Remove types-cryptography from crypto extra by @lautat in #805

Fixed
---------
    Invalidate token on the exact second the token expires #797
    fix: version 2.5.0 heading typo by @c0state in #803

Added
-------
    Adding validation for issued_at when iat > (now + leeway) as ImmatureSignatureError by @sriharan16 in #794

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../python/{python3-pyjwt_2.5.0.bb => python3-pyjwt_2.6.0.bb}   | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-pyjwt_2.5.0.bb => python3-pyjwt_2.6.0.bb} (83%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pyjwt_2.5.0.bb b/meta-python/recipes-devtools/python/python3-pyjwt_2.6.0.bb
similarity index 83%
rename from meta-python/recipes-devtools/python/python3-pyjwt_2.5.0.bb
rename to meta-python/recipes-devtools/python/python3-pyjwt_2.6.0.bb
index f587e5c0de..d6ca242c58 100644
--- a/meta-python/recipes-devtools/python/python3-pyjwt_2.5.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pyjwt_2.6.0.bb
@@ -5,7 +5,7 @@  HOMEPAGE = "http://github.com/jpadilla/pyjwt"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=e4b56d2c9973d8cf54655555be06e551"
 
-SRC_URI[sha256sum] = "e77ab89480905d86998442ac5788f35333fa85f65047a534adc38edf3c88fc3b"
+SRC_URI[sha256sum] = "69285c7e31fc44f68a1feb309e948e0df53259d579295e6cfe2b1792329f05fd"
 
 PYPI_PACKAGE = "PyJWT"
 inherit pypi setuptools3