diff mbox series

[meta-gnome] gexiv2: Fix buildpaths warning.

Message ID 1663291931-26311-1-git-send-email-leimaohui@fujitsu.com
State Under Review
Headers show
Series [meta-gnome] gexiv2: Fix buildpaths warning. | expand

Commit Message

Maohui Lei (Fujitsu) Sept. 16, 2022, 1:32 a.m. UTC
WARNING: gexiv2-0.14.0-r0 do_package_qa: QA Issue: File /usr/src/debug/gexiv2/0.14.0-r0/gexiv2/gexiv2-enums.cpp in package lib32-gexiv2-src contains reference to TMPDIR [buildpaths]

Signed-off-by: Lei Maohui <leimaohui@fujitsu.com>
---
 meta-gnome/recipes-gnome/gexiv2/gexiv2_0.14.0.bb | 7 +++++++
 1 file changed, 7 insertions(+)
diff mbox series

Patch

diff --git a/meta-gnome/recipes-gnome/gexiv2/gexiv2_0.14.0.bb b/meta-gnome/recipes-gnome/gexiv2/gexiv2_0.14.0.bb
index afec302..fed29da 100644
--- a/meta-gnome/recipes-gnome/gexiv2/gexiv2_0.14.0.bb
+++ b/meta-gnome/recipes-gnome/gexiv2/gexiv2_0.14.0.bb
@@ -19,3 +19,10 @@  EXTRA_OEMESON = " \
 PACKAGES =+ "${PN}-python3"
 FILES:${PN}-python3 = "${PYTHON_SITEPACKAGES_DIR}"
 RDEPENDS:${PN}-python3 = "${PN}"
+
+PACKAGE_PREPROCESS_FUNCS += "src_package_preprocess"
+src_package_preprocess () {
+        # Trim build paths from comments in generated sources to ensure reproducibility
+        sed -i -e "s,${B}/../${BPN}-${PV}/${BPN}/,,g" \
+            ${B}/gexiv2/gexiv2-enums.cpp
+}