diff mbox series

[meta-python] python3-werkzeug: upgrade 2.1.2 -> 2.2.0

Message ID 1658974589-10681-2-git-send-email-wangmy@fujitsu.com
State Under Review
Headers show
Series [meta-python] python3-werkzeug: upgrade 2.1.2 -> 2.2.0 | expand

Commit Message

Mingyu Wang (Fujitsu) July 28, 2022, 2:16 a.m. UTC
Add dependence python3-markupsafe

Changelog:
==========
-  Deprecated get_script_name, get_query_string, peek_path_info, pop_path_info,
   and extract_path_info. #2461
-  Remove previously deprecated code. #2461
-  Add MarkupSafe as a dependency and use it to escape values when rendering
   HTML. #2419
-  Added the werkzeug.debug.preserve_context mechanism for restoring
   context-local data for a request when running code in the debug console.
-  Fix compatibility with Python 3.11 by ensuring that end_lineno and
   end_col_offset are present on AST nodes. #2425
-  Add a new faster matching router based on a state machine. #2433
-  Names within options headers are always converted to lowercase. This matches
   RFC 6266 that the case is not relevant. #2442
-  AnyConverter validates the value passed for it when building URLs. #2388
-  The debugger shows enhanced error locations in tracebacks in Python 3.11. #2407
-  Added Sans-IO is_resource_modified and parse_cookie functions based on WSGI versions.
-  Added Sans-IO get_content_length function. #2415

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../{python3-werkzeug_2.1.2.bb => python3-werkzeug_2.2.0.bb}   | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-werkzeug_2.1.2.bb => python3-werkzeug_2.2.0.bb} (90%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-werkzeug_2.1.2.bb b/meta-python/recipes-devtools/python/python3-werkzeug_2.2.0.bb
similarity index 90%
rename from meta-python/recipes-devtools/python/python3-werkzeug_2.1.2.bb
rename to meta-python/recipes-devtools/python/python3-werkzeug_2.2.0.bb
index 74796d8962..c9e3b0de40 100644
--- a/meta-python/recipes-devtools/python/python3-werkzeug_2.1.2.bb
+++ b/meta-python/recipes-devtools/python/python3-werkzeug_2.2.0.bb
@@ -12,7 +12,7 @@  LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=5dc88300786f1c214c1e9827a5229462"
 
 PYPI_PACKAGE = "Werkzeug"
 
-SRC_URI[sha256sum] = "1ce08e8093ed67d638d63879fd1ba3735817f7a80de3674d293f5984f25fb6e6"
+SRC_URI[sha256sum] = "fe8bcdcef40275ed915fc734c2527a39d705b57a716d4f09e790296abbd16a7f"
 
 inherit pypi setuptools3
 
@@ -36,4 +36,5 @@  RDEPENDS:${PN} += " \
     ${PYTHON_PN}-unixadmin \
     ${PYTHON_PN}-misc \
     ${PYTHON_PN}-profile \
+    ${PYTHON_PN}-markupsafe \
 "