diff mbox series

[meta-oe] googlebenchmark: upgrade 1.6.1 -> 1.7.0

Message ID 1658631009-16775-1-git-send-email-wangmy@fujitsu.com
State New
Headers show
Series [meta-oe] googlebenchmark: upgrade 1.6.1 -> 1.7.0 | expand

Commit Message

Mingyu Wang (Fujitsu) July 24, 2022, 2:50 a.m. UTC
Changelog from 1.6.1 to 1.7.0:
==========
  Stop generating the export header and just check it in
  use target_compile_definitions
  simplified code
  Add docs for ThreadRange.
  Add docs on Memory profiling (#1217).
  Suppress GoogleTest warnings on windows (MSVC) too.
  Expand documentation for unpacking arbitrary arguments.
  Refine docs on changing cpufreq governor
  Refine the User Guide CPU Frequency Scaling section
  Fix some errors in Custom Statistics document demo code.
  Cache PerfCounters instance in PerfCountersMeasurement
  Fix cross compilation for macOS ARM builds in cibuildwheel
  bump numby, as per dependabot
  Use Win32 API only for Win32 apps
  Add mutex when reading counters_ (Fixes #1335)
  Avoid potential truncation issues for the integral type parameterized tests.
  Expose default display reporter creation in public API
  explicitly export public symbols
  Check for macro existence before using
  simplify reference to internal path
  Introduce the possibility to customize the help printer function
  move bzl file out of tools
  resolve case sensitivity issues with WORKSPACE and workspace
  Make generate_export_header.bzl work for Windows.
  @platforms is magical; remove it from WORKSPACE.
  restore BENCHMARK_MAIN()
  Allow setting the default time unit globally
  Add long description and content type for proper PyPI presentation
  Add SetBenchmarkFilter() to set --benchmark_filter flag value in user code
  Add PyPI upload job to wheel building workflow
  Fix float comparaison and add float comparison warning
  Add BENCHMARK_STATIC_DEFINE to the Python bindings' cc_binary local…
  Remove conditional trigger from PyPI upload job
  Change artifact download name to dist to match upload name
  Build //:benchmark as a static library only.
  Fix Bazel build breakage caused by commit 6a894bd.
  [nfc] Reformat doc-string in generate_export_header
  Updates for inclusive language
  getting sysinfo in line with Google style
  Small optimization to counter map management
  Shut down Bazel gracefully and revert wheel build strategy to job matrix
  Fix wheel job name for PyPI uploads
  Filter out benchmarks that start with "DISABLED_"
  Add benchmark labels to the output of the comparison tool
  Enable -Wconversion
  Add installation and build instructions for Python bindings
  fix some typos
  Add option to get the verbosity provided by commandline flag -v (#1330)
  Add support to get clock for new architecture CSKY
  Introduce warmup phase to BenchmarkRunner (#1130)
  Report large numbers in scientific notation in console reporter (#1303)
  add multiple OSes to bazel workflow
  Add possibility to ask for libbenchmark version number (#1004)
  Fix DoNotOptimize() GCC copy overhead (#1340)
  Clarify that the cpu frequency is not used for benchmark timings.
  Revert "Add possibility to ask for libbenchmark version number (#1004)"
  Remove redundant formatting tags
  Fix DoNotOptimize() GCC compile error with some types (#1340)
  Expose default help printer function
  fix sanitizer builds by using clang 13
  Suppress nvcc offsetof warning
  Expose google_benchmark.State for python bindings.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../{googlebenchmark_1.6.1.bb => googlebenchmark_1.7.0.bb}      | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-oe/recipes-support/googlebenchmark/{googlebenchmark_1.6.1.bb => googlebenchmark_1.7.0.bb} (90%)

Comments

Mingyu Wang (Fujitsu) July 27, 2022, 1:34 a.m. UTC | #1
Yes, because the system of host automatically updates and restarts, the time error occurred when the virtual machine was not shut down normally.
The time of the virtual machine and the host has been synchronized now.

  --
Best Regards
---------------------------------------------------
Wang Mingyu
Development Dept.I
Nanjing Fujitsu Nanda Software Tech. Co., Ltd.(FNST) No. 6 Wenzhu Road, Nanjing, 210012, China
TEL: +86+25-86630566-8568
COINS: 79988548
FAX: +86+25-83317685
MAIL: wangmy@fujitsu.com
http://www.fujitsu.com/cn/fnst/

> -----Original Message-----
> From: Khem Raj <raj.khem@gmail.com>
> Sent: Wednesday, July 27, 2022 8:54 AM
> To: Wang, Mingyu/王 鸣瑜 <wangmy@fujitsu.com>;
> openembedded-devel@lists.openembedded.org
> Subject: Re: [oe] [meta-oe] [PATCH] googlebenchmark: upgrade 1.6.1 -> 1.7.0
> 
> Hi Wang
> 
> Its strange that the date on your emails is not correct. This makes it difficult to
> sort patch emails by date. e.g. this message says it was sent on July-23 but it has
> appeared today July-26 here, this is issue with all emailed patched from your
> account. Can you take a look at your machine, it may not have its time set
> correctly.
> 
> On 7/23/22 10:50 PM, wangmy wrote:
> > Changelog from 1.6.1 to 1.7.0:
> > ==========
> >    Stop generating the export header and just check it in
> >    use target_compile_definitions
> >    simplified code
> >    Add docs for ThreadRange.
> >    Add docs on Memory profiling (#1217).
> >    Suppress GoogleTest warnings on windows (MSVC) too.
> >    Expand documentation for unpacking arbitrary arguments.
> >    Refine docs on changing cpufreq governor
> >    Refine the User Guide CPU Frequency Scaling section
> >    Fix some errors in Custom Statistics document demo code.
> >    Cache PerfCounters instance in PerfCountersMeasurement
> >    Fix cross compilation for macOS ARM builds in cibuildwheel
> >    bump numby, as per dependabot
> >    Use Win32 API only for Win32 apps
> >    Add mutex when reading counters_ (Fixes #1335)
> >    Avoid potential truncation issues for the integral type parameterized
> tests.
> >    Expose default display reporter creation in public API
> >    explicitly export public symbols
> >    Check for macro existence before using
> >    simplify reference to internal path
> >    Introduce the possibility to customize the help printer function
> >    move bzl file out of tools
> >    resolve case sensitivity issues with WORKSPACE and workspace
> >    Make generate_export_header.bzl work for Windows.
> >    @platforms is magical; remove it from WORKSPACE.
> >    restore BENCHMARK_MAIN()
> >    Allow setting the default time unit globally
> >    Add long description and content type for proper PyPI presentation
> >    Add SetBenchmarkFilter() to set --benchmark_filter flag value in user code
> >    Add PyPI upload job to wheel building workflow
> >    Fix float comparaison and add float comparison warning
> >    Add BENCHMARK_STATIC_DEFINE to the Python bindings' cc_binary
> local…
> >    Remove conditional trigger from PyPI upload job
> >    Change artifact download name to dist to match upload name
> >    Build //:benchmark as a static library only.
> >    Fix Bazel build breakage caused by commit 6a894bd.
> >    [nfc] Reformat doc-string in generate_export_header
> >    Updates for inclusive language
> >    getting sysinfo in line with Google style
> >    Small optimization to counter map management
> >    Shut down Bazel gracefully and revert wheel build strategy to job matrix
> >    Fix wheel job name for PyPI uploads
> >    Filter out benchmarks that start with "DISABLED_"
> >    Add benchmark labels to the output of the comparison tool
> >    Enable -Wconversion
> >    Add installation and build instructions for Python bindings
> >    fix some typos
> >    Add option to get the verbosity provided by commandline flag -v (#1330)
> >    Add support to get clock for new architecture CSKY
> >    Introduce warmup phase to BenchmarkRunner (#1130)
> >    Report large numbers in scientific notation in console reporter (#1303)
> >    add multiple OSes to bazel workflow
> >    Add possibility to ask for libbenchmark version number (#1004)
> >    Fix DoNotOptimize() GCC copy overhead (#1340)
> >    Clarify that the cpu frequency is not used for benchmark timings.
> >    Revert "Add possibility to ask for libbenchmark version number (#1004)"
> >    Remove redundant formatting tags
> >    Fix DoNotOptimize() GCC compile error with some types (#1340)
> >    Expose default help printer function
> >    fix sanitizer builds by using clang 13
> >    Suppress nvcc offsetof warning
> >    Expose google_benchmark.State for python bindings.
> >
> > Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
> > ---
> >   .../{googlebenchmark_1.6.1.bb => googlebenchmark_1.7.0.bb}      | 2
> +-
> >   1 file changed, 1 insertion(+), 1 deletion(-)
> >   rename
> > meta-oe/recipes-support/googlebenchmark/{googlebenchmark_1.6.1.bb =>
> > googlebenchmark_1.7.0.bb} (90%)
> >
> > diff --git
> > a/meta-oe/recipes-support/googlebenchmark/googlebenchmark_1.6.1.bb
> > b/meta-oe/recipes-support/googlebenchmark/googlebenchmark_1.7.0.bb
> > similarity index 90%
> > rename from
> > meta-oe/recipes-support/googlebenchmark/googlebenchmark_1.6.1.bb
> > rename to
> > meta-oe/recipes-support/googlebenchmark/googlebenchmark_1.7.0.bb
> > index b44d3bee27..7fc6d64728 100644
> > --- a/meta-oe/recipes-support/googlebenchmark/googlebenchmark_1.6.1.bb
> > +++
> b/meta-oe/recipes-support/googlebenchmark/googlebenchmark_1.7.0.bb
> > @@ -5,7 +5,7 @@ LICENSE = "Apache-2.0"
> >   LIC_FILES_CHKSUM =
> "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
> >
> >   SRC_URI =
> "git://github.com/google/benchmark.git;protocol=https;branch=main"
> > -SRCREV = "0d98dba29d66e93259db7daa53a9327df767a415"
> > +SRCREV = "361e8d1cfe0c6c36d30b39f1b61302ece5507320"
> >
> >   S = "${WORKDIR}/git"
> >
> >
> >
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#97998):
> > https://lists.openembedded.org/g/openembedded-devel/message/97998
> > Mute This Topic: https://lists.openembedded.org/mt/92640720/1997914
> > Group Owner: openembedded-devel+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub
> > [raj.khem@gmail.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
diff mbox series

Patch

diff --git a/meta-oe/recipes-support/googlebenchmark/googlebenchmark_1.6.1.bb b/meta-oe/recipes-support/googlebenchmark/googlebenchmark_1.7.0.bb
similarity index 90%
rename from meta-oe/recipes-support/googlebenchmark/googlebenchmark_1.6.1.bb
rename to meta-oe/recipes-support/googlebenchmark/googlebenchmark_1.7.0.bb
index b44d3bee27..7fc6d64728 100644
--- a/meta-oe/recipes-support/googlebenchmark/googlebenchmark_1.6.1.bb
+++ b/meta-oe/recipes-support/googlebenchmark/googlebenchmark_1.7.0.bb
@@ -5,7 +5,7 @@  LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
 
 SRC_URI = "git://github.com/google/benchmark.git;protocol=https;branch=main"
-SRCREV = "0d98dba29d66e93259db7daa53a9327df767a415"
+SRCREV = "361e8d1cfe0c6c36d30b39f1b61302ece5507320"
 
 S = "${WORKDIR}/git"