diff mbox series

[meta-python] python3-ecdsa: upgrade 0.17.0 -> 0.18.0

Message ID 1658453731-24016-1-git-send-email-zhengrq.fnst@fujitsu.com
State New
Headers show
Series [meta-python] python3-ecdsa: upgrade 0.17.0 -> 0.18.0 | expand

Commit Message

zhengrq.fnst@fujitsu.com July 22, 2022, 1:35 a.m. UTC
Changelog:
==========
New features:
------------
    Support for EdDSA (Ed25519, Ed448) signature creation and verification.
    Support for Ed25519 and Ed448 in PKCS#8 and public key files.
    Support for point precomputation for EdDSA.

New API:
------------
    CurveEdTw class to represent the Twisted Edwards curve parameters.
    PointEdwards class to represent points on Twisted Edwards curve and
    provide point arithmetic on it.
    curve_by_name in curves module to get a Curve object by providing curve
    name.

Bug fix:
---------
    Accept private EdDSA keys that include public key in the ASN.1 structure.
    Fix incompatibility with Python 3.3 in handling of memoryviews of empty
    strings.
    Make the VerifyingKey encoded with explicit parameters use the same
    kind of point encoding for public key and curve generator.
    Better handling of malformed curve parameters (as in CVE-2022-0778);
    make python-ecdsa raise MalformedPointError instead of AssertionError.

Doc fix:
-----------
    Publish the documentation on https://ecdsa.readthedocs.io/,
    include explanation of basics of handling of ECC data formats and how to use
    the library for elliptic curve arithmetic.
    Make object names more consistent, make them into hyperlinks on the
    readthedocs documentation.
    Make security note more explicit (Ian Rodney)
    Fix the explicit vs named_curve confusion in VerifyingKey docs.

Maintenance:
------------
    Fix few typos (thanks to Tim Gates and Kian Meng Ang).
    Updated black version; slight changes to formatting
    Include interoperability tests for Ed25519 and Ed448 with OpenSSL.

Signed-off-by: Zheng Ruoqin <zhengrq.fnst@fujitsu.com>
---
 .../python/{python3-ecdsa_0.17.0.bb => python3-ecdsa_0.18.0.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-ecdsa_0.17.0.bb => python3-ecdsa_0.18.0.bb} (80%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-ecdsa_0.17.0.bb b/meta-python/recipes-devtools/python/python3-ecdsa_0.18.0.bb
similarity index 80%
rename from meta-python/recipes-devtools/python/python3-ecdsa_0.17.0.bb
rename to meta-python/recipes-devtools/python/python3-ecdsa_0.18.0.bb
index 177019ccc2..6a399a96fe 100644
--- a/meta-python/recipes-devtools/python/python3-ecdsa_0.17.0.bb
+++ b/meta-python/recipes-devtools/python/python3-ecdsa_0.18.0.bb
@@ -6,7 +6,7 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=66ffc5e30f76cbb5358fe54b645e5a1d"
 DEPENDS += "python3-pip python3-pbr"
 
 PYPI_PACKAGE = "ecdsa"
-SRC_URI[sha256sum] = "b9f500bb439e4153d0330610f5d26baaf18d17b8ced1bc54410d189385ea68aa"
+SRC_URI[sha256sum] = "190348041559e21b22a1d65cee485282ca11a6f81d503fddb84d5017e9ed1e49"
 
 inherit pypi setuptools3 python3native