[meta-python,v3] python3-cppy: upgrade 1.2.0 -> 1.2.1

Message ID 1650281336-16196-1-git-send-email-wangmy@fujitsu.com
State New
Headers show
Series [meta-python,v3] python3-cppy: upgrade 1.2.0 -> 1.2.1 | expand

Commit Message

Mingyu Wang (Fujitsu) April 18, 2022, 11:28 a.m. UTC
Add patch 0001-Fix-build-error-as-following.patch to fix build bug.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../0001-Fix-build-error-as-following.patch   | 28 +++++++++++++++++++
 ...n3-cppy_1.2.0.bb => python3-cppy_1.2.1.bb} |  9 ++++--
 2 files changed, 35 insertions(+), 2 deletions(-)
 create mode 100644 meta-python/recipes-devtools/python/python3-cppy/0001-Fix-build-error-as-following.patch
 rename meta-python/recipes-devtools/python/{python3-cppy_1.2.0.bb => python3-cppy_1.2.1.bb} (55%)

Patch

diff --git a/meta-python/recipes-devtools/python/python3-cppy/0001-Fix-build-error-as-following.patch b/meta-python/recipes-devtools/python/python3-cppy/0001-Fix-build-error-as-following.patch
new file mode 100644
index 0000000000..5a613c827a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cppy/0001-Fix-build-error-as-following.patch
@@ -0,0 +1,28 @@ 
+From a6ba15048bbb660abfa094b581862b4936ac4005 Mon Sep 17 00:00:00 2001
+From: Lei Maohui <leimaohui@fujitsu.com>
+Date: Mon, 18 Apr 2022 12:19:35 +0900
+Subject: [PATCH] Fix build error as following:
+
+flit_core.config.ConfigError: description must be specified under [project] or listed as a dynamic field.
+
+Upstream-Status: Pending
+Signed-off-by: Lei Maohui <leimaohui@fujitsu.com>
+---
+ pyproject.toml | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/pyproject.toml b/pyproject.toml
+index 2d2ac74..66fcee0 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -8,6 +8,7 @@
+ 
+ [project]
+ name = "cppy"
++description = "A small C++ header library"
+ readme = "README.rst"
+ requires-python = ">=3.7"
+ license = {file = "LICENSE"}
+-- 
+2.25.1
+
diff --git a/meta-python/recipes-devtools/python/python3-cppy_1.2.0.bb b/meta-python/recipes-devtools/python/python3-cppy_1.2.1.bb
similarity index 55%
rename from meta-python/recipes-devtools/python/python3-cppy_1.2.0.bb
rename to meta-python/recipes-devtools/python/python3-cppy_1.2.1.bb
index f86f571938..57ef3b2776 100644
--- a/meta-python/recipes-devtools/python/python3-cppy_1.2.0.bb
+++ b/meta-python/recipes-devtools/python/python3-cppy_1.2.1.bb
@@ -3,10 +3,15 @@  HOMEPAGE = "https://cppy.readthedocs.io/en/latest/"
 LICENSE = "BSD-3-Clause"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=0bfb3e39b13587f0028f17baf0e42371"
 
-SRC_URI[sha256sum] = "95e8862e4f826c3f2a6b7b658333b162f80cbe9f943aa0d0a7a6b2ef850aeffc"
+SRC_URI[sha256sum] = "83b43bf17b1085ac15c5debdb42154f138b928234b21447358981f69d0d6fe1b"
 
 RDEPENDS:${PN} += "python3-setuptools python3-distutils"
 
-inherit pypi setuptools3
+inherit pypi python_flit_core 
+
+SRC_URI += " file://0001-Fix-build-error-as-following.patch \
+           "
+
+DEPENDS += "python3-setuptools-native"
 
 BBCLASSEXTEND = "native nativesdk"