[1/5,meta-python] python3-alembic: upgrade 1.7.6 -> 1.7.7

Message ID 1648113480-29846-1-git-send-email-xuhuan.fnst@fujitsu.com
State New
Headers show
Series [1/5,meta-python] python3-alembic: upgrade 1.7.6 -> 1.7.7 | expand

Commit Message

XU Huan March 24, 2022, 9:17 a.m. UTC
From: Xu Huan <xuhuan.fnst@fujitsu.com>

changelog:
===============================================================================
-[bug] [operations]

Fixed issue where using Operations.create_table() in conjunction with a
CheckConstraint that referred to table-bound Column objects rather than string
expressions would be added to the parent table potentially multiple times,
resulting in an incorrect DDL sequence. Pull request courtesy Nicolas CANIART.

-[bug] [environment]

The logging.fileConfig() line in env.py templates, which is used to setup Python
logging for the migration run, is now conditional on Config.config_file_name not
being None. Otherwise, the line is skipped as there is no default logging
configuration present.

-[bug] [mssql]

Fixed bug where an Operations.alter_column() operation would change a “NOT NULL”
column to “NULL” by emitting an ALTER COLUMN statement that did not specify
“NOT NULL”. (In the absence of “NOT NULL” T-SQL was implicitly assuming “NULL”).
An Operations.alter_column() operation that specifies
Operations.alter_column.type should also specify include either
Operations.alter_column.nullable or Operations.alter_column.existing_nullable to
inform Alembic as to whether the emitted DDL should include “NULL” or “NOT NULL”;
a warning is now emitted if this is missing under this scenario.

Signed-off-by: Xu Huan <xuhuan.fnst@fujitsu.com>
---
 .../{python3-alembic_1.7.6.bb => python3-alembic_1.7.7.bb}      | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-alembic_1.7.6.bb => python3-alembic_1.7.7.bb} (81%)

Patch

diff --git a/meta-python/recipes-devtools/python/python3-alembic_1.7.6.bb b/meta-python/recipes-devtools/python/python3-alembic_1.7.7.bb
similarity index 81%
rename from meta-python/recipes-devtools/python/python3-alembic_1.7.6.bb
rename to meta-python/recipes-devtools/python/python3-alembic_1.7.7.bb
index 822b3c02b8..6b7ac4a99c 100644
--- a/meta-python/recipes-devtools/python/python3-alembic_1.7.6.bb
+++ b/meta-python/recipes-devtools/python/python3-alembic_1.7.7.bb
@@ -4,7 +4,7 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=f5a8522010db1a393833988dbe2c7f0b"
 
 inherit pypi setuptools3
 
-SRC_URI[sha256sum] = "6c0c05e9768a896d804387e20b299880fe01bc56484246b0dffe8075d6d3d847"
+SRC_URI[sha256sum] = "4961248173ead7ce8a21efb3de378f13b8398e6630fab0eb258dc74a8af24c58"
 
 PYPI_PACKAGE = "alembic"