[1/3,meta-python] python3-wrapt: upgrade 1.13.3 -> 1.14.0

Message ID 1647524807-17685-1-git-send-email-xuhuan.fnst@fujitsu.com
State Under Review
Headers show
Series [1/3,meta-python] python3-wrapt: upgrade 1.13.3 -> 1.14.0 | expand

Commit Message

XU Huan March 17, 2022, 1:46 p.m. UTC
From: Xu Huan <xuhuan.fnst@fujitsu.com>

changelog:
===============================================================================
-Bugs Fixed

Python 3.11 dropped inspect.formatargspec() which was used in creating
signature changing decorators. Now bundling a version of this function which
uses Parameter and Signature from inspect module when available. The
replacement function is exposed as wrapt.formatargspec() if need it for
your own code.

When using a decorator on a class, isinstance() checks wouldn’t previously
work as expected and you had to manually use Type.__wrapped__ to access the
real type when doing instance checks. The __instancecheck__ hook is now
implemented such that you don’t have to use Type.__wrapped__ instead of Type
as last argument to isinstance().
Eliminated deprecation warnings related to Python module import system, which
would have turned into broken code in Python 3.12. This was used by the post
import hook mechanism.

-New Features

Binary wheels provided on PyPi for aarch64 Linux systems and macOS native
silicon where supported by Python when using pypa/cibuildwheel.

Signed-off-by: Xu Huan <xuhuan.fnst@fujitsu.com>
---
 .../python/{python3-wrapt_1.13.3.bb => python3-wrapt_1.14.0.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-wrapt_1.13.3.bb => python3-wrapt_1.14.0.bb} (81%)

Patch

diff --git a/meta-python/recipes-devtools/python/python3-wrapt_1.13.3.bb b/meta-python/recipes-devtools/python/python3-wrapt_1.14.0.bb
similarity index 81%
rename from meta-python/recipes-devtools/python/python3-wrapt_1.13.3.bb
rename to meta-python/recipes-devtools/python/python3-wrapt_1.14.0.bb
index 05ee4c6356..9dcab8101f 100644
--- a/meta-python/recipes-devtools/python/python3-wrapt_1.13.3.bb
+++ b/meta-python/recipes-devtools/python/python3-wrapt_1.14.0.bb
@@ -4,7 +4,7 @@  LICENSE = "BSD-2-Clause"
 SECTION = "devel/python"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=fdfc019b57affbe1d7a32e3d34e83db4"
 
-SRC_URI[sha256sum] = "1fea9cd438686e6682271d36f3481a9f3636195578bab9ca3382e2f5f01fc185"
+SRC_URI[sha256sum] = "8323a43bd9c91f62bb7d4be74cc9ff10090e7ef820e27bfe8815c57e68261311"
 
 inherit pypi setuptools3