[meta-python] python3-astroid: upgrade 2.10.0 -> 2.11.0

Message ID 1647419779-81651-1-git-send-email-wangmy@fujitsu.com
State Under Review
Headers show
Series [meta-python] python3-astroid: upgrade 2.10.0 -> 2.11.0 | expand

Commit Message

Mingyu Wang (Fujitsu) March 16, 2022, 8:36 a.m. UTC
Changelog:
=========
Add new (optional) doc_node attribute to nodes.Module, nodes.ClassDef,
and nodes.FunctionDef.

Accessing the doc attribute of nodes.Module, nodes.ClassDef, and
nodes.FunctionDef has been deprecated in favour of the doc_node attribute.
Note: doc_node is an (optional) nodes.Const whereas doc was an (optional) str.

Passing the doc argument to the __init__ of nodes.Module, nodes.ClassDef,
and nodes.FunctionDef has been deprecated in favour of the postinit doc_node attribute.
Note: doc_node is an (optional) nodes.Const whereas doc was an (optional) str.

Replace custom cachedproperty with functools.cached_property and deprecate it
for Python 3.8+.

Closes #1410

Set end_lineno and end_col_offset attributes to None for all nodes
with PyPy 3.8. PyPy 3.8 assigns these attributes inconsistently which could lead
to unexpected errors. Overwriting them with None will cause a fallback
to the already supported way of PyPy 3.7.

Add missing shape parameter to numpy zeros_like, ones_like,
and full_like methods.

Closes PyCQA/pylint#5871

Only pin wrapt on the major version.

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../{python3-astroid_2.10.0.bb => python3-astroid_2.11.0.bb}    | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-astroid_2.10.0.bb => python3-astroid_2.11.0.bb} (89%)

Patch

diff --git a/meta-python/recipes-devtools/python/python3-astroid_2.10.0.bb b/meta-python/recipes-devtools/python/python3-astroid_2.11.0.bb
similarity index 89%
rename from meta-python/recipes-devtools/python/python3-astroid_2.10.0.bb
rename to meta-python/recipes-devtools/python/python3-astroid_2.11.0.bb
index fc23f17c6b..1a69be2f98 100644
--- a/meta-python/recipes-devtools/python/python3-astroid_2.10.0.bb
+++ b/meta-python/recipes-devtools/python/python3-astroid_2.11.0.bb
@@ -4,7 +4,7 @@  SECTION = "devel/python"
 LICENSE = "LGPL-2.1-only"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=a70cf540abf41acb644ac3b621b2fad1"
 
-SRC_URI[sha256sum] = "f616b9687a5f4afa673dfd2d684d2b6f38365c8ad7c6f27229dda1ede750c445"
+SRC_URI[sha256sum] = "d56f6a5239981567ceaa3413d4971936c7b4b0c796fcff90c24254dcf8b05b62"
 
 inherit pypi setuptools3