[meta-oe] php: upgrade 8.1.2 -> 8.1.3

Message ID 1645573548-27245-2-git-send-email-wangmy@fujitsu.com
State New
Headers show
Series [meta-oe] php: upgrade 8.1.2 -> 8.1.3 | expand

Commit Message

Mingyu Wang (Fujitsu) Feb. 22, 2022, 11:45 p.m. UTC
Changelog:
=========
Core:
------
Fixed bug #81430 (Attribute instantiation leaves dangling pointer).
Fixed bug #7896 (Environment vars may be mangled on Windows).
Fixed bug #7883 (Segfault when INI file is not readable).

FFI:
-----
Fixed bug #7867 (FFI::cast() from pointer to array is broken).

Filter:
------
Fix #81708: UAF due to php_filter_float() failing for ints. (CVE-2021-21708)

FPM:
-----
Fixed memory leak on invalid port.
Fixed bug #7842 (Invalid OpenMetrics response format returned by FPM status page.

MBString:
--------
Fixed bug #7902 (mb_send_mail may delimit headers with LF only).

MySQLnd:
--------
Fixed bug #7972 (MariaDB version prefix 5.5.5- is not stripped).

pcntl:
------
Fixed pcntl_rfork build for DragonFlyBSD.

Sockets:
-------
Fixed bug #7978 (sockets extension compilation errors).

Standard:
---------
Fixed bug #7899 (Regression in unpack for negative int value).
Fixed bug #7875 (mails are sent even if failure to log throws exception).

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 meta-oe/recipes-devtools/php/{php_8.1.2.bb => php_8.1.3.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-oe/recipes-devtools/php/{php_8.1.2.bb => php_8.1.3.bb} (99%)

Patch

diff --git a/meta-oe/recipes-devtools/php/php_8.1.2.bb b/meta-oe/recipes-devtools/php/php_8.1.3.bb
similarity index 99%
rename from meta-oe/recipes-devtools/php/php_8.1.2.bb
rename to meta-oe/recipes-devtools/php/php_8.1.3.bb
index 038d79783b..bfe4d270d6 100644
--- a/meta-oe/recipes-devtools/php/php_8.1.2.bb
+++ b/meta-oe/recipes-devtools/php/php_8.1.3.bb
@@ -32,7 +32,7 @@  SRC_URI:append:class-target = " \
           "
 
 S = "${WORKDIR}/php-${PV}"
-SRC_URI[sha256sum] = "913dc7dd4388427fa33ea4ac89834e856ff5394f4218eace260a3a279f5b53a9"
+SRC_URI[sha256sum] = "354c4e2c506046eca812d1fc2526884a2f54b5e3d20ef0ede919a69eb232d0be"
 
 inherit autotools pkgconfig python3native gettext