[meta-python] python3-twisted: upgrade 21.7.0 -> 22.1.0

Message ID 1644910647-5613-2-git-send-email-wangmy@fujitsu.com
State New
Headers show
Series [meta-python] python3-twisted: upgrade 21.7.0 -> 22.1.0 | expand

Commit Message

Mingyu Wang (Fujitsu) Feb. 15, 2022, 7:37 a.m. UTC
License-Update: year updated to 2022

Changelog:
=========
Features
--------
-Python 3.10 is now a supported platform (#10224)
-Type annotations have been added to the twisted.python.fakepwd module. (#10287)

Bugfixes
--------
-twisted.internet.defer.inlineCallbacks has an improved type annotation, to
 avoid typing errors when it is used on a function which returns a non-None
 result. (#10231)
-twisted.internet.base.DelayedCall.__repr__ and
 twisted.internet.task.LoopingCall.__repr__ had the changes from #10155
 reverted to accept non-function callables. (#10235)
-Revert the removal of .whl building that was done as part of #10177. (#10236)
-The type annotation of the host parameter to
 twisted.internet.interfaces.IReactorTCP.connectTCP has been corrected from
 bytes to str. (#10251)
-Deprecated twisted.python.threading.ThreadPool.currentThread() in favor of
 threading.current_thread().
-Switched twisted.python.threading.ThreadPool.currentThread() and
 twisted.python.threadable.getThreadID() to use 'threading.current_thread() to
 avoid the deprecation warnings introduced forthreading.currentThread()'
 in Python 3.10. (#10273)

Improved Documentation
----------------------
-twisted.internet.utils.runWithWarningsSupressed behavior of waiting on
 deferreds has been documented. (#10238)
-Sync API docs templates with pydoctor 21.9.0 release, using new theming
 capabilities. (#10267)

Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
---
 .../{python3-twisted_21.7.0.bb => python3-twisted_22.1.0.bb}  | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-twisted_21.7.0.bb => python3-twisted_22.1.0.bb} (98%)

Patch

diff --git a/meta-python/recipes-devtools/python/python3-twisted_21.7.0.bb b/meta-python/recipes-devtools/python/python3-twisted_22.1.0.bb
similarity index 98%
rename from meta-python/recipes-devtools/python/python3-twisted_21.7.0.bb
rename to meta-python/recipes-devtools/python/python3-twisted_22.1.0.bb
index 4e9472793b..8fd7801c35 100644
--- a/meta-python/recipes-devtools/python/python3-twisted_21.7.0.bb
+++ b/meta-python/recipes-devtools/python/python3-twisted_22.1.0.bb
@@ -5,9 +5,9 @@  HOMEPAGE = "http://www.twistedmatrix.com"
 
 #twisted/topfiles/NEWS:655: - Relicensed: Now under the MIT license, rather than LGPL.
 LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=e33c411c0b86b1f3ca299091ed51ca31"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=0f8d67f84b6e178c92d471011b2245fc"
 
-SRC_URI[sha256sum] = "2cd652542463277378b0d349f47c62f20d9306e57d1247baabd6d1d38a109006"
+SRC_URI[sha256sum] = "b7971ec9805b0f80e1dcb1a3721d7bfad636d5f909de687430ce373979d67b61"
 
 PYPI_PACKAGE = "Twisted"