[meta-python] python3-pymongo: upgrade 4.0 -> 4.0.1

Message ID 1641980182-11598-2-git-send-email-xuhuan.fnst@fujitsu.com
State New
Headers show
Series [meta-python] python3-pymongo: upgrade 4.0 -> 4.0.1 | expand

Commit Message

XU Huan Jan. 12, 2022, 9:36 a.m. UTC
From: Xu Huan <xuhuan.fnst@fujitsu.com>

changelog:
===============================================================================
:meth:`pymongo.collection.Collection.update_one`,
:meth:`pymongo.collection.Collection.update_many`,
:meth:`pymongo.collection.Collection.delete_one`,
:meth:`pymongo.collection.Collection.delete_many`,
:meth:`pymongo.collection.Collection.aggregate`,
:meth:`pymongo.collection.Collection.find_one_and_delete`,
:meth:`pymongo.collection.Collection.find_one_and_replace`,
:meth:`pymongo.collection.Collection.find_one_and_update`,
and :meth:`pymongo.collection.Collection.find` all support a new keyword argument
let which is a map of parameter names and values. Parameters can then be
accessed as variables in an aggregate expression context.

:meth:`~pymongo.collection.Collection.aggregate` now supports $merge and $out
executing on secondaries on MongoDB >=5.0. aggregate() now always obeys the
collection's :attr:`read_preference` on MongoDB >= 5.0.

Signed-off-by: Xu Huan <xuhuan.fnst@fujitsu.com>
---
 .../python/{python3-pymongo_4.0.bb => python3-pymongo_4.0.1.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-pymongo_4.0.bb => python3-pymongo_4.0.1.bb} (91%)

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pymongo_4.0.bb b/meta-python/recipes-devtools/python/python3-pymongo_4.0.1.bb
similarity index 91%
rename from meta-python/recipes-devtools/python/python3-pymongo_4.0.bb
rename to meta-python/recipes-devtools/python/python3-pymongo_4.0.1.bb
index ea057c1804..8eb0833fd0 100644
--- a/meta-python/recipes-devtools/python/python3-pymongo_4.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pymongo_4.0.1.bb
@@ -8,7 +8,7 @@  HOMEPAGE = "http://github.com/mongodb/mongo-python-driver"
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
 
-SRC_URI[sha256sum] = "6d158eadba3aaab276a3b188b7f467ab0384b68c1d31cfa87335e52addd9dcb6"
+SRC_URI[sha256sum] = "13d0624c13a91da71fa0d960205d93b3d98344481be865ee7cc238c972d41d73"
 
 inherit pypi setuptools3