diff mbox series

[AUH] python3-greenlet: upgrading to 3.0.1 SUCCEEDED

Message ID 0101018b97fb111b-f95f90ad-af44-44d6-ae1f-392f85e1e8f6-000000@us-west-2.amazonses.com
State New
Headers show
Series [AUH] python3-greenlet: upgrading to 3.0.1 SUCCEEDED | expand

Commit Message

auh@yoctoproject.org Nov. 4, 2023, 1:38 a.m. UTC
Hello,

this email is a notification from the Auto Upgrade Helper
that the automatic attempt to upgrade the recipe *python3-greenlet* to *3.0.1* has Succeeded.

Next steps:
    - apply the patch: git am 0001-python3-greenlet-upgrade-2.0.2-3.0.1.patch
    - check the changes to upstream patches and summarize them in the commit message,
    - compile an image that contains the package
    - perform some basic sanity tests
    - amend the patch and sign it off: git commit -s --reset-author --amend
    - send it to the appropriate mailing list

Alternatively, if you believe the recipe should not be upgraded at this time,
you can fill RECIPE_NO_UPDATE_REASON in respective recipe file so that
automatic upgrades would no longer be attempted.

Please review the attached files for further information and build/update failures.
Any problem please file a bug at https://bugzilla.yoctoproject.org/enter_bug.cgi?product=Automated%20Update%20Handler

Regards,
The Upgrade Helper

-- >8 --
From bb21e6accd81353a3030a924a5c57456d69e5cb1 Mon Sep 17 00:00:00 2001
From: Upgrade Helper <auh@yoctoproject.org>
Date: Fri, 3 Nov 2023 21:36:31 +0000
Subject: [PATCH] python3-greenlet: upgrade 2.0.2 -> 3.0.1

---
 ...ng-register-storage-class-keyword-ev.patch | 247 ------------------
 ...let_2.0.2.bb => python3-greenlet_3.0.1.bb} |   4 +-
 2 files changed, 2 insertions(+), 249 deletions(-)
 delete mode 100644 meta-python/recipes-devtools/python/python3-greenlet/0001-cleanup-Drop-using-register-storage-class-keyword-ev.patch
 rename meta-python/recipes-devtools/python/{python3-greenlet_2.0.2.bb => python3-greenlet_3.0.1.bb} (65%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-greenlet/0001-cleanup-Drop-using-register-storage-class-keyword-ev.patch b/meta-python/recipes-devtools/python/python3-greenlet/0001-cleanup-Drop-using-register-storage-class-keyword-ev.patch
deleted file mode 100644
index 2a6ddd472..000000000
--- a/meta-python/recipes-devtools/python/python3-greenlet/0001-cleanup-Drop-using-register-storage-class-keyword-ev.patch
+++ /dev/null
@@ -1,247 +0,0 @@ 
-From 74d8c5ecdc677a7a412c7f782fe8488a5d987333 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Sun, 5 Feb 2023 19:05:45 -0800
-Subject: [PATCH] cleanup: Drop using 'register' storage class keyword everywhere
-
-This has been dropped in c++17 and newer
-
-Upstream-Status: Submitted [https://github.com/python-greenlet/greenlet/pull/347]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- src/greenlet/platform/switch_alpha_unix.h    | 4 ++--
- src/greenlet/platform/switch_arm32_gcc.h     | 2 +-
- src/greenlet/platform/switch_arm32_ios.h     | 2 +-
- src/greenlet/platform/switch_csky_gcc.h      | 2 +-
- src/greenlet/platform/switch_mips_unix.h     | 4 ++--
- src/greenlet/platform/switch_ppc64_aix.h     | 4 ++--
- src/greenlet/platform/switch_ppc64_linux.h   | 4 ++--
- src/greenlet/platform/switch_ppc_aix.h       | 4 ++--
- src/greenlet/platform/switch_ppc_linux.h     | 4 ++--
- src/greenlet/platform/switch_ppc_macosx.h    | 4 ++--
- src/greenlet/platform/switch_ppc_unix.h      | 4 ++--
- src/greenlet/platform/switch_s390_unix.h     | 4 ++--
- src/greenlet/platform/switch_sparc_sun_gcc.h | 4 ++--
- src/greenlet/platform/switch_x32_unix.h      | 4 ++--
- src/greenlet/platform/switch_x86_unix.h      | 2 +-
- 15 files changed, 26 insertions(+), 26 deletions(-)
-
-diff --git a/src/greenlet/platform/switch_alpha_unix.h b/src/greenlet/platform/switch_alpha_unix.h
-index 216619f..7e07abf 100644
---- a/src/greenlet/platform/switch_alpha_unix.h
-+++ b/src/greenlet/platform/switch_alpha_unix.h
-@@ -9,8 +9,8 @@
- static int
- slp_switch(void)
- {
--  register int ret;
--  register long *stackref, stsizediff;
-+  int ret;
-+  long *stackref, stsizediff;
-   __asm__ volatile ("" : : : REGS_TO_SAVE);
-   __asm__ volatile ("mov $30, %0" : "=r" (stackref) : );
-   {
-diff --git a/src/greenlet/platform/switch_arm32_gcc.h b/src/greenlet/platform/switch_arm32_gcc.h
-index 035d6b9..655003a 100644
---- a/src/greenlet/platform/switch_arm32_gcc.h
-+++ b/src/greenlet/platform/switch_arm32_gcc.h
-@@ -56,7 +56,7 @@ __attribute__((optimize("no-omit-frame-pointer")))
- slp_switch(void)
- {
-         void *fp;
--        register int *stackref, stsizediff;
-+        int *stackref, stsizediff;
-         int result;
-         __asm__ volatile ("" : : : REGS_TO_SAVE);
-         __asm__ volatile ("mov r0," REG_FP "\n\tstr r0,%0" : "=m" (fp) : : "r0");
-diff --git a/src/greenlet/platform/switch_arm32_ios.h b/src/greenlet/platform/switch_arm32_ios.h
-index e993707..9e640e1 100644
---- a/src/greenlet/platform/switch_arm32_ios.h
-+++ b/src/greenlet/platform/switch_arm32_ios.h
-@@ -38,7 +38,7 @@ __attribute__((optimize("no-omit-frame-pointer")))
- slp_switch(void)
- {
-         void *fp;
--        register int *stackref, stsizediff, result;
-+        int *stackref, stsizediff, result;
-         __asm__ volatile ("" : : : REGS_TO_SAVE);
-         __asm__ volatile ("str " REG_FP ",%0" : "=m" (fp));
-         __asm__ ("mov %0," REG_SP : "=r" (stackref));
-diff --git a/src/greenlet/platform/switch_csky_gcc.h b/src/greenlet/platform/switch_csky_gcc.h
-index 7486b94..ac469d3 100644
---- a/src/greenlet/platform/switch_csky_gcc.h
-+++ b/src/greenlet/platform/switch_csky_gcc.h
-@@ -23,7 +23,7 @@ __attribute__((optimize("no-omit-frame-pointer")))
- #endif
- slp_switch(void)
- {
--        register int *stackref, stsizediff;
-+        int *stackref, stsizediff;
-         int result;
- 
-         __asm__ volatile ("" : : : REGS_TO_SAVE);
-diff --git a/src/greenlet/platform/switch_mips_unix.h b/src/greenlet/platform/switch_mips_unix.h
-index 1916b26..b9003e9 100644
---- a/src/greenlet/platform/switch_mips_unix.h
-+++ b/src/greenlet/platform/switch_mips_unix.h
-@@ -19,8 +19,8 @@
- static int
- slp_switch(void)
- {
--    register int err;
--    register int *stackref, stsizediff;
-+    int err;
-+    int *stackref, stsizediff;
- #ifdef __mips64
-     uint64_t gpsave;
- #endif
-diff --git a/src/greenlet/platform/switch_ppc64_aix.h b/src/greenlet/platform/switch_ppc64_aix.h
-index e07b8de..e7e0b87 100644
---- a/src/greenlet/platform/switch_ppc64_aix.h
-+++ b/src/greenlet/platform/switch_ppc64_aix.h
-@@ -74,8 +74,8 @@
- static int
- slp_switch(void)
- {
--    register int err;
--    register long *stackref, stsizediff;
-+    int err;
-+    long *stackref, stsizediff;
-     void * toc;
-     void * r30;
-     __asm__ volatile ("" : : : REGS_TO_SAVE);
-diff --git a/src/greenlet/platform/switch_ppc64_linux.h b/src/greenlet/platform/switch_ppc64_linux.h
-index 88e6847..3c324d0 100644
---- a/src/greenlet/platform/switch_ppc64_linux.h
-+++ b/src/greenlet/platform/switch_ppc64_linux.h
-@@ -76,8 +76,8 @@
- static int
- slp_switch(void)
- {
--    register int err;
--    register long *stackref, stsizediff;
-+    int err;
-+    long *stackref, stsizediff;
-     void * toc;
-     void * r30;
-     __asm__ volatile ("" : : : REGS_TO_SAVE);
-diff --git a/src/greenlet/platform/switch_ppc_aix.h b/src/greenlet/platform/switch_ppc_aix.h
-index c7d476f..6d93c13 100644
---- a/src/greenlet/platform/switch_ppc_aix.h
-+++ b/src/greenlet/platform/switch_ppc_aix.h
-@@ -53,8 +53,8 @@
- static int
- slp_switch(void)
- {
--    register int err;
--    register int *stackref, stsizediff;
-+    int err;
-+    int *stackref, stsizediff;
-     __asm__ volatile ("" : : : REGS_TO_SAVE);
-     __asm__ ("mr %0, 1" : "=r" (stackref) : );
-     {
-diff --git a/src/greenlet/platform/switch_ppc_linux.h b/src/greenlet/platform/switch_ppc_linux.h
-index 0a71255..e83ad70 100644
---- a/src/greenlet/platform/switch_ppc_linux.h
-+++ b/src/greenlet/platform/switch_ppc_linux.h
-@@ -49,8 +49,8 @@
- static int
- slp_switch(void)
- {
--    register int err;
--    register int *stackref, stsizediff;
-+    int err;
-+    int *stackref, stsizediff;
-     __asm__ volatile ("" : : : REGS_TO_SAVE);
-     __asm__ ("mr %0, 1" : "=r" (stackref) : );
-     {
-diff --git a/src/greenlet/platform/switch_ppc_macosx.h b/src/greenlet/platform/switch_ppc_macosx.h
-index 56e573f..d6e5a03 100644
---- a/src/greenlet/platform/switch_ppc_macosx.h
-+++ b/src/greenlet/platform/switch_ppc_macosx.h
-@@ -46,8 +46,8 @@
- static int
- slp_switch(void)
- {
--    register int err;
--    register int *stackref, stsizediff;
-+    int err;
-+    int *stackref, stsizediff;
-     __asm__ volatile ("" : : : REGS_TO_SAVE);
-     __asm__ ("; asm block 2\n\tmr %0, r1" : "=g" (stackref) : );
-     {
-diff --git a/src/greenlet/platform/switch_ppc_unix.h b/src/greenlet/platform/switch_ppc_unix.h
-index 2b3d307..ca590a5 100644
---- a/src/greenlet/platform/switch_ppc_unix.h
-+++ b/src/greenlet/platform/switch_ppc_unix.h
-@@ -47,8 +47,8 @@
- static int
- slp_switch(void)
- {
--    register int err;
--    register int *stackref, stsizediff;
-+    int err;
-+    int *stackref, stsizediff;
-     __asm__ volatile ("" : : : REGS_TO_SAVE);
-     __asm__ ("mr %0, 1" : "=g" (stackref) : );
-     {
-diff --git a/src/greenlet/platform/switch_s390_unix.h b/src/greenlet/platform/switch_s390_unix.h
-index 6641854..9199367 100644
---- a/src/greenlet/platform/switch_s390_unix.h
-+++ b/src/greenlet/platform/switch_s390_unix.h
-@@ -36,8 +36,8 @@
- static int
- slp_switch(void)
- {
--    register int ret;
--    register long *stackref, stsizediff;
-+    int ret;
-+    long *stackref, stsizediff;
-     __asm__ volatile ("" : : : REGS_TO_SAVE);
- #ifdef __s390x__
-     __asm__ volatile ("lgr %0, 15" : "=r" (stackref) : );
-diff --git a/src/greenlet/platform/switch_sparc_sun_gcc.h b/src/greenlet/platform/switch_sparc_sun_gcc.h
-index 652b57f..96990c3 100644
---- a/src/greenlet/platform/switch_sparc_sun_gcc.h
-+++ b/src/greenlet/platform/switch_sparc_sun_gcc.h
-@@ -51,8 +51,8 @@
- static int
- slp_switch(void)
- {
--    register int err;
--    register int *stackref, stsizediff;
-+    int err;
-+    int *stackref, stsizediff;
- 
-     /* Put current stack pointer into stackref.
-      * Register spilling is done in save/restore.
-diff --git a/src/greenlet/platform/switch_x32_unix.h b/src/greenlet/platform/switch_x32_unix.h
-index cb14ec1..893369c 100644
---- a/src/greenlet/platform/switch_x32_unix.h
-+++ b/src/greenlet/platform/switch_x32_unix.h
-@@ -22,8 +22,8 @@ slp_switch(void)
-     void* ebx;
-     unsigned int csr;
-     unsigned short cw;
--    register int err;
--    register int *stackref, stsizediff;
-+    int err;
-+    int *stackref, stsizediff;
-     __asm__ volatile ("" : : : REGS_TO_SAVE);
-     __asm__ volatile ("fstcw %0" : "=m" (cw));
-     __asm__ volatile ("stmxcsr %0" : "=m" (csr));
-diff --git a/src/greenlet/platform/switch_x86_unix.h b/src/greenlet/platform/switch_x86_unix.h
-index 3a95186..493fa6b 100644
---- a/src/greenlet/platform/switch_x86_unix.h
-+++ b/src/greenlet/platform/switch_x86_unix.h
-@@ -51,7 +51,7 @@ slp_switch(void)
- #endif
-     void *ebp, *ebx;
-     unsigned short cw;
--    register int *stackref, stsizediff;
-+    int *stackref, stsizediff;
-     __asm__ volatile ("" : : : "esi", "edi");
-     __asm__ volatile ("fstcw %0" : "=m" (cw));
-     __asm__ volatile ("movl %%ebp, %0" : "=m" (ebp));
--- 
-2.39.1
-
diff --git a/meta-python/recipes-devtools/python/python3-greenlet_2.0.2.bb b/meta-python/recipes-devtools/python/python3-greenlet_3.0.1.bb
similarity index 65%
rename from meta-python/recipes-devtools/python/python3-greenlet_2.0.2.bb
rename to meta-python/recipes-devtools/python/python3-greenlet_3.0.1.bb
index a2e036a89..fbabf12a3 100644
--- a/meta-python/recipes-devtools/python/python3-greenlet_2.0.2.bb
+++ b/meta-python/recipes-devtools/python/python3-greenlet_3.0.1.bb
@@ -4,7 +4,7 @@  LICENSE = "MIT & PSF-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=e95668d68e4329085c7ab3535e6a7aee \
                     file://LICENSE.PSF;md5=c106931d9429eda0492617f037b8f69a"
 
-SRC_URI += "file://0001-cleanup-Drop-using-register-storage-class-keyword-ev.patch"
-SRC_URI[sha256sum] = "e7c8dc13af7db097bed64a051d2dd49e9f0af495c26995c00a9ee842690d34c0"
+SRC_URI += "${PYPI_SRC_URI}"
+SRC_URI[sha256sum] = "816bd9488a94cba78d93e1abb58000e8266fa9cc2aa9ccdd6eb0696acb24005b"
 
 inherit pypi setuptools3