diff mbox series

[2/6] linux-yocto/6.6: config: x86 tidy & consolidation

Message ID ea05be7021e1fff79a32f994e03bb995cb3bca16.1708986570.git.bruce.ashfield@gmail.com
State Accepted, archived
Commit e8ffc63f3ed61cc31c3077741f3f96dae9baa3fb
Headers show
Series [1/6] linux-yocto/6.6: enable squashfs for selftests | expand

Commit Message

Bruce Ashfield Feb. 26, 2024, 10:34 p.m. UTC
From: Bruce Ashfield <bruce.ashfield@gmail.com>

Integrating the following commit(s) to linux-yocto/.:

1/3 [
    Author: Paul Gortmaker
    Email: paul.gortmaker@windriver.com
    Subject: BSP: remove from all - latencytop feature inclusion
    Date: Thu, 30 Nov 2023 14:07:48 -0500

    Consider this 5+ year old commit

        commit bcbc7bbc4fb967d8d4ae6333f71b73491a80b94e
        Author: Alexander Kanavin <alexander.kanavin@linux.intel.com>
        Date:   Thu Mar 1 16:00:41 2018 +0200

        latencytop: remove recipe

        Last commit and release were in 2009; website is down; it's a dead project.

        (From OE-Core rev: 36aae56e7f86a4d5ce93e4528e7dcc42f60c705e)

        Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
        Signed-off-by: Ross Burton <ross.burton@intel.com>
        Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>

    Given that, it seems sensible to drop it from default inclusion across
    the BSPs.  I've left the feature itself, so anyone who still cares can
    easily manually add it still.

    Signed-off-by: Paul Gortmaker <paul.gortmaker@windriver.com>
    Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
]

2/3 [
    Author: Paul Gortmaker
    Email: paul.gortmaker@windriver.com
    Subject: x86-64: separate out the NUMA features to our existing NUMA scc/cfg
    Date: Thu, 30 Nov 2023 14:07:45 -0500

    A user reported getting NUMA warnings like the ones reported here:

    https://www.suse.com/support/kb/doc/?id=000021040

    "Fail to get numa node for CPU:0 bus:0 dev:0 fn:1"

    ...and repeated for every core on the platform.  Distracting.

    When I asked if it was a crazy big server system with multiple CPU
    sockets and localized RAM near each socket - the answer was "no".

    Turns out they didn't choose NUMA support - rather we did it for them.

    Yocto has been and still remains more "embedded leaning".  That is not
    to say we can't support NUMA.  We just shouldn't be enabling it by
    default in the base x86-64 config fragment that everyone uses.

    Move the two NUMA settings that were not in our existing numa.cfg
    feature out of the BSP and into the feature.

    Signed-off-by: Paul Gortmaker <paul.gortmaker@windriver.com>
    Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
]

3/3 [
    Author: Paul Gortmaker
    Email: paul.gortmaker@windriver.com
    Subject: x86-64: consolidate crypto options
    Date: Thu, 30 Nov 2023 14:07:44 -0500

    No functional change - just makes further reorganizations and
    refactoring more easy to review/parse.

    Signed-off-by: Paul Gortmaker <paul.gortmaker@windriver.com>
    Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
]

Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
---
 meta/recipes-kernel/linux/linux-yocto-rt_6.6.bb   | 2 +-
 meta/recipes-kernel/linux/linux-yocto-tiny_6.6.bb | 2 +-
 meta/recipes-kernel/linux/linux-yocto_6.6.bb      | 2 +-
 3 files changed, 3 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_6.6.bb b/meta/recipes-kernel/linux/linux-yocto-rt_6.6.bb
index ab28df64cd..3b85917506 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_6.6.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_6.6.bb
@@ -15,7 +15,7 @@  python () {
 }
 
 SRCREV_machine ?= "f0a5daf40acf2b457445f9b4f97f9eb2a3d1508a"
-SRCREV_meta ?= "7fa1deab7b048f2b8c5cad8268e48419e00b92fb"
+SRCREV_meta ?= "1a7881cb61f28deae2a90a93648a76fd4e1b0cc2"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine;protocol=https \
            git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-6.6;destsuffix=${KMETA};protocol=https"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_6.6.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_6.6.bb
index 7ac6987582..a2234c4f57 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_6.6.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_6.6.bb
@@ -18,7 +18,7 @@  KMETA = "kernel-meta"
 KCONF_BSP_AUDIT_LEVEL = "2"
 
 SRCREV_machine ?= "cdd0ebde3e0d20f0524b1328b9ea2d23e82dc629"
-SRCREV_meta ?= "7fa1deab7b048f2b8c5cad8268e48419e00b92fb"
+SRCREV_meta ?= "1a7881cb61f28deae2a90a93648a76fd4e1b0cc2"
 
 PV = "${LINUX_VERSION}+git"
 
diff --git a/meta/recipes-kernel/linux/linux-yocto_6.6.bb b/meta/recipes-kernel/linux/linux-yocto_6.6.bb
index 2b93f5d185..141e1e4529 100644
--- a/meta/recipes-kernel/linux/linux-yocto_6.6.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_6.6.bb
@@ -29,7 +29,7 @@  SRCREV_machine:qemux86 ?= "cdd0ebde3e0d20f0524b1328b9ea2d23e82dc629"
 SRCREV_machine:qemux86-64 ?= "cdd0ebde3e0d20f0524b1328b9ea2d23e82dc629"
 SRCREV_machine:qemumips64 ?= "7c478488b642339d97ac55fd8b1acfd086e95c5c"
 SRCREV_machine ?= "cdd0ebde3e0d20f0524b1328b9ea2d23e82dc629"
-SRCREV_meta ?= "7fa1deab7b048f2b8c5cad8268e48419e00b92fb"
+SRCREV_meta ?= "1a7881cb61f28deae2a90a93648a76fd4e1b0cc2"
 
 # set your preferred provider of linux-yocto to 'linux-yocto-upstream', and you'll
 # get the <version>/base branch, which is pure upstream -stable, and the same