diff mbox series

[04/14] python3-poetry-core: upgrade 1.4.0 -> 1.5.0

Message ID daa8c442de92995ef7bd3d831a2cdff060abeaf2.1675446372.git.tim.orling@konsulko.com
State Accepted, archived
Commit 32921155acf776c91ee2fb002660b419512f0932
Headers show
Series [01/14] libtest-needs-perl: upgrade 0.002009 -> 0.002010 | expand

Commit Message

Tim Orling Feb. 3, 2023, 5:50 p.m. UTC
* Drop deterministic.patch; merged https://github.com/python-poetry/poetry-core/pull/545
* Drop vendored pyparsing LICENSE; no longer vendored

https://github.com/python-poetry/poetry-core/blob/main/CHANGELOG.md#150---2023-01-27

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
---
 .../python3-poetry-core/deterministic.patch   | 23 -------------------
 ..._1.4.0.bb => python3-poetry-core_1.5.0.bb} |  5 +---
 2 files changed, 1 insertion(+), 27 deletions(-)
 delete mode 100644 meta/recipes-devtools/python/python3-poetry-core/deterministic.patch
 rename meta/recipes-devtools/python/{python3-poetry-core_1.4.0.bb => python3-poetry-core_1.5.0.bb} (89%)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-poetry-core/deterministic.patch b/meta/recipes-devtools/python/python3-poetry-core/deterministic.patch
deleted file mode 100644
index 402ee530944..00000000000
--- a/meta/recipes-devtools/python/python3-poetry-core/deterministic.patch
+++ /dev/null
@@ -1,23 +0,0 @@ 
-builders/wheel: Ensure dist-info is written determinisically
-
-glob() returns values in "on disk" order. To make the RECORD file
-deterministic and consistent between builds we need to sort the
-data before adding to the records list.
-
-Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-
-Upstream-Status: Submitted [https://github.com/python-poetry/poetry-core/pull/545]
-
-Index: builders/wheel.py
-===================================================================
---- a/src/poetry/core/masonry/builders/wheel.py
-+++ b/src/poetry/core/masonry/builders/wheel.py
-@@ -294,7 +294,7 @@ class WheelBuilder(Builder):
- 
-     def _copy_dist_info(self, wheel: zipfile.ZipFile, source: Path) -> None:
-         dist_info = Path(self.dist_info)
--        for file in source.glob("**/*"):
-+        for file in sorted(source.glob("**/*") ):
-             if not file.is_file():
-                 continue
- 
diff --git a/meta/recipes-devtools/python/python3-poetry-core_1.4.0.bb b/meta/recipes-devtools/python/python3-poetry-core_1.5.0.bb
similarity index 89%
rename from meta/recipes-devtools/python/python3-poetry-core_1.4.0.bb
rename to meta/recipes-devtools/python/python3-poetry-core_1.5.0.bb
index 8a950220125..03db426b39a 100644
--- a/meta/recipes-devtools/python/python3-poetry-core_1.4.0.bb
+++ b/meta/recipes-devtools/python/python3-poetry-core_1.5.0.bb
@@ -14,20 +14,17 @@  LIC_FILES_CHKSUM = "\
     file://src/poetry/core/_vendor/packaging/LICENSE;md5=faadaedca9251a90b205c9167578ce91 \
     file://src/poetry/core/_vendor/packaging/LICENSE.APACHE;md5=2ee41112a44fe7014dce33e26468ba93 \
     file://src/poetry/core/_vendor/packaging/LICENSE.BSD;md5=7bef9bf4a8e4263634d0597e7ba100b8 \
-    file://src/poetry/core/_vendor/pyparsing/LICENSE;md5=657a566233888513e1f07ba13e2f47f1 \
     file://src/poetry/core/_vendor/pyrsistent/LICENSE.mit;md5=b695eb9c6e7a6fb1b1bc2d193c42776e \
     file://src/poetry/core/_vendor/tomlkit/LICENSE;md5=31aac0dbc1babd278d5386dadb7f8e82 \
     file://src/poetry/core/_vendor/typing_extensions.LICENSE;md5=f16b323917992e0f8a6f0071bc9913e2 \
 "
 
-SRC_URI[sha256sum] = "514bd33c30e0bf56b0ed44ee15e120d7e47b61ad908b2b1011da68c48a84ada9"
+SRC_URI[sha256sum] = "253521bb7104e1df81f64d7b49ea1825057c91fa156d7d0bd752fefdad6f8c7a"
 
 inherit python_poetry_core pypi
 PYPI_ARCHIVE_NAME = "poetry_core-${PV}.${PYPI_PACKAGE_EXT}"
 S = "${WORKDIR}/poetry_core-${PV}"
 
-SRC_URI += "file://deterministic.patch"
-
 RDEPENDS:${PN}:append:class-target = "\
     python3-compression \
     python3-core \