[11/20] python: import pyrsistent from meta-python

Message ID bc9fecb4605b7ed14d931d179854fc94ada18d8c.1637788184.git.bruce.ashfield@gmail.com
State Accepted, archived
Commit e25d4417bc4ca01474c74dc5bd38594bcfbe6639
Headers show
Series [01/20] linux-yocto-dev: bump to v5.16+ | expand

Commit Message

Bruce Ashfield Nov. 24, 2021, 9:14 p.m. UTC
From: Bruce Ashfield <bruce.ashfield@gmail.com>

pyrsistent is a dependency of python3-jsonschema, which is being
imported to support kernel device tree validation.

Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
---
 .../python/python3-pyrsistent_0.18.0.bb            | 14 ++++++++++++++
 1 file changed, 14 insertions(+)
 create mode 100644 meta/recipes-devtools/python/python3-pyrsistent_0.18.0.bb

Patch

diff --git a/meta/recipes-devtools/python/python3-pyrsistent_0.18.0.bb b/meta/recipes-devtools/python/python3-pyrsistent_0.18.0.bb
new file mode 100644
index 0000000000..0b4d2564f6
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pyrsistent_0.18.0.bb
@@ -0,0 +1,14 @@ 
+SUMMARY = "Persistent/Immutable/Functional data structures for Python"
+HOMEPAGE = "https://github.com/tobgu/pyrsistent"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.mit;md5=a4b94c2b800b582a8d3925a9939cbf44"
+
+SRC_URI[sha256sum] = "773c781216f8c2900b42a7b638d5b517bb134ae1acbebe4d1e8f1f41ea60eb4b"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+    ${PYTHON_PN}-numbers \
+"
+
+BBCLASSEXTEND = "native nativesdk"