diff mbox series

[3/5] libtest-fatal-perl: add recipe for 0.016

Message ID 74ae6498d65b11537ea8547d1a5206d2c6aec78a.1668793524.git.tim.orling@konsulko.com
State Accepted, archived
Commit 285643275ef0ac04bdc3ce500a79f49629e7ebba
Headers show
Series [1/5] mirrors.bbclass: update CPAN_MIRROR | expand

Commit Message

Tim Orling Nov. 18, 2022, 5:52 p.m. UTC
Test::Fatal - incredibly simple helpers for testing code with exceptions

https://metacpan.org/release/RJBS/Test-Fatal-0.016

* Dependency for liburi-perl ptest.
* Add self as maintainer
* Add to ptest-packages.inc (fast)

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
---
 meta/conf/distro/include/maintainers.inc      |  1 +
 .../distro/include/ptest-packagelists.inc     |  1 +
 .../perl/libtest-fatal-perl_0.016.bb          | 36 +++++++++++++++++++
 3 files changed, 38 insertions(+)
 create mode 100644 meta/recipes-devtools/perl/libtest-fatal-perl_0.016.bb
diff mbox series

Patch

diff --git a/meta/conf/distro/include/maintainers.inc b/meta/conf/distro/include/maintainers.inc
index 141578a7a99..42e705bda95 100644
--- a/meta/conf/distro/include/maintainers.inc
+++ b/meta/conf/distro/include/maintainers.inc
@@ -389,6 +389,7 @@  RECIPE_MAINTAINER:pn-libsoup-2.4 = "Anuj Mittal <anuj.mittal@intel.com>"
 RECIPE_MAINTAINER:pn-libssh2 = "Unassigned <unassigned@yoctoproject.org>"
 RECIPE_MAINTAINER:pn-libssp-nonshared = "Khem Raj <raj.khem@gmail.com>"
 RECIPE_MAINTAINER:pn-libtasn1 = "Anuj Mittal <anuj.mittal@intel.com>"
+RECIPE_MAINTAINER:pn-libtest-fatal-perl = "Tim Orling <tim.orling@konsulko.com>"
 RECIPE_MAINTAINER:pn-libtest-needs-perl = "Tim Orling <tim.orling@konsulko.com>"
 RECIPE_MAINTAINER:pn-libtheora = "Alexander Kanavin <alex.kanavin@gmail.com>"
 RECIPE_MAINTAINER:pn-libtimedate-perl = "Tim Orling <tim.orling@konsulko.com>"
diff --git a/meta/conf/distro/include/ptest-packagelists.inc b/meta/conf/distro/include/ptest-packagelists.inc
index b0925e13dd0..983f1dd72a5 100644
--- a/meta/conf/distro/include/ptest-packagelists.inc
+++ b/meta/conf/distro/include/ptest-packagelists.inc
@@ -33,6 +33,7 @@  PTESTS_FAST = "\
     libpcre-ptest \
     libssh2-ptest \
     libtimedate-perl-ptest \
+    libtest-fatal-perl-ptest \
     libtest-needs-perl-ptest \
     libtry-tiny-perl-ptest \
     liburi-perl-ptest \
diff --git a/meta/recipes-devtools/perl/libtest-fatal-perl_0.016.bb b/meta/recipes-devtools/perl/libtest-fatal-perl_0.016.bb
new file mode 100644
index 00000000000..6d36c94eeb5
--- /dev/null
+++ b/meta/recipes-devtools/perl/libtest-fatal-perl_0.016.bb
@@ -0,0 +1,36 @@ 
+SUMMARY = "Incredibly simple helpers for testing code with exceptions"
+DESCRIPTION = "Test::Fatal is an alternative to the popular Test::Exception.\
+It does much less, but should allow greater flexibility in testing \
+exception-throwing code with about the same amount of typing."
+HOMEPAGE = "https://github.com/rjbs/Test-Fatal"
+BUGTRACKER = "https://github.com/rjbs/Test-Fatal/issues"
+SECTION = "libs"
+LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=f7c73bf24be1bc7759bde9c15000db6c"
+
+SRC_URI = "${CPAN_MIRROR}/authors/id/R/RJ/RJBS/Test-Fatal-${PV}.tar.gz"
+
+SRC_URI[sha256sum] = "7283d430f2ba2030b8cd979ae3039d3f1b2ec3dde1a11ca6ae09f992a66f788f"
+
+S = "${WORKDIR}/Test-Fatal-${PV}"
+
+inherit cpan ptest-perl
+
+RDEPENDS:${PN} += "\
+    libtry-tiny-perl \
+    perl-module-carp \
+    perl-module-exporter \
+    perl-module-test-builder \
+"
+
+RDEPENDS:${PN}-ptest += "\
+    perl-module-extutils-makemaker \
+    perl-module-extutils-mm-unix \
+    perl-module-file-spec \
+    perl-module-overload \
+    perl-module-test-builder-tester \
+    perl-module-test-more \
+"
+
+BBCLASSEXTEND = "native nativesdk"