[kirkstone,02/20] perl: Add dependency on make-native to avoid race issues

Message ID 6b1bc1366bf88ec3b77fe9db44813c4dfd545a7d.1655129917.git.steve@sakoman.com
State Accepted, archived
Commit 6b1bc1366bf88ec3b77fe9db44813c4dfd545a7d
Headers show
Series [kirkstone,01/20] sanity: Switch to make 4.0 as a minimum version | expand

Commit Message

Steve Sakoman June 13, 2022, 2:21 p.m. UTC
From: Richard Purdie <richard.purdie@linuxfoundation.org>

Make 4.1 has race issues with double colon usage in makefiles which are common
in MakeMaker generated code in perl. Add a dependency on make-native to avoid
this as it is relaitvely low overhead.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit 692b7c518637c77804caf7b3cfc60a83afa2e4f4)
Signed-off-by: Steve Sakoman <steve@sakoman.com>
---
 meta/recipes-devtools/perl/perl_5.34.1.bb | 2 ++
 1 file changed, 2 insertions(+)

Patch

diff --git a/meta/recipes-devtools/perl/perl_5.34.1.bb b/meta/recipes-devtools/perl/perl_5.34.1.bb
index 4b9d2e2c50..42bcb8b1bc 100644
--- a/meta/recipes-devtools/perl/perl_5.34.1.bb
+++ b/meta/recipes-devtools/perl/perl_5.34.1.bb
@@ -33,6 +33,8 @@  S = "${WORKDIR}/perl-${PV}"
 inherit upstream-version-is-even update-alternatives
 
 DEPENDS += "perlcross-native zlib virtual/crypt"
+# make 4.1 has race issues with the double-colon usage of MakeMaker, see #14096
+DEPENDS += "make-native"
 
 PERL_LIB_VER = "${@'.'.join(d.getVar('PV').split('.')[0:2])}.0"