diff mbox series

[mickledore,02/30] gawk: upgrade 5.2.1 -> 5.2.2

Message ID 3ace3af1e57b701308ab397c6ac45a6fa703ed40.1688484463.git.steve@sakoman.com
State New
Headers show
Series [mickledore,01/30] perl: Fix CVE-2023-31484 & CVE-2023-31486 | expand

Commit Message

Steve Sakoman July 4, 2023, 3:29 p.m. UTC
From: Alexander Kanavin <alex.kanavin@gmail.com>

This is a bug fix release.

Changes from 5.2.1 to 5.2.2
---------------------------

1. Infrastructure upgrades: makeinfo 7.0.1 must be used to format
   the manual.  As a result, the manual can also now be formatted
   with LaTeX by running it through `makeinfo --latex'.

2. Gawk no longer builds an x86_64 executable on M1 macOS systems.
   This means that PMA is unavailable on those systems.

3. Gawk will now diagnose if a heap file was created with a different
   setting of -M/--bignum than in the current invocation and exit with
   a fatal message if so.

4. Gawk no longer "leaks" its free list of NODEs in the heap file, resulting
   in much more efficient usage of persistent storage.

5. PROCINFO["pma"] exists if the PMA allocator is compiled into gawk.
   Its value is the PMA version.

6. The time extension is no longer deprecated. The strptime() function
   from gawkextlib's timex extension has been added to it.

7. Better information is passed to input parsers for when they want to
   decide whether or not to take control of a file. In particular, the
   readdir extension is simplified for Windows because of this.

8. The various PNG files are now installed for Info and HTML. The
   images files now have gawk_ prefixed names to avoid any conflicts
   with other installed PNG file names.

9. As usual, there have been several minor code cleanups and bug fixes.
   See the ChangeLog for details.

Signed-off-by: Alexander Kanavin <alex@linutronix.de>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit 8504a35f1fe222d256241ff00c05b63e24e9adcb)
Signed-off-by: Steve Sakoman <steve@sakoman.com>
---
 meta/recipes-extended/gawk/{gawk_5.2.1.bb => gawk_5.2.2.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta/recipes-extended/gawk/{gawk_5.2.1.bb => gawk_5.2.2.bb} (97%)
diff mbox series

Patch

diff --git a/meta/recipes-extended/gawk/gawk_5.2.1.bb b/meta/recipes-extended/gawk/gawk_5.2.2.bb
similarity index 97%
rename from meta/recipes-extended/gawk/gawk_5.2.1.bb
rename to meta/recipes-extended/gawk/gawk_5.2.2.bb
index 768c8eb364..3c18b6911a 100644
--- a/meta/recipes-extended/gawk/gawk_5.2.1.bb
+++ b/meta/recipes-extended/gawk/gawk_5.2.2.bb
@@ -19,7 +19,7 @@  SRC_URI = "${GNU_MIRROR}/gawk/gawk-${PV}.tar.gz \
            file://run-ptest \
            "
 
-SRC_URI[sha256sum] = "529e7c8c6acf21ff3a6183f4d763c632810908989c24675c77995d51ac37b79c"
+SRC_URI[sha256sum] = "945aef7ccff101f20b22a10802bc005e994ab2b8ea3e724cc1a197c62f41f650"
 
 inherit autotools gettext texinfo update-alternatives