[v2,01/32] python3-wheel: move 0.37.0 from meta-python

Message ID 2c82b18cfcc34dce08fa4600baa2bbdc046a0350.1645478020.git.tim.orling@konsulko.com
State New
Headers show
Series [v2,01/32] python3-wheel: move 0.37.0 from meta-python | expand

Commit Message

Tim Orling Feb. 21, 2022, 9:23 p.m. UTC
This is one of the "new build tools" which are part of pypa (Python
Packaging Authority) toolchain.

Wheels are the official delivery mechanism for Python packages, replacing
the now deprecated Eggs (egg-info).

[YOCTO #14638]

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
---
 meta/conf/distro/include/maintainers.inc             |  1 +
 meta/recipes-devtools/python/python3-wheel_0.37.1.bb | 12 ++++++++++++
 2 files changed, 13 insertions(+)
 create mode 100644 meta/recipes-devtools/python/python3-wheel_0.37.1.bb

Comments

Khem Raj Feb. 23, 2022, 4:01 p.m. UTC | #1
this series is breaking things quite a bit in rest of world.

https://errors.yoctoproject.org/Errors/Build/141298/

On Mon, Feb 21, 2022 at 1:24 PM Tim Orling <ticotimo@gmail.com> wrote:
>
> This is one of the "new build tools" which are part of pypa (Python
> Packaging Authority) toolchain.
>
> Wheels are the official delivery mechanism for Python packages, replacing
> the now deprecated Eggs (egg-info).
>
> [YOCTO #14638]
>
> Signed-off-by: Tim Orling <tim.orling@konsulko.com>
> ---
>  meta/conf/distro/include/maintainers.inc             |  1 +
>  meta/recipes-devtools/python/python3-wheel_0.37.1.bb | 12 ++++++++++++
>  2 files changed, 13 insertions(+)
>  create mode 100644 meta/recipes-devtools/python/python3-wheel_0.37.1.bb
>
> diff --git a/meta/conf/distro/include/maintainers.inc b/meta/conf/distro/include/maintainers.inc
> index 740e5fe55c4..72cd0125814 100644
> --- a/meta/conf/distro/include/maintainers.inc
> +++ b/meta/conf/distro/include/maintainers.inc
> @@ -651,6 +651,7 @@ RECIPE_MAINTAINER:pn-python3-typogrify = "Alexander Kanavin <alex.kanavin@gmail.
>  RECIPE_MAINTAINER:pn-python3-vcversioner = "Bruce Ashfield <bruce.ashfield@gmail.com>"
>  RECIPE_MAINTAINER:pn-python3-wcwidth = "Tim Orling <tim.orling@konsulko.com>"
>  RECIPE_MAINTAINER:pn-python3-webcolors = "Bruce Ashfield <bruce.ashfield@gmail.com>"
> +RECIPE_MAINTAINER:pn-python3-wheel = "Tim Orling <tim.orling@konsulko.com>"
>  RECIPE_MAINTAINER:pn-python3-zipp = "Tim Orling <tim.orling@konsulko.com>"
>  RECIPE_MAINTAINER:pn-qemu = "Richard Purdie <richard.purdie@linuxfoundation.org>"
>  RECIPE_MAINTAINER:pn-qemu-helper-native = "Richard Purdie <richard.purdie@linuxfoundation.org>"
> diff --git a/meta/recipes-devtools/python/python3-wheel_0.37.1.bb b/meta/recipes-devtools/python/python3-wheel_0.37.1.bb
> new file mode 100644
> index 00000000000..6c7a31db9e7
> --- /dev/null
> +++ b/meta/recipes-devtools/python/python3-wheel_0.37.1.bb
> @@ -0,0 +1,12 @@
> +SUMMARY = "The official binary distribution format for Python "
> +HOMEPAGE = "https://github.com/pypa/wheel"
> +SECTION = "devel/python"
> +LICENSE = "MIT"
> +LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=10;endline=10;md5=8227180126797a0148f94f483f3e1489"
> +
> +SRC_URI[sha256sum] = "e9a504e793efbca1b8e0e9cb979a249cf4a0a7b5b8c9e8b65a5e39d49529c1c4"
> +
> +inherit pypi setuptools3
> +
> +BBCLASSEXTEND = "native"
> +
> --
> 2.30.2
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#162077): https://lists.openembedded.org/g/openembedded-core/message/162077
> Mute This Topic: https://lists.openembedded.org/mt/89304009/1997914
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Tim Orling Feb. 23, 2022, 5:01 p.m. UTC | #2
On Wed, Feb 23, 2022 at 8:01 AM Khem Raj <raj.khem@gmail.com> wrote:

> this series is breaking things quite a bit in rest of world.
>
> https://errors.yoctoproject.org/Errors/Build/141298/


I understand, but we do need to be able to modernize. And getting oe-core
stable is currently consuming all bandwidth.

Most of the failures will be because the wheel has a name like
setuptools_rust*.whl but PYPI_PACKAGE = 'setuptools-rust'
The fix is to set PIP_INSTALL_PACKAGE = "setuptools_rust"


>
>
On Mon, Feb 21, 2022 at 1:24 PM Tim Orling <ticotimo@gmail.com> wrote:
> >
> > This is one of the "new build tools" which are part of pypa (Python
> > Packaging Authority) toolchain.
> >
> > Wheels are the official delivery mechanism for Python packages, replacing
> > the now deprecated Eggs (egg-info).
> >
> > [YOCTO #14638]
> >
> > Signed-off-by: Tim Orling <tim.orling@konsulko.com>
> > ---
> >  meta/conf/distro/include/maintainers.inc             |  1 +
> >  meta/recipes-devtools/python/python3-wheel_0.37.1.bb | 12 ++++++++++++
> >  2 files changed, 13 insertions(+)
> >  create mode 100644 meta/recipes-devtools/python/python3-wheel_0.37.1.bb
> >
> > diff --git a/meta/conf/distro/include/maintainers.inc
> b/meta/conf/distro/include/maintainers.inc
> > index 740e5fe55c4..72cd0125814 100644
> > --- a/meta/conf/distro/include/maintainers.inc
> > +++ b/meta/conf/distro/include/maintainers.inc
> > @@ -651,6 +651,7 @@ RECIPE_MAINTAINER:pn-python3-typogrify = "Alexander
> Kanavin <alex.kanavin@gmail.
> >  RECIPE_MAINTAINER:pn-python3-vcversioner = "Bruce Ashfield <
> bruce.ashfield@gmail.com>"
> >  RECIPE_MAINTAINER:pn-python3-wcwidth = "Tim Orling <
> tim.orling@konsulko.com>"
> >  RECIPE_MAINTAINER:pn-python3-webcolors = "Bruce Ashfield <
> bruce.ashfield@gmail.com>"
> > +RECIPE_MAINTAINER:pn-python3-wheel = "Tim Orling <
> tim.orling@konsulko.com>"
> >  RECIPE_MAINTAINER:pn-python3-zipp = "Tim Orling <
> tim.orling@konsulko.com>"
> >  RECIPE_MAINTAINER:pn-qemu = "Richard Purdie <
> richard.purdie@linuxfoundation.org>"
> >  RECIPE_MAINTAINER:pn-qemu-helper-native = "Richard Purdie <
> richard.purdie@linuxfoundation.org>"
> > diff --git a/meta/recipes-devtools/python/python3-wheel_0.37.1.bb
> b/meta/recipes-devtools/python/python3-wheel_0.37.1.bb
> > new file mode 100644
> > index 00000000000..6c7a31db9e7
> > --- /dev/null
> > +++ b/meta/recipes-devtools/python/python3-wheel_0.37.1.bb
> > @@ -0,0 +1,12 @@
> > +SUMMARY = "The official binary distribution format for Python "
> > +HOMEPAGE = "https://github.com/pypa/wheel"
> > +SECTION = "devel/python"
> > +LICENSE = "MIT"
> > +LIC_FILES_CHKSUM =
> "file://PKG-INFO;beginline=10;endline=10;md5=8227180126797a0148f94f483f3e1489"
> > +
> > +SRC_URI[sha256sum] =
> "e9a504e793efbca1b8e0e9cb979a249cf4a0a7b5b8c9e8b65a5e39d49529c1c4"
> > +
> > +inherit pypi setuptools3
> > +
> > +BBCLASSEXTEND = "native"
> > +
> > --
> > 2.30.2
> >
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#162077):
> https://lists.openembedded.org/g/openembedded-core/message/162077
> > Mute This Topic: https://lists.openembedded.org/mt/89304009/1997914
> > Group Owner: openembedded-core+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
> raj.khem@gmail.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
>

Patch

diff --git a/meta/conf/distro/include/maintainers.inc b/meta/conf/distro/include/maintainers.inc
index 740e5fe55c4..72cd0125814 100644
--- a/meta/conf/distro/include/maintainers.inc
+++ b/meta/conf/distro/include/maintainers.inc
@@ -651,6 +651,7 @@  RECIPE_MAINTAINER:pn-python3-typogrify = "Alexander Kanavin <alex.kanavin@gmail.
 RECIPE_MAINTAINER:pn-python3-vcversioner = "Bruce Ashfield <bruce.ashfield@gmail.com>"
 RECIPE_MAINTAINER:pn-python3-wcwidth = "Tim Orling <tim.orling@konsulko.com>"
 RECIPE_MAINTAINER:pn-python3-webcolors = "Bruce Ashfield <bruce.ashfield@gmail.com>"
+RECIPE_MAINTAINER:pn-python3-wheel = "Tim Orling <tim.orling@konsulko.com>"
 RECIPE_MAINTAINER:pn-python3-zipp = "Tim Orling <tim.orling@konsulko.com>"
 RECIPE_MAINTAINER:pn-qemu = "Richard Purdie <richard.purdie@linuxfoundation.org>"
 RECIPE_MAINTAINER:pn-qemu-helper-native = "Richard Purdie <richard.purdie@linuxfoundation.org>"
diff --git a/meta/recipes-devtools/python/python3-wheel_0.37.1.bb b/meta/recipes-devtools/python/python3-wheel_0.37.1.bb
new file mode 100644
index 00000000000..6c7a31db9e7
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-wheel_0.37.1.bb
@@ -0,0 +1,12 @@ 
+SUMMARY = "The official binary distribution format for Python "
+HOMEPAGE = "https://github.com/pypa/wheel"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=10;endline=10;md5=8227180126797a0148f94f483f3e1489"
+
+SRC_URI[sha256sum] = "e9a504e793efbca1b8e0e9cb979a249cf4a0a7b5b8c9e8b65a5e39d49529c1c4"
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND = "native"
+