diff mbox series

[6/6] kmod: upgrade from 31 to 32

Message ID 20240520081040.2380736-6-Qi.Chen@windriver.com
State New
Headers show
Series [1/6] systemd/systemd-boot: upgrade from 255.4 to 255.6 | expand

Commit Message

ChenQi May 20, 2024, 8:10 a.m. UTC
From: Chen Qi <Qi.Chen@windriver.com>

kmod now installs symlinks in 'make install'.
https://git.kernel.org/pub/scm/utils/kernel/kmod/kmod.git/commit/?
id=e98cef6f3f8cd6f8bfb26d147b2c209297453cca

With this change, we no longer need to deal with the symlinks in
do_install. Besides, as upstream chooses 'bin' instead of 'sbin'
to hold the tools, we'd better sync with it. That's the reason for
the sbindir -> bindir changes.

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
---
 .../kmod/{kmod_31.bb => kmod_32.bb}           | 24 +++++++------------
 1 file changed, 8 insertions(+), 16 deletions(-)
 rename meta/recipes-kernel/kmod/{kmod_31.bb => kmod_32.bb} (78%)

Comments

Richard Purdie May 21, 2024, 10:26 p.m. UTC | #1
On Mon, 2024-05-20 at 16:10 +0800, Chen Qi via lists.openembedded.org wrote:
> From: Chen Qi <Qi.Chen@windriver.com>
> 
> kmod now installs symlinks in 'make install'.
> https://git.kernel.org/pub/scm/utils/kernel/kmod/kmod.git/commit/?
> id=e98cef6f3f8cd6f8bfb26d147b2c209297453cca
> 
> With this change, we no longer need to deal with the symlinks in
> do_install. Besides, as upstream chooses 'bin' instead of 'sbin'
> to hold the tools, we'd better sync with it. That's the reason for
> the sbindir -> bindir changes.
> 
> Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
> ---
>  .../kmod/{kmod_31.bb => kmod_32.bb}           | 24 +++++++------------
>  1 file changed, 8 insertions(+), 16 deletions(-)
>  rename meta/recipes-kernel/kmod/{kmod_31.bb => kmod_32.bb} (78%)

I think this is causing libnl ptest failures:

https://autobuilder.yoctoproject.org/typhoon/#/builders/82/builds/6437/steps/12/logs/stdio

https://autobuilder.yocto.io/pub/non-release/20240521-26/testresults/qemuarm64-ptest/libnl.log


Cheers,

Richard
ChenQi May 22, 2024, 2:25 a.m. UTC | #2
Thanks. I'll fix it and send out V2.

Regards,
Qi

On 5/22/24 06:26, Richard Purdie wrote:
> On Mon, 2024-05-20 at 16:10 +0800, Chen Qi via lists.openembedded.org wrote:
>> From: Chen Qi <Qi.Chen@windriver.com>
>>
>> kmod now installs symlinks in 'make install'.
>> https://git.kernel.org/pub/scm/utils/kernel/kmod/kmod.git/commit/?
>> id=e98cef6f3f8cd6f8bfb26d147b2c209297453cca
>>
>> With this change, we no longer need to deal with the symlinks in
>> do_install. Besides, as upstream chooses 'bin' instead of 'sbin'
>> to hold the tools, we'd better sync with it. That's the reason for
>> the sbindir -> bindir changes.
>>
>> Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
>> ---
>>   .../kmod/{kmod_31.bb => kmod_32.bb}           | 24 +++++++------------
>>   1 file changed, 8 insertions(+), 16 deletions(-)
>>   rename meta/recipes-kernel/kmod/{kmod_31.bb => kmod_32.bb} (78%)
> I think this is causing libnl ptest failures:
>
> https://autobuilder.yoctoproject.org/typhoon/#/builders/82/builds/6437/steps/12/logs/stdio
>
> https://autobuilder.yocto.io/pub/non-release/20240521-26/testresults/qemuarm64-ptest/libnl.log
>
>
> Cheers,
>
> Richard
diff mbox series

Patch

diff --git a/meta/recipes-kernel/kmod/kmod_31.bb b/meta/recipes-kernel/kmod/kmod_32.bb
similarity index 78%
rename from meta/recipes-kernel/kmod/kmod_31.bb
rename to meta/recipes-kernel/kmod/kmod_32.bb
index 718a5565b4..1235bc1bf8 100644
--- a/meta/recipes-kernel/kmod/kmod_31.bb
+++ b/meta/recipes-kernel/kmod/kmod_32.bb
@@ -15,7 +15,7 @@  LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
                    "
 inherit autotools bash-completion gtk-doc pkgconfig manpages update-alternatives
 
-SRCREV = "aff617ea871d0568cc491bd116c0be1e857463bb"
+SRCREV = "41faa59711742c1476d59985011ee0f27ed91d30"
 
 SRC_URI = "git://git.kernel.org/pub/scm/utils/kernel/kmod/kmod.git;branch=master;protocol=https \
            file://depmod-search.conf \
@@ -50,12 +50,6 @@  EXTRA_OECONF += "--bindir=${base_bindir} --sbindir=${base_sbindir}"
 
 do_install:append () {
         install -dm755 ${D}${base_bindir}
-        install -dm755 ${D}${base_sbindir}
-        # add symlinks to kmod
-        ln -rs ${D}${base_bindir}/kmod ${D}${base_bindir}/lsmod
-        for tool in insmod rmmod depmod modinfo modprobe; do
-                ln -rs ${D}${base_bindir}/kmod ${D}${base_sbindir}/${tool}
-        done
         # configuration directories
         install -dm755 ${D}${nonarch_base_libdir}/depmod.d
         install -dm755 ${D}${nonarch_base_libdir}/modprobe.d
@@ -71,16 +65,14 @@  do_install:append () {
 
 ALTERNATIVE_PRIORITY = "70"
 
-ALTERNATIVE:kmod = "insmod modprobe rmmod modinfo bin-lsmod lsmod depmod"
+ALTERNATIVE:kmod = "insmod modprobe rmmod modinfo lsmod depmod"
 
-ALTERNATIVE_LINK_NAME[depmod] = "${base_sbindir}/depmod"
-ALTERNATIVE_LINK_NAME[insmod] = "${base_sbindir}/insmod"
-ALTERNATIVE_LINK_NAME[modprobe] = "${base_sbindir}/modprobe"
-ALTERNATIVE_LINK_NAME[rmmod] = "${base_sbindir}/rmmod"
-ALTERNATIVE_LINK_NAME[modinfo] = "${base_sbindir}/modinfo"
-ALTERNATIVE_LINK_NAME[bin-lsmod] = "${base_bindir}/lsmod"
-ALTERNATIVE_LINK_NAME[lsmod] = "${base_sbindir}/lsmod"
-ALTERNATIVE_TARGET[lsmod] = "${base_bindir}/lsmod.${BPN}"
+ALTERNATIVE_LINK_NAME[depmod] = "${base_bindir}/depmod"
+ALTERNATIVE_LINK_NAME[insmod] = "${base_bindir}/insmod"
+ALTERNATIVE_LINK_NAME[modprobe] = "${base_bindir}/modprobe"
+ALTERNATIVE_LINK_NAME[rmmod] = "${base_bindir}/rmmod"
+ALTERNATIVE_LINK_NAME[modinfo] = "${base_bindir}/modinfo"
+ALTERNATIVE_LINK_NAME[lsmod] = "${base_bindir}/lsmod"
 
 PACKAGES =+ "libkmod"
 FILES:libkmod = "${base_libdir}/libkmod*${SOLIBS} ${libdir}/libkmod*${SOLIBS}"