diff mbox series

[v2] oeqa: Use gnu make as testcase for autotooled recipe

Message ID 20240520012154.1644115-1-raj.khem@gmail.com
State New
Headers show
Series [v2] oeqa: Use gnu make as testcase for autotooled recipe | expand

Commit Message

Khem Raj May 20, 2024, 1:21 a.m. UTC
librdfa codebase is 10+ year old and is starting to show cracks
with gcc-14 e.g. it fails to compile

 ../../../../../../workspace/sources/librdfa/c/rdfa.c:345:36: error: passing argument 2 of 'rdfa_next_mapping' from incompatible pointer type [-Wincompatible-pointer-types]
|          rdfa_next_mapping(umap++, &umap_key, &umap_value);
|                                    ^~~~~~~~~
|                                    |
|                                    const char **

Replace with gnu make project which is also autotools based but the
codebase is maitained well with minimum dependendencies

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
v2: Use gnu make instead of alisp

 meta/lib/oeqa/manual/crops.json       | 16 ++++++----------
 meta/lib/oeqa/sdkext/cases/devtool.py |  5 ++---
 2 files changed, 8 insertions(+), 13 deletions(-)
diff mbox series

Patch

diff --git a/meta/lib/oeqa/manual/crops.json b/meta/lib/oeqa/manual/crops.json
index 5cfa6538432..3d361849598 100644
--- a/meta/lib/oeqa/manual/crops.json
+++ b/meta/lib/oeqa/manual/crops.json
@@ -188,20 +188,16 @@ 
                     "expected_results": "this should output the directory of the devtool script and it should be within the sdk workdir you are working in.   \n\n"
                 },
                 "5": {
-                    "action": "devtool sdk-install -s libxml2  \n\n",
-                    "expected_results": "this should install libxml2   \n\n"
+                    "action": "devtool add crops-test-make https://ftp.gnu.org/gnu/make/make-4.4.1.tar.gz  \n\n",
+                    "expected_results": "This should automatically create the recipe crops-test-make_4.4.1.bb under /recipes/crops-test-make/   \n\n"
                 },
                 "6": {
-                    "action": "devtool add librdfa  https://github.com/rdfa/librdfa  \n\n",
-                    "expected_results": "This should automatically create the recipe librdfa.bb under /recipes/librdfa/librdfa.bb   \n\n"
-                },
-                "7": {
-                    "action": "devtool build librdfa  \n\n",
+                    "action": "devtool build crops-test-make  \n\n",
                     "expected_results": "This should compile   \n\n"
                 },
-                "8": {
-                    "action": "devtool reset librdfa  ",
-                    "expected_results": "This cleans sysroot of the librdfa recipe, but it leaves the source tree intact. meaning it does not erase."
+                "7": {
+                    "action": "devtool reset crops-test-make  ",
+                    "expected_results": "This cleans sysroot of the crops-test-make recipe, but it leaves the source tree intact. meaning it does not erase."
                 }
             },
             "summary": "sdkext_extend_autotools_recipe_creation"
diff --git a/meta/lib/oeqa/sdkext/cases/devtool.py b/meta/lib/oeqa/sdkext/cases/devtool.py
index 5ffb732556b..dccf1250444 100644
--- a/meta/lib/oeqa/sdkext/cases/devtool.py
+++ b/meta/lib/oeqa/sdkext/cases/devtool.py
@@ -69,9 +69,8 @@  class DevtoolTest(OESDKExtTestCase):
         self._test_devtool_build(self.myapp_cmake_dst)
 
     def test_extend_autotools_recipe_creation(self):
-        req = 'https://github.com/rdfa/librdfa'
-        recipe = "librdfa"
-        self._run('devtool sdk-install libxml2')
+        req = 'https://ftp.gnu.org/gnu/make/make-4.4.1.tar.gz'
+        recipe = "devtool-test-make"
         self._run('devtool add %s %s' % (recipe, req) )
         try:
             self._run('devtool build %s' % recipe)