diff mbox series

enchant2: Disable incompatible-pointer-types warning as error

Message ID 20240509041406.2977304-1-raj.khem@gmail.com
State New
Headers show
Series enchant2: Disable incompatible-pointer-types warning as error | expand

Commit Message

Khem Raj May 9, 2024, 4:14 a.m. UTC
This fixes build with GCC-14

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-support/enchant/enchant2_2.7.2.bb | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Ross Burton May 9, 2024, 12:48 p.m. UTC | #1
On 9 May 2024, at 05:14, Khem Raj via lists.openembedded.org <raj.khem=gmail.com@lists.openembedded.org> wrote:
> +#api.vala:43:18: error: assignment to 'gchar **' {aka 'char **'} from incompatible pointer type 'const gchar * const*' {aka 'const char * const*'} [-Wincompatible-pointer-types] 
> +
> +CFLAGS += "-Wno-error=incompatible-pointer-typesā€¯

I poked upstream about this: this is basically a vala bug and if we upgrade vala or enchant then it will be resolved:

https://github.com/AbiWord/enchant/issues/379#issuecomment-2102590822

Ross
diff mbox series

Patch

diff --git a/meta/recipes-support/enchant/enchant2_2.7.2.bb b/meta/recipes-support/enchant/enchant2_2.7.2.bb
index 08998dd48fe..7e175852556 100644
--- a/meta/recipes-support/enchant/enchant2_2.7.2.bb
+++ b/meta/recipes-support/enchant/enchant2_2.7.2.bb
@@ -27,3 +27,7 @@  FILES:${PN} += " \
     ${libdir}/enchant-2 \
 "
 FILES:${PN}-staticdev += "${libdir}/enchant-2/*.a"
+
+#api.vala:43:18: error: assignment to 'gchar **' {aka 'char **'} from incompatible pointer type 'const gchar * const*' {aka 'const char * const*'} [-Wincompatible-pointer-types] 
+
+CFLAGS += "-Wno-error=incompatible-pointer-types"