diff mbox series

[v2,04/11] zip lrzsz connman-gnome libfm: ignore various issues fatal with gcc-14

Message ID 20240507053320.1566814-4-raj.khem@gmail.com
State New
Headers show
Series [v2,01/11] rng-tools: ignore incompatible-pointer-types errors for now | expand

Commit Message

Khem Raj May 7, 2024, 5:33 a.m. UTC
From: Martin Jansa <martin.jansa@gmail.com>

work arounds for:
oe-core/meta/recipes-bsp/lrzsz/lrzsz_0.12.20.bb:do_compile
oe-core/meta/recipes-connectivity/connman/connman-gnome_0.7.bb:do_compile
oe-core/meta/recipes-support/libfm/libfm_1.3.2.bb:do_compile
oe-core/meta/recipes-extended/zip/zip_3.0.bb:do_compile

http://errors.yoctoproject.org/Errors/Build/183127/

More fixes on ML (especially for -native with gcc-14 on host)
zip: https://lists.openembedded.org/g/openembedded-core/message/198783
cdrtools: https://lists.openembedded.org/g/openembedded-core/message/198899
syslinux: https://lists.openembedded.org/g/openembedded-core/message/198901

Signed-off-by: Martin Jansa <martin.jansa@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta/recipes-bsp/lrzsz/lrzsz_0.12.20.bb                | 6 ++++++
 meta/recipes-connectivity/connman/connman-gnome_0.7.bb | 4 ++++
 meta/recipes-extended/zip/zip_3.0.bb                   | 5 +++++
 meta/recipes-support/libfm/libfm_1.3.2.bb              | 4 ++++
 4 files changed, 19 insertions(+)

Comments

Martin Jansa May 7, 2024, 5:38 a.m. UTC | #1
On Tue, May 7, 2024 at 7:33 AM Khem Raj <raj.khem@gmail.com> wrote:
>
> From: Martin Jansa <martin.jansa@gmail.com>
>
> work arounds for:
> oe-core/meta/recipes-bsp/lrzsz/lrzsz_0.12.20.bb:do_compile
> oe-core/meta/recipes-connectivity/connman/connman-gnome_0.7.bb:do_compile
> oe-core/meta/recipes-support/libfm/libfm_1.3.2.bb:do_compile
> oe-core/meta/recipes-extended/zip/zip_3.0.bb:do_compile
>
> http://errors.yoctoproject.org/Errors/Build/183127/
>
> More fixes on ML (especially for -native with gcc-14 on host)
> zip: https://lists.openembedded.org/g/openembedded-core/message/198783
> cdrtools: https://lists.openembedded.org/g/openembedded-core/message/198899
> syslinux: https://lists.openembedded.org/g/openembedded-core/message/198901
>
> Signed-off-by: Martin Jansa <martin.jansa@gmail.com>
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> ---
...
> diff --git a/meta/recipes-extended/zip/zip_3.0.bb b/meta/recipes-extended/zip/zip_3.0.bb
> index 70df5ab8728..e7705b8faf4 100644
> --- a/meta/recipes-extended/zip/zip_3.0.bb
> +++ b/meta/recipes-extended/zip/zip_3.0.bb
> @@ -53,3 +53,8 @@ BBCLASSEXTEND = "native"
>
>  # exclude version 2.3.2 which triggers a false positive
>  UPSTREAM_CHECK_REGEX = "^zip(?P<pver>(?!232).+)\.tgz"
> +
> +# http://errors.yoctoproject.org/Errors/Details/766953/
> +# unix/unix.c:84:51: error: passing argument 4 of 'fread' from incompatible pointer type [-Wincompatible-pointer-types]
> +CFLAGS += "-Wno-error=incompatible-pointer-types"
> +# proper fix on ML: https://lists.openembedded.org/g/openembedded-core/message/198783

I think we should take the proper fix from ML instead of this work
around (I just haven't tested it yet).
Khem Raj May 7, 2024, 5:57 a.m. UTC | #2
On Mon, May 6, 2024 at 10:38 PM Martin Jansa <martin.jansa@gmail.com> wrote:
>
> On Tue, May 7, 2024 at 7:33 AM Khem Raj <raj.khem@gmail.com> wrote:
> >
> > From: Martin Jansa <martin.jansa@gmail.com>
> >
> > work arounds for:
> > oe-core/meta/recipes-bsp/lrzsz/lrzsz_0.12.20.bb:do_compile
> > oe-core/meta/recipes-connectivity/connman/connman-gnome_0.7.bb:do_compile
> > oe-core/meta/recipes-support/libfm/libfm_1.3.2.bb:do_compile
> > oe-core/meta/recipes-extended/zip/zip_3.0.bb:do_compile
> >
> > http://errors.yoctoproject.org/Errors/Build/183127/
> >
> > More fixes on ML (especially for -native with gcc-14 on host)
> > zip: https://lists.openembedded.org/g/openembedded-core/message/198783
> > cdrtools: https://lists.openembedded.org/g/openembedded-core/message/198899
> > syslinux: https://lists.openembedded.org/g/openembedded-core/message/198901
> >
> > Signed-off-by: Martin Jansa <martin.jansa@gmail.com>
> > Signed-off-by: Khem Raj <raj.khem@gmail.com>
> > ---
> ...
> > diff --git a/meta/recipes-extended/zip/zip_3.0.bb b/meta/recipes-extended/zip/zip_3.0.bb
> > index 70df5ab8728..e7705b8faf4 100644
> > --- a/meta/recipes-extended/zip/zip_3.0.bb
> > +++ b/meta/recipes-extended/zip/zip_3.0.bb
> > @@ -53,3 +53,8 @@ BBCLASSEXTEND = "native"
> >
> >  # exclude version 2.3.2 which triggers a false positive
> >  UPSTREAM_CHECK_REGEX = "^zip(?P<pver>(?!232).+)\.tgz"
> > +
> > +# http://errors.yoctoproject.org/Errors/Details/766953/
> > +# unix/unix.c:84:51: error: passing argument 4 of 'fread' from incompatible pointer type [-Wincompatible-pointer-types]
> > +CFLAGS += "-Wno-error=incompatible-pointer-types"
> > +# proper fix on ML: https://lists.openembedded.org/g/openembedded-core/message/198783
>
> I think we should take the proper fix from ML instead of this work
> around (I just haven't tested it yet).

I have cherry-picked the fix from ML and dropped zip from workaround
in my branches
diff mbox series

Patch

diff --git a/meta/recipes-bsp/lrzsz/lrzsz_0.12.20.bb b/meta/recipes-bsp/lrzsz/lrzsz_0.12.20.bb
index 63edcbd8643..3024ddcaf07 100644
--- a/meta/recipes-bsp/lrzsz/lrzsz_0.12.20.bb
+++ b/meta/recipes-bsp/lrzsz/lrzsz_0.12.20.bb
@@ -46,3 +46,9 @@  ALTERNATIVE_TARGET[rb] = "${bindir}/lrz"
 ALTERNATIVE_TARGET[sz] = "${bindir}/lsz"
 ALTERNATIVE_TARGET[sx] = "${bindir}/lsz"
 ALTERNATIVE_TARGET[sb] = "${bindir}/lsz"
+
+# http://errors.yoctoproject.org/Errors/Details/766929/
+# lrzsz-0.12.20/src/tcp.c:75:56: error: passing argument 3 of 'getsockname' from incompatible pointer type [-Wincompatible-pointer-types]
+# lrzsz-0.12.20/src/tcp.c:83:52: error: passing argument 3 of 'getsockname' from incompatible pointer type [-Wincompatible-pointer-types]
+# lrzsz-0.12.20/src/tcp.c:103:51: error: passing argument 3 of 'accept' from incompatible pointer type [-Wincompatible-pointer-types]
+CFLAGS += "-Wno-error=incompatible-pointer-types"
diff --git a/meta/recipes-connectivity/connman/connman-gnome_0.7.bb b/meta/recipes-connectivity/connman/connman-gnome_0.7.bb
index f6150d98ec9..46b3f854c52 100644
--- a/meta/recipes-connectivity/connman/connman-gnome_0.7.bb
+++ b/meta/recipes-connectivity/connman/connman-gnome_0.7.bb
@@ -28,3 +28,7 @@  RDEPENDS:${PN} = "connman"
 do_install:append() {
     install -m 0644 ${UNPACKDIR}/images/* ${D}/usr/share/icons/hicolor/22x22/apps/
 }
+
+# http://errors.yoctoproject.org/Errors/Details/766926/
+# connman-client.c:200:15: error: assignment to 'GtkTreeModel *' {aka 'struct _GtkTreeModel *'} from incompatible pointer type 'GtkTreeStore *' {aka 'struct _GtkTreeStore *'} [-Wincompatible-pointer-types]
+CFLAGS += "-Wno-error=incompatible-pointer-types"
diff --git a/meta/recipes-extended/zip/zip_3.0.bb b/meta/recipes-extended/zip/zip_3.0.bb
index 70df5ab8728..e7705b8faf4 100644
--- a/meta/recipes-extended/zip/zip_3.0.bb
+++ b/meta/recipes-extended/zip/zip_3.0.bb
@@ -53,3 +53,8 @@  BBCLASSEXTEND = "native"
 
 # exclude version 2.3.2 which triggers a false positive
 UPSTREAM_CHECK_REGEX = "^zip(?P<pver>(?!232).+)\.tgz"
+
+# http://errors.yoctoproject.org/Errors/Details/766953/
+# unix/unix.c:84:51: error: passing argument 4 of 'fread' from incompatible pointer type [-Wincompatible-pointer-types]
+CFLAGS += "-Wno-error=incompatible-pointer-types"
+# proper fix on ML: https://lists.openembedded.org/g/openembedded-core/message/198783
diff --git a/meta/recipes-support/libfm/libfm_1.3.2.bb b/meta/recipes-support/libfm/libfm_1.3.2.bb
index 057c7370293..1d7609165b4 100644
--- a/meta/recipes-support/libfm/libfm_1.3.2.bb
+++ b/meta/recipes-support/libfm/libfm_1.3.2.bb
@@ -53,3 +53,7 @@  do_install:append () {
     rm -f ${D}${libdir}/libfm-extra.a
     rm -f ${D}${libdir}/libfm-extra.la
 }
+
+# http://errors.yoctoproject.org/Errors/Details/766924/
+# libfm-1.3.2/src/actions/action.c:2050:25: error: assignment to 'gchar **' {aka 'char **'} from incompatible pointer type 'const gchar * const*' {aka 'const char * const*'} [-Wincompatible-pointer-types]
+CFLAGS += "-Wno-error=incompatible-pointer-types"