diff mbox series

u-boot: Enable devupstream

Message ID 20240502105721.775868-1-peter.hoyes@arm.com
State New
Headers show
Series u-boot: Enable devupstream | expand

Commit Message

Peter Hoyes May 2, 2024, 10:57 a.m. UTC
To enable downstream testing of the bleeding edge of U-Boot,
add devupstream to the recipe, with SRCREV set to automatically
track the latest revision.

Signed-off-by: Peter Hoyes <peter.hoyes@arm.com>
---
 meta/recipes-bsp/u-boot/u-boot_2024.04.bb | 3 +++
 1 file changed, 3 insertions(+)

Comments

Richard Purdie May 2, 2024, 11:02 a.m. UTC | #1
On Thu, 2024-05-02 at 11:57 +0100, Peter Hoyes via
lists.openembedded.org wrote:
> To enable downstream testing of the bleeding edge of U-Boot,
> add devupstream to the recipe, with SRCREV set to automatically
> track the latest revision.
> 
> Signed-off-by: Peter Hoyes <peter.hoyes@arm.com>
> ---
>  meta/recipes-bsp/u-boot/u-boot_2024.04.bb | 3 +++
>  1 file changed, 3 insertions(+)
> 
> diff --git a/meta/recipes-bsp/u-boot/u-boot_2024.04.bb
> b/meta/recipes-bsp/u-boot/u-boot_2024.04.bb
> index b15bcaa818..dc2e2da8ae 100644
> --- a/meta/recipes-bsp/u-boot/u-boot_2024.04.bb
> +++ b/meta/recipes-bsp/u-boot/u-boot_2024.04.bb
> @@ -3,3 +3,6 @@ require u-boot.inc
>  
>  DEPENDS += "bc-native dtc-native python3-pyelftools-native"
>  
> +BBCLASSEXTEND += "devupstream:target"
> +SRCREV:class-devupstream = "${AUTOREV}"
> +PV:class-devupstream = "dev+git"

Doesn't that mean parsing would hit the network by default every time?

Cheers,

Richard
Ross Burton May 2, 2024, 12:55 p.m. UTC | #2
On 2 May 2024, at 12:02, Richard Purdie via lists.openembedded.org <richard.purdie=linuxfoundation.org@lists.openembedded.org> wrote:
>> +BBCLASSEXTEND += "devupstream:target"
>> +SRCREV:class-devupstream = "${AUTOREV}"
>> +PV:class-devupstream = "dev+git"
> 
> Doesn't that mean parsing would hit the network by default every time?

I _believe_ it only hits when the devupstream variation is actually picked.  Is this acceptable?

Ross
Richard Purdie May 2, 2024, 1:29 p.m. UTC | #3
On Thu, 2024-05-02 at 12:55 +0000, Ross Burton wrote:
> On 2 May 2024, at 12:02, Richard Purdie via lists.openembedded.org
> <richard.purdie=linuxfoundation.org@lists.openembedded.org> wrote:
> > > +BBCLASSEXTEND += "devupstream:target"
> > > +SRCREV:class-devupstream = "${AUTOREV}"
> > > +PV:class-devupstream = "dev+git"
> > 
> > Doesn't that mean parsing would hit the network by default every
> > time?
> 
> I _believe_ it only hits when the devupstream variation is actually
> picked.  Is this acceptable?

I believe you're wrong ;-)

I applied this patch and the first thing I'd note is that:

$ bitbake -p
Parsing of 991 .bb files complete (990 cached, 1 parsed). 1969 targets, 50 skipped, 0 masked, 0 errors.
$ bitbake -p
Parsing of 991 .bb files complete (990 cached, 1 parsed). 1969 targets, 50 skipped, 0 masked, 0 errors.

i.e. it is *always* now parsing one recipe, you can guess which.

I then tried "bitbake -pDDD" which in the output includes:

DEBUG: /media/build/poky/meta/recipes-bsp/u-boot/u-boot_2024.04.bb: Fetcher accessed the network with the command git -c gc.autoDetach=false -c core.pager=cat -c safe.bareRepository=all ls-remote https://source.denx.de/u-boot/u-boot.git 

so I believe this is accessing the network on every parse.

Cheers,

Richard
diff mbox series

Patch

diff --git a/meta/recipes-bsp/u-boot/u-boot_2024.04.bb b/meta/recipes-bsp/u-boot/u-boot_2024.04.bb
index b15bcaa818..dc2e2da8ae 100644
--- a/meta/recipes-bsp/u-boot/u-boot_2024.04.bb
+++ b/meta/recipes-bsp/u-boot/u-boot_2024.04.bb
@@ -3,3 +3,6 @@  require u-boot.inc
 
 DEPENDS += "bc-native dtc-native python3-pyelftools-native"
 
+BBCLASSEXTEND += "devupstream:target"
+SRCREV:class-devupstream = "${AUTOREV}"
+PV:class-devupstream = "dev+git"