diff mbox series

[v2] curl: improve reproducibility

Message ID 20240327171434.949887-1-omatiush@cisco.com
State New
Headers show
Series [v2] curl: improve reproducibility | expand

Commit Message

nativesdk-curl package contains host references in output files.
remove them.

Signed-off-by: Oleh Matiusha <omatiush@cisco.com>
---
v2
 - moved common code to separate function 
---
---
 meta/recipes-support/curl/curl_8.6.0.bb | 10 +++++++++-
 1 file changed, 9 insertions(+), 1 deletion(-)

Comments

Ross Burton March 27, 2024, 8:17 p.m. UTC | #1
On 27 Mar 2024, at 17:14, Oleh Matiusha via lists.openembedded.org <omatiush=cisco.com@lists.openembedded.org> wrote:
> +do_install:append:class-target() {
> + fix_absolute_paths
> +}
> +
> +do_install:append:class-nativesdk() {
> + fix_absolute_paths
> +}

Would it be best to just always do this sed?  A native build won’t have a —sysroot anyway.

(or even better, stop curl-config from embedding the sysroot in the first place)

Ross
What about --with-libtool-sysroot and DEBUG_PREFIX_MAP?

Oleh
diff mbox series

Patch

diff --git a/meta/recipes-support/curl/curl_8.6.0.bb b/meta/recipes-support/curl/curl_8.6.0.bb
index ea69164d76..49ba0cb4a7 100644
--- a/meta/recipes-support/curl/curl_8.6.0.bb
+++ b/meta/recipes-support/curl/curl_8.6.0.bb
@@ -79,7 +79,7 @@  EXTRA_OECONF = " \
     ${@'--without-ssl' if (bb.utils.filter('PACKAGECONFIG', 'gnutls mbedtls openssl', d) == '') else ''} \
 "
 
-do_install:append:class-target() {
+fix_absolute_paths () {
 	# cleanup buildpaths from curl-config
 	sed -i \
 	    -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
@@ -89,6 +89,14 @@  do_install:append:class-target() {
 	    ${D}${bindir}/curl-config
 }
 
+do_install:append:class-target() {
+	fix_absolute_paths
+}
+
+do_install:append:class-nativesdk() {
+	fix_absolute_paths
+}
+
 do_compile_ptest() {
 	oe_runmake -C ${B}/tests
 }