diff mbox series

[kirkstone,1/2] python3-unittest-automake-output: add new recipe for ptest integration

Message ID 20240327072236.2221619-1-mingli.yu@windriver.com
State Rejected
Delegated to: Steve Sakoman
Headers show
Series [kirkstone,1/2] python3-unittest-automake-output: add new recipe for ptest integration | expand

Commit Message

Yu, Mingli March 27, 2024, 7:22 a.m. UTC
From: Ross Burton <ross.burton@arm.com>

This package contains modules for both unittest and pytest that alter
the output to look like automake's 'make check' output, for better
integration with ptest.

Signed-off-by: Ross Burton <ross.burton@arm.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit 961e4f3fc786715fc136fa446686972a4a95a3d5)
Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
---
 meta/conf/distro/include/maintainers.inc            |  1 +
 .../python/python3-unittest-automake-output_0.1.bb  | 13 +++++++++++++
 2 files changed, 14 insertions(+)
 create mode 100644 meta/recipes-devtools/python/python3-unittest-automake-output_0.1.bb

Comments

Steve Sakoman March 27, 2024, 3:54 p.m. UTC | #1
Sorry, it is outside of stable branch policy to add features so I
can't take this patch series.

Steve

On Tue, Mar 26, 2024 at 9:22 PM Yu, Mingli <mingli.yu@eng.windriver.com> wrote:
>
> From: Ross Burton <ross.burton@arm.com>
>
> This package contains modules for both unittest and pytest that alter
> the output to look like automake's 'make check' output, for better
> integration with ptest.
>
> Signed-off-by: Ross Burton <ross.burton@arm.com>
> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
> (cherry picked from commit 961e4f3fc786715fc136fa446686972a4a95a3d5)
> Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
> ---
>  meta/conf/distro/include/maintainers.inc            |  1 +
>  .../python/python3-unittest-automake-output_0.1.bb  | 13 +++++++++++++
>  2 files changed, 14 insertions(+)
>  create mode 100644 meta/recipes-devtools/python/python3-unittest-automake-output_0.1.bb
>
> diff --git a/meta/conf/distro/include/maintainers.inc b/meta/conf/distro/include/maintainers.inc
> index bfc14951fe..09c1599915 100644
> --- a/meta/conf/distro/include/maintainers.inc
> +++ b/meta/conf/distro/include/maintainers.inc
> @@ -684,6 +684,7 @@ RECIPE_MAINTAINER:pn-python3-toml = "Tim Orling <tim.orling@konsulko.com>"
>  RECIPE_MAINTAINER:pn-python3-tomli = "Tim Orling <tim.orling@konsulko.com>"
>  RECIPE_MAINTAINER:pn-python3-typing-extensions = "Tim Orling <tim.orling@konsulko.com>"
>  RECIPE_MAINTAINER:pn-python3-typogrify = "Alexander Kanavin <alex.kanavin@gmail.com>"
> +RECIPE_MAINTAINER:pn-python3-unittest-automake-output = "Ross Burton <ross.burton@arm.com>"
>  RECIPE_MAINTAINER:pn-python3-urllib3 = "Tim Orling <tim.orling@konsulko.com>"
>  RECIPE_MAINTAINER:pn-python3-vcversioner = "Bruce Ashfield <bruce.ashfield@gmail.com>"
>  RECIPE_MAINTAINER:pn-python3-wcwidth = "Tim Orling <tim.orling@konsulko.com>"
> diff --git a/meta/recipes-devtools/python/python3-unittest-automake-output_0.1.bb b/meta/recipes-devtools/python/python3-unittest-automake-output_0.1.bb
> new file mode 100644
> index 0000000000..ba58c18df0
> --- /dev/null
> +++ b/meta/recipes-devtools/python/python3-unittest-automake-output_0.1.bb
> @@ -0,0 +1,13 @@
> +SUMMARY = "Modules to make unittest and pytest look like Automake output, for ptest"
> +HOMEPAGE = "https://gitlab.com/rossburton/python-unittest-automake-output"
> +LICENSE = "MIT"
> +LIC_FILES_CHKSUM = "file://LICENSE;md5=f6f16008d9fb7349f06609329f1ab93b"
> +
> +SRC_URI = "git://gitlab.com/rossburton/python-unittest-automake-output;protocol=https;branch=main"
> +SRCREV = "06537edb18f3641c70bce25256f6ecf5f5164ead"
> +
> +S = "${WORKDIR}/git"
> +
> +inherit python_flit_core
> +
> +BBCLASSEXTEND = "native nativesdk"
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#197548): https://lists.openembedded.org/g/openembedded-core/message/197548
> Mute This Topic: https://lists.openembedded.org/mt/105173226/3620601
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [steve@sakoman.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/conf/distro/include/maintainers.inc b/meta/conf/distro/include/maintainers.inc
index bfc14951fe..09c1599915 100644
--- a/meta/conf/distro/include/maintainers.inc
+++ b/meta/conf/distro/include/maintainers.inc
@@ -684,6 +684,7 @@  RECIPE_MAINTAINER:pn-python3-toml = "Tim Orling <tim.orling@konsulko.com>"
 RECIPE_MAINTAINER:pn-python3-tomli = "Tim Orling <tim.orling@konsulko.com>"
 RECIPE_MAINTAINER:pn-python3-typing-extensions = "Tim Orling <tim.orling@konsulko.com>"
 RECIPE_MAINTAINER:pn-python3-typogrify = "Alexander Kanavin <alex.kanavin@gmail.com>"
+RECIPE_MAINTAINER:pn-python3-unittest-automake-output = "Ross Burton <ross.burton@arm.com>"
 RECIPE_MAINTAINER:pn-python3-urllib3 = "Tim Orling <tim.orling@konsulko.com>"
 RECIPE_MAINTAINER:pn-python3-vcversioner = "Bruce Ashfield <bruce.ashfield@gmail.com>"
 RECIPE_MAINTAINER:pn-python3-wcwidth = "Tim Orling <tim.orling@konsulko.com>"
diff --git a/meta/recipes-devtools/python/python3-unittest-automake-output_0.1.bb b/meta/recipes-devtools/python/python3-unittest-automake-output_0.1.bb
new file mode 100644
index 0000000000..ba58c18df0
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-unittest-automake-output_0.1.bb
@@ -0,0 +1,13 @@ 
+SUMMARY = "Modules to make unittest and pytest look like Automake output, for ptest"
+HOMEPAGE = "https://gitlab.com/rossburton/python-unittest-automake-output"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=f6f16008d9fb7349f06609329f1ab93b"
+
+SRC_URI = "git://gitlab.com/rossburton/python-unittest-automake-output;protocol=https;branch=main"
+SRCREV = "06537edb18f3641c70bce25256f6ecf5f5164ead"
+
+S = "${WORKDIR}/git"
+
+inherit python_flit_core
+
+BBCLASSEXTEND = "native nativesdk"