diff mbox series

[1/3] nativesdk-packagegroup-sdk-host: add gprofng package to RDEPENDS

Message ID 20240322101053.1397030-1-Harish.Sadineni@windriver.com
State New
Headers show
Series [1/3] nativesdk-packagegroup-sdk-host: add gprofng package to RDEPENDS | expand

Commit Message

Sadineni, Harish March 22, 2024, 10:10 a.m. UTC
From: Harish Sadineni <Harish.Sadineni@windriver.com>

In SDK, while running "x86_64-poky-linux-gp-collect-app ./exe" fails to create 'test.1.er' due to missing gprofng configure file in sysconfdir and aborting with below error while generating the profiling data.
- configuration error: can not find libgp-collector.so. run aborted

Signed-off-by: Harish Sadineni <Harish.Sadineni@windriver.com>
---
 .../packagegroups/nativesdk-packagegroup-sdk-host.bb             | 1 +
 1 file changed, 1 insertion(+)

Comments

Richard Purdie March 22, 2024, 10:29 p.m. UTC | #1
On Fri, 2024-03-22 at 03:10 -0700, Sadineni, Harish via
lists.openembedded.org wrote:
> From: Harish Sadineni <Harish.Sadineni@windriver.com>
> 
> In SDK, while running "x86_64-poky-linux-gp-collect-app ./exe" fails
> to create 'test.1.er' due to missing gprofng configure file in
> sysconfdir and aborting with below error while generating the
> profiling data.
> - configuration error: can not find libgp-collector.so. run aborted
> 
> Signed-off-by: Harish Sadineni <Harish.Sadineni@windriver.com>
> ---
>  .../packagegroups/nativesdk-packagegroup-sdk-host.bb             | 1
> +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/meta/recipes-core/packagegroups/nativesdk-packagegroup-
> sdk-host.bb b/meta/recipes-core/packagegroups/nativesdk-packagegroup-
> sdk-host.bb
> index c1d3c25060..5374067bab 100644
> --- a/meta/recipes-core/packagegroups/nativesdk-packagegroup-sdk-
> host.bb
> +++ b/meta/recipes-core/packagegroups/nativesdk-packagegroup-sdk-
> host.bb
> @@ -30,6 +30,7 @@ RDEPENDS:${PN} = "\
>      nativesdk-bison \
>      nativesdk-flex \
>      nativesdk-perl-module-integer \
> +    nativesdk-gprofng \
>      "
>  
>  RDEPENDS:${PN}:darwin = "\

Should the package which contains x86_64-poky-linux-gp-collect-app not
be the place where we need to add this dependency?

Cheers,

Richard
Sadineni, Harish March 29, 2024, 3:01 p.m. UTC | #2
gprofng belongs to binutils module, i tried a build by adding it in binutils-cross-canadian.inc and the build is sucessfully generating gprofng.rc in sysconf directory as expected.
we have sent a v2 patch by adding it in binutils (https://lists.openembedded.org/g/openembedded-core/message/197632).

Thanks,
Harish sadineni
diff mbox series

Patch

diff --git a/meta/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bb b/meta/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bb
index c1d3c25060..5374067bab 100644
--- a/meta/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bb
+++ b/meta/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bb
@@ -30,6 +30,7 @@  RDEPENDS:${PN} = "\
     nativesdk-bison \
     nativesdk-flex \
     nativesdk-perl-module-integer \
+    nativesdk-gprofng \
     "
 
 RDEPENDS:${PN}:darwin = "\