diff mbox series

[1/3] curl: improve run-ptest

Message ID 20240315143738.1234858-1-ross.burton@arm.com
State Accepted, archived
Commit 3c3601d50ae290e7e9797eadd20c05df99bbd040
Headers show
Series [1/3] curl: improve run-ptest | expand

Commit Message

Ross Burton March 15, 2024, 2:37 p.m. UTC
From: Ross Burton <ross.burton@arm.com>

There's no need to run the output of runtests.pl through a sed to get
automake-style output, as you can pass -am to get this formatting.

Don't run timing dependent tests, as the ptests can run on loaded
systems.

Add a dependency on the en_US locale because some of the tests require
this.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta/recipes-support/curl/curl/run-ptest | 13 +++++++++----
 meta/recipes-support/curl/curl_8.6.0.bb  |  1 +
 2 files changed, 10 insertions(+), 4 deletions(-)

Comments

Khem Raj March 15, 2024, 4:08 p.m. UTC | #1
On Fri, Mar 15, 2024 at 7:37 AM Ross Burton <ross.burton@arm.com> wrote:
>
> From: Ross Burton <ross.burton@arm.com>
>
> There's no need to run the output of runtests.pl through a sed to get
> automake-style output, as you can pass -am to get this formatting.
>
> Don't run timing dependent tests, as the ptests can run on loaded
> systems.
>
> Add a dependency on the en_US locale because some of the tests require
> this.
>
> Signed-off-by: Ross Burton <ross.burton@arm.com>
> ---
>  meta/recipes-support/curl/curl/run-ptest | 13 +++++++++----
>  meta/recipes-support/curl/curl_8.6.0.bb  |  1 +
>  2 files changed, 10 insertions(+), 4 deletions(-)
>
> diff --git a/meta/recipes-support/curl/curl/run-ptest b/meta/recipes-support/curl/curl/run-ptest
> index 8f9c20f34df..acd2892f80e 100644
> --- a/meta/recipes-support/curl/curl/run-ptest
> +++ b/meta/recipes-support/curl/curl/run-ptest
> @@ -1,6 +1,11 @@
>  #!/bin/sh
> +
>  cd tests
> -{ ./runtests.pl -a -n -s -j4 !flaky || echo "FAIL: curl" ; } | sed \
> -     -e 's|\([^ ]* *\) \([^ ]* *\)...OK|PASS: \1 \2|' \
> -     -e 's|\([^ ]* *\) \([^ ]* *\)...FAILED|FAIL: \1 \2|' \
> -     -e 's/Warning: test[0-9]\+ not present in tests\/data\/Makefile.inc//'
> +
> +# Run all tests, don't stop on first failure
> +# Don't use valgrind if it is found
> +# Use automake-style output
> +# Run four tests in parallel
> +# Print log output on failure
> +# Don't run the flaky or timing dependent tests
> +./runtests.pl -a -n -am -j4 -p '!flaky !timing-dependent'
> diff --git a/meta/recipes-support/curl/curl_8.6.0.bb b/meta/recipes-support/curl/curl_8.6.0.bb
> index b01f4542a22..d4473d868e2 100644
> --- a/meta/recipes-support/curl/curl_8.6.0.bb
> +++ b/meta/recipes-support/curl/curl_8.6.0.bb
> @@ -125,6 +125,7 @@ RDEPENDS:${PN}-ptest += " \
>         perl-module-storable \
>         perl-module-time-hires \
>  "
> +RDEPENDS:${PN}-ptest:append:libc-glibc = " locale-base-en-us"

musl-locales does provide a subset of locales and locale-base-en-us is
one of them
so you don't have to make it conditional.

>
>  PACKAGES =+ "lib${BPN}"
>
> --
> 2.34.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#197133): https://lists.openembedded.org/g/openembedded-core/message/197133
> Mute This Topic: https://lists.openembedded.org/mt/104948640/1997914
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-support/curl/curl/run-ptest b/meta/recipes-support/curl/curl/run-ptest
index 8f9c20f34df..acd2892f80e 100644
--- a/meta/recipes-support/curl/curl/run-ptest
+++ b/meta/recipes-support/curl/curl/run-ptest
@@ -1,6 +1,11 @@ 
 #!/bin/sh
+
 cd tests
-{ ./runtests.pl -a -n -s -j4 !flaky || echo "FAIL: curl" ; } | sed \
-     -e 's|\([^ ]* *\) \([^ ]* *\)...OK|PASS: \1 \2|' \
-     -e 's|\([^ ]* *\) \([^ ]* *\)...FAILED|FAIL: \1 \2|' \
-     -e 's/Warning: test[0-9]\+ not present in tests\/data\/Makefile.inc//'
+
+# Run all tests, don't stop on first failure
+# Don't use valgrind if it is found
+# Use automake-style output
+# Run four tests in parallel
+# Print log output on failure
+# Don't run the flaky or timing dependent tests
+./runtests.pl -a -n -am -j4 -p '!flaky !timing-dependent'
diff --git a/meta/recipes-support/curl/curl_8.6.0.bb b/meta/recipes-support/curl/curl_8.6.0.bb
index b01f4542a22..d4473d868e2 100644
--- a/meta/recipes-support/curl/curl_8.6.0.bb
+++ b/meta/recipes-support/curl/curl_8.6.0.bb
@@ -125,6 +125,7 @@  RDEPENDS:${PN}-ptest += " \
 	perl-module-storable \
 	perl-module-time-hires \
 "
+RDEPENDS:${PN}-ptest:append:libc-glibc = " locale-base-en-us"
 
 PACKAGES =+ "lib${BPN}"