diff mbox series

[2/2] linux-firmware: add a package for ath12k firmware

Message ID 20240314100610.21815-2-brgl@bgdev.pl
State New
Headers show
Series [1/2] linux-firmware: update to 20240312 | expand

Commit Message

Bartosz Golaszewski March 14, 2024, 10:06 a.m. UTC
From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>

Add the firmware package for the ATH12K module.

Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
---
 .../linux-firmware/linux-firmware_20240312.bb             | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)

Comments

Alexandre Belloni April 17, 2024, 4:27 p.m. UTC | #1
Hello,

Now that master has dverged from Scarthgap, can you rebase?

On 14/03/2024 11:06:10+0100, Bartosz Golaszewski wrote:
> From: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
> 
> Add the firmware package for the ATH12K module.
> 
> Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>
> ---
>  .../linux-firmware/linux-firmware_20240312.bb             | 8 +++++++-
>  1 file changed, 7 insertions(+), 1 deletion(-)
> 
> diff --git a/meta/recipes-kernel/linux-firmware/linux-firmware_20240312.bb b/meta/recipes-kernel/linux-firmware/linux-firmware_20240312.bb
> index 390d10d2f3..4961b43ad5 100644
> --- a/meta/recipes-kernel/linux-firmware/linux-firmware_20240312.bb
> +++ b/meta/recipes-kernel/linux-firmware/linux-firmware_20240312.bb
> @@ -320,7 +320,8 @@ PACKAGES =+ "${PN}-amphion-vpu-license ${PN}-amphion-vpu \
>               ${PN}-cnm-license ${PN}-cnm \
>               ${PN}-atheros-license ${PN}-ar5523 ${PN}-ar9170 ${PN}-ath6k ${PN}-ath9k ${PN}-ath3k \
>               ${PN}-gplv2-license ${PN}-carl9170 \
> -             ${PN}-ar3k-license ${PN}-ar3k ${PN}-ath10k-license ${PN}-ath10k ${PN}-ath11k ${PN}-qca \
> +             ${PN}-ar3k-license ${PN}-ar3k \
> +             ${PN}-ath10k-license ${PN}-ath10k ${PN}-ath11k ${PN}-ath12k ${PN}-qca \
>               \
>               ${PN}-imx-sdma-license ${PN}-imx-sdma-imx6q ${PN}-imx-sdma-imx7d \
>               \
> @@ -488,6 +489,10 @@ FILES:${PN}-ath11k = " \
>    ${nonarch_base_libdir}/firmware/ath11k \
>  "
>  
> +FILES:${PN}-ath12k = " \
> +  ${nonarch_base_libdir}/firmware/ath12k \
> +"
> +
>  FILES:${PN}-qca = " \
>    ${nonarch_base_libdir}/firmware/qca \
>  "
> @@ -495,6 +500,7 @@ FILES:${PN}-qca = " \
>  RDEPENDS:${PN}-ar3k += "${PN}-ar3k-license ${PN}-atheros-license"
>  RDEPENDS:${PN}-ath10k += "${PN}-ath10k-license"
>  RDEPENDS:${PN}-ath11k += "${PN}-ath10k-license"
> +RDEPENDS:${PN}-ath12k += "${PN}-ath10k-license"
>  RDEPENDS:${PN}-qca += "${PN}-ath10k-license"
>  
>  # For ralink
> -- 
> 2.40.1
> 

> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#197102): https://lists.openembedded.org/g/openembedded-core/message/197102
> Mute This Topic: https://lists.openembedded.org/mt/104923522/3617179
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alexandre.belloni@bootlin.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-kernel/linux-firmware/linux-firmware_20240312.bb b/meta/recipes-kernel/linux-firmware/linux-firmware_20240312.bb
index 390d10d2f3..4961b43ad5 100644
--- a/meta/recipes-kernel/linux-firmware/linux-firmware_20240312.bb
+++ b/meta/recipes-kernel/linux-firmware/linux-firmware_20240312.bb
@@ -320,7 +320,8 @@  PACKAGES =+ "${PN}-amphion-vpu-license ${PN}-amphion-vpu \
              ${PN}-cnm-license ${PN}-cnm \
              ${PN}-atheros-license ${PN}-ar5523 ${PN}-ar9170 ${PN}-ath6k ${PN}-ath9k ${PN}-ath3k \
              ${PN}-gplv2-license ${PN}-carl9170 \
-             ${PN}-ar3k-license ${PN}-ar3k ${PN}-ath10k-license ${PN}-ath10k ${PN}-ath11k ${PN}-qca \
+             ${PN}-ar3k-license ${PN}-ar3k \
+             ${PN}-ath10k-license ${PN}-ath10k ${PN}-ath11k ${PN}-ath12k ${PN}-qca \
              \
              ${PN}-imx-sdma-license ${PN}-imx-sdma-imx6q ${PN}-imx-sdma-imx7d \
              \
@@ -488,6 +489,10 @@  FILES:${PN}-ath11k = " \
   ${nonarch_base_libdir}/firmware/ath11k \
 "
 
+FILES:${PN}-ath12k = " \
+  ${nonarch_base_libdir}/firmware/ath12k \
+"
+
 FILES:${PN}-qca = " \
   ${nonarch_base_libdir}/firmware/qca \
 "
@@ -495,6 +500,7 @@  FILES:${PN}-qca = " \
 RDEPENDS:${PN}-ar3k += "${PN}-ar3k-license ${PN}-atheros-license"
 RDEPENDS:${PN}-ath10k += "${PN}-ath10k-license"
 RDEPENDS:${PN}-ath11k += "${PN}-ath10k-license"
+RDEPENDS:${PN}-ath12k += "${PN}-ath10k-license"
 RDEPENDS:${PN}-qca += "${PN}-ath10k-license"
 
 # For ralink