diff mbox series

[09/21] libpam: update 1.5.3 -> 1.6.0

Message ID 20240313173336.3900178-9-alex@linutronix.de
State New
Headers show
Series [01/21] meson: correct upstream version check (exclude pre-releases) | expand

Commit Message

Alexander Kanavin March 13, 2024, 5:33 p.m. UTC
Signed-off-by: Alexander Kanavin <alex@linutronix.de>
---
 ...place-use-of-termio.h-with-termios.h.patch | 39 -------------------
 .../pam/libpam/libpam-xtests.patch            | 22 +++++++----
 .../pam/{libpam_1.5.3.bb => libpam_1.6.0.bb}  |  3 +-
 3 files changed, 16 insertions(+), 48 deletions(-)
 delete mode 100644 meta/recipes-extended/pam/libpam/0001-examples-Replace-use-of-termio.h-with-termios.h.patch
 rename meta/recipes-extended/pam/{libpam_1.5.3.bb => libpam_1.6.0.bb} (97%)

Comments

Khem Raj March 14, 2024, 4:14 a.m. UTC | #1
fails to build with musl

| ../../../Linux-PAM-1.6.0/modules/pam_namespace/pam_namespace.c:649:41:
error: use of undeclared identifier 'SIZE_MAX'
|   649 |         if (count > UINT_MAX || count > SIZE_MAX / sizeof(uid_t)) {
|       |                                         ^
| 1 error generated.
| make[3]: *** [Makefile:807: pam_namespace.lo] Error 1

On Wed, Mar 13, 2024 at 10:33 AM Alexander Kanavin
<alex.kanavin@gmail.com> wrote:
>
> Signed-off-by: Alexander Kanavin <alex@linutronix.de>
> ---
>  ...place-use-of-termio.h-with-termios.h.patch | 39 -------------------
>  .../pam/libpam/libpam-xtests.patch            | 22 +++++++----
>  .../pam/{libpam_1.5.3.bb => libpam_1.6.0.bb}  |  3 +-
>  3 files changed, 16 insertions(+), 48 deletions(-)
>  delete mode 100644 meta/recipes-extended/pam/libpam/0001-examples-Replace-use-of-termio.h-with-termios.h.patch
>  rename meta/recipes-extended/pam/{libpam_1.5.3.bb => libpam_1.6.0.bb} (97%)
>
> diff --git a/meta/recipes-extended/pam/libpam/0001-examples-Replace-use-of-termio.h-with-termios.h.patch b/meta/recipes-extended/pam/libpam/0001-examples-Replace-use-of-termio.h-with-termios.h.patch
> deleted file mode 100644
> index 95c437df4f1..00000000000
> --- a/meta/recipes-extended/pam/libpam/0001-examples-Replace-use-of-termio.h-with-termios.h.patch
> +++ /dev/null
> @@ -1,39 +0,0 @@
> -From 9b96fcfa5748934b8b6a4db4ee25a5e3165905c0 Mon Sep 17 00:00:00 2001
> -From: Khem Raj <raj.khem@gmail.com>
> -Date: Sat, 1 Jul 2023 07:48:17 -0700
> -Subject: [PATCH] examples: Replace use of termio.h with termios.h
> -
> -Fixes build with musl and makes it portable
> -
> -Upstream-Status: Backport [https://github.com/linux-pam/linux-pam/commit/5374f677e4cae669eb9accf2449178b602e8a40a]
> -Signed-off-by: Khem Raj <raj.khem@gmail.com>
> ----
> - examples/tty_conv.c | 5 +++--
> - 1 file changed, 3 insertions(+), 2 deletions(-)
> -
> -diff --git a/examples/tty_conv.c b/examples/tty_conv.c
> -index 23f0684..db22500 100644
> ---- a/examples/tty_conv.c
> -+++ b/examples/tty_conv.c
> -@@ -6,7 +6,8 @@
> - #include <string.h>
> - #include <errno.h>
> - #include <unistd.h>
> --#include <termio.h>
> -+#include <termios.h>
> -+#include <sys/ioctl.h>
> - #include <security/pam_appl.h>
> -
> - /***************************************
> -@@ -16,7 +17,7 @@
> -  ***************************************/
> - static void echoOff(int fd, int off)
> - {
> --    struct termio tty;
> -+    struct termios tty;
> -     if (ioctl(fd, TCGETA, &tty) < 0)
> -     {
> -         fprintf(stderr, "TCGETA failed: %s\n", strerror(errno));
> ---
> -2.41.0
> -
> diff --git a/meta/recipes-extended/pam/libpam/libpam-xtests.patch b/meta/recipes-extended/pam/libpam/libpam-xtests.patch
> index ea145899b49..f2dafa72a5b 100644
> --- a/meta/recipes-extended/pam/libpam/libpam-xtests.patch
> +++ b/meta/recipes-extended/pam/libpam/libpam-xtests.patch
> @@ -1,13 +1,21 @@
> -This patch is used to create a new sub package libpam-xtests to do more checks.
> +From 060726f7e60c8ecb5bf50fd776910b290d9a0a69 Mon Sep 17 00:00:00 2001
> +From: Kang Kai <kai.kang@windriver.com>
> +Date: Tue, 19 Jul 2011 17:08:31 +0800
> +Subject: [PATCH] This patch is used to create a new sub package libpam-xtests
> + to do more checks.
>
>  Upstream-Status: Pending
>
>  Signed-off-by: Kang Kai <kai.kang@windriver.com>
> -Index: Linux-PAM-1.3.0/xtests/Makefile.am
> -===================================================================
> ---- Linux-PAM-1.3.0.orig/xtests/Makefile.am
> -+++ Linux-PAM-1.3.0/xtests/Makefile.am
> -@@ -7,7 +7,7 @@ AM_CFLAGS = -DLIBPAM_COMPILE -I$(top_src
> +---
> + xtests/Makefile.am | 17 ++++++++++++++++-
> + 1 file changed, 16 insertions(+), 1 deletion(-)
> +
> +diff --git a/xtests/Makefile.am b/xtests/Makefile.am
> +index acf9746..9826c9f 100644
> +--- a/xtests/Makefile.am
> ++++ b/xtests/Makefile.am
> +@@ -8,7 +8,7 @@ AM_CFLAGS = -DLIBPAM_COMPILE -I$(top_srcdir)/libpam/include \
>   LDADD = $(top_builddir)/libpam/libpam.la \
>         $(top_builddir)/libpam_misc/libpam_misc.la
>
> @@ -16,7 +24,7 @@ Index: Linux-PAM-1.3.0/xtests/Makefile.am
>
>   EXTRA_DIST = run-xtests.sh tst-pam_dispatch1.pamd tst-pam_dispatch2.pamd \
>         tst-pam_dispatch3.pamd tst-pam_dispatch4.pamd \
> -@@ -51,3 +51,18 @@ EXTRA_PROGRAMS = $(XTESTS)
> +@@ -55,3 +55,18 @@ EXTRA_PROGRAMS = $(XTESTS)
>
>   xtests: $(XTESTS) run-xtests.sh
>         "$(srcdir)"/run-xtests.sh "$(srcdir)" ${XTESTS} ${NOSRCTESTS}
> diff --git a/meta/recipes-extended/pam/libpam_1.5.3.bb b/meta/recipes-extended/pam/libpam_1.6.0.bb
> similarity index 97%
> rename from meta/recipes-extended/pam/libpam_1.5.3.bb
> rename to meta/recipes-extended/pam/libpam_1.6.0.bb
> index 4dd98906064..bbea008d552 100644
> --- a/meta/recipes-extended/pam/libpam_1.5.3.bb
> +++ b/meta/recipes-extended/pam/libpam_1.6.0.bb
> @@ -21,12 +21,11 @@ SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/Linux-PAM-${PV}.tar.xz \
>             file://pam.d/common-session-noninteractive \
>             file://pam.d/other \
>             file://libpam-xtests.patch \
> -           file://0001-examples-Replace-use-of-termio.h-with-termios.h.patch \
>             file://run-ptest \
>             file://pam-volatiles.conf \
>             "
>
> -SRC_URI[sha256sum] = "7ac4b50feee004a9fa88f1dfd2d2fa738a82896763050cd773b3c54b0a818283"
> +SRC_URI[sha256sum] = "fff4a34e5bbee77e2e8f1992f27631e2329bcbf8a0563ddeb5c3389b4e3169ad"
>
>  DEPENDS = "bison-native flex-native cracklib libxml2-native virtual/crypt"
>
> --
> 2.39.2
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#197061): https://lists.openembedded.org/g/openembedded-core/message/197061
> Mute This Topic: https://lists.openembedded.org/mt/104910676/1997914
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-extended/pam/libpam/0001-examples-Replace-use-of-termio.h-with-termios.h.patch b/meta/recipes-extended/pam/libpam/0001-examples-Replace-use-of-termio.h-with-termios.h.patch
deleted file mode 100644
index 95c437df4f1..00000000000
--- a/meta/recipes-extended/pam/libpam/0001-examples-Replace-use-of-termio.h-with-termios.h.patch
+++ /dev/null
@@ -1,39 +0,0 @@ 
-From 9b96fcfa5748934b8b6a4db4ee25a5e3165905c0 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Sat, 1 Jul 2023 07:48:17 -0700
-Subject: [PATCH] examples: Replace use of termio.h with termios.h
-
-Fixes build with musl and makes it portable
-
-Upstream-Status: Backport [https://github.com/linux-pam/linux-pam/commit/5374f677e4cae669eb9accf2449178b602e8a40a]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- examples/tty_conv.c | 5 +++--
- 1 file changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/examples/tty_conv.c b/examples/tty_conv.c
-index 23f0684..db22500 100644
---- a/examples/tty_conv.c
-+++ b/examples/tty_conv.c
-@@ -6,7 +6,8 @@
- #include <string.h>
- #include <errno.h>
- #include <unistd.h>
--#include <termio.h>
-+#include <termios.h>
-+#include <sys/ioctl.h>
- #include <security/pam_appl.h>
- 
- /***************************************
-@@ -16,7 +17,7 @@
-  ***************************************/
- static void echoOff(int fd, int off)
- {
--    struct termio tty;
-+    struct termios tty;
-     if (ioctl(fd, TCGETA, &tty) < 0)
-     {
-         fprintf(stderr, "TCGETA failed: %s\n", strerror(errno));
--- 
-2.41.0
-
diff --git a/meta/recipes-extended/pam/libpam/libpam-xtests.patch b/meta/recipes-extended/pam/libpam/libpam-xtests.patch
index ea145899b49..f2dafa72a5b 100644
--- a/meta/recipes-extended/pam/libpam/libpam-xtests.patch
+++ b/meta/recipes-extended/pam/libpam/libpam-xtests.patch
@@ -1,13 +1,21 @@ 
-This patch is used to create a new sub package libpam-xtests to do more checks.
+From 060726f7e60c8ecb5bf50fd776910b290d9a0a69 Mon Sep 17 00:00:00 2001
+From: Kang Kai <kai.kang@windriver.com>
+Date: Tue, 19 Jul 2011 17:08:31 +0800
+Subject: [PATCH] This patch is used to create a new sub package libpam-xtests
+ to do more checks.
 
 Upstream-Status: Pending
 
 Signed-off-by: Kang Kai <kai.kang@windriver.com>
-Index: Linux-PAM-1.3.0/xtests/Makefile.am
-===================================================================
---- Linux-PAM-1.3.0.orig/xtests/Makefile.am
-+++ Linux-PAM-1.3.0/xtests/Makefile.am
-@@ -7,7 +7,7 @@ AM_CFLAGS = -DLIBPAM_COMPILE -I$(top_src
+---
+ xtests/Makefile.am | 17 ++++++++++++++++-
+ 1 file changed, 16 insertions(+), 1 deletion(-)
+
+diff --git a/xtests/Makefile.am b/xtests/Makefile.am
+index acf9746..9826c9f 100644
+--- a/xtests/Makefile.am
++++ b/xtests/Makefile.am
+@@ -8,7 +8,7 @@ AM_CFLAGS = -DLIBPAM_COMPILE -I$(top_srcdir)/libpam/include \
  LDADD = $(top_builddir)/libpam/libpam.la \
  	$(top_builddir)/libpam_misc/libpam_misc.la
  
@@ -16,7 +24,7 @@  Index: Linux-PAM-1.3.0/xtests/Makefile.am
  
  EXTRA_DIST = run-xtests.sh tst-pam_dispatch1.pamd tst-pam_dispatch2.pamd \
  	tst-pam_dispatch3.pamd tst-pam_dispatch4.pamd \
-@@ -51,3 +51,18 @@ EXTRA_PROGRAMS = $(XTESTS)
+@@ -55,3 +55,18 @@ EXTRA_PROGRAMS = $(XTESTS)
  
  xtests: $(XTESTS) run-xtests.sh
  	"$(srcdir)"/run-xtests.sh "$(srcdir)" ${XTESTS} ${NOSRCTESTS}
diff --git a/meta/recipes-extended/pam/libpam_1.5.3.bb b/meta/recipes-extended/pam/libpam_1.6.0.bb
similarity index 97%
rename from meta/recipes-extended/pam/libpam_1.5.3.bb
rename to meta/recipes-extended/pam/libpam_1.6.0.bb
index 4dd98906064..bbea008d552 100644
--- a/meta/recipes-extended/pam/libpam_1.5.3.bb
+++ b/meta/recipes-extended/pam/libpam_1.6.0.bb
@@ -21,12 +21,11 @@  SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/Linux-PAM-${PV}.tar.xz \
            file://pam.d/common-session-noninteractive \
            file://pam.d/other \
            file://libpam-xtests.patch \
-           file://0001-examples-Replace-use-of-termio.h-with-termios.h.patch \
            file://run-ptest \
            file://pam-volatiles.conf \
            "
 
-SRC_URI[sha256sum] = "7ac4b50feee004a9fa88f1dfd2d2fa738a82896763050cd773b3c54b0a818283"
+SRC_URI[sha256sum] = "fff4a34e5bbee77e2e8f1992f27631e2329bcbf8a0563ddeb5c3389b4e3169ad"
 
 DEPENDS = "bison-native flex-native cracklib libxml2-native virtual/crypt"