diff mbox series

mesa: fix opencl-spirv build

Message ID 20240308164728.1933548-1-f_l_k@t-online.de
State New
Headers show
Series mesa: fix opencl-spirv build | expand

Commit Message

Markus Volk March 8, 2024, 4:47 p.m. UTC
https://gitlab.freedesktop.org/mesa/mesa/-/commit/815a6647eb1383e9dc704ffcc266d85f3b13338a
adds a regression and breaks opencl-spirv build.

The next step in mesa will probably be to completely remove nir in favour of rusticl.
https://gitlab.freedesktop.org/mesa/mesa/-/issues/10674

Revert this commit to avoid that the lts version cannot use spirv
because rusticl is not yet and opencl-spirv is no longer supported.

Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 ...-meson-do-not-pull-in-clc-for-clover.patch | 49 +++++++++++++++++++
 meta/recipes-graphics/mesa/mesa.inc           |  1 +
 2 files changed, 50 insertions(+)
 create mode 100644 meta/recipes-graphics/mesa/files/0001-Revert-meson-do-not-pull-in-clc-for-clover.patch

Comments

patchtest@automation.yoctoproject.org March 8, 2024, 5:03 p.m. UTC | #1
Thank you for your submission. Patchtest identified one
or more issues with the patch. Please see the log below for
more information:

---
Testing patch /home/patchtest/share/mboxes/mesa-fix-opencl-spirv-build.patch

FAIL: test Signed-off-by presence: A patch file has been added without a Signed-off-by tag: '0001-Revert-meson-do-not-pull-in-clc-for-clover.patch' (test_patch.TestPatch.test_signed_off_by_presence)
FAIL: test Upstream-Status presence: Upstream-Status is Inappropriate, but no reason was provided (test_patch.TestPatch.test_upstream_status_presence_format)

PASS: test CVE tag format (test_patch.TestPatch.test_cve_tag_format)
PASS: test Signed-off-by presence (test_mbox.TestMbox.test_signed_off_by_presence)
PASS: test author valid (test_mbox.TestMbox.test_author_valid)
PASS: test commit message presence (test_mbox.TestMbox.test_commit_message_presence)
PASS: test max line length (test_metadata.TestMetadata.test_max_line_length)
PASS: test mbox format (test_mbox.TestMbox.test_mbox_format)
PASS: test non-AUH upgrade (test_mbox.TestMbox.test_non_auh_upgrade)
PASS: test shortlog format (test_mbox.TestMbox.test_shortlog_format)
PASS: test shortlog length (test_mbox.TestMbox.test_shortlog_length)

SKIP: pretest pylint: No python related patches, skipping test (test_python_pylint.PyLint.pretest_pylint)
SKIP: pretest src uri left files: No modified recipes, skipping pretest (test_metadata.TestMetadata.pretest_src_uri_left_files)
SKIP: test CVE check ignore: No modified recipes or older target branch, skipping test (test_metadata.TestMetadata.test_cve_check_ignore)
SKIP: test bugzilla entry format: No bug ID found (test_mbox.TestMbox.test_bugzilla_entry_format)
SKIP: test lic files chksum modified not mentioned: No modified recipes, skipping test (test_metadata.TestMetadata.test_lic_files_chksum_modified_not_mentioned)
SKIP: test lic files chksum presence: No added recipes, skipping test (test_metadata.TestMetadata.test_lic_files_chksum_presence)
SKIP: test license presence: No added recipes, skipping test (test_metadata.TestMetadata.test_license_presence)
SKIP: test pylint: No python related patches, skipping test (test_python_pylint.PyLint.test_pylint)
SKIP: test series merge on head: Merge test is disabled for now (test_mbox.TestMbox.test_series_merge_on_head)
SKIP: test src uri left files: No modified recipes, skipping pretest (test_metadata.TestMetadata.test_src_uri_left_files)
SKIP: test summary presence: No added recipes, skipping test (test_metadata.TestMetadata.test_summary_presence)
SKIP: test target mailing list: Series merged, no reason to check other mailing lists (test_mbox.TestMbox.test_target_mailing_list)

---

Please address the issues identified and
submit a new revision of the patch, or alternatively, reply to this
email with an explanation of why the patch should be accepted. If you
believe these results are due to an error in patchtest, please submit a
bug at https://bugzilla.yoctoproject.org/ (use the 'Patchtest' category
under 'Yocto Project Subprojects'). For more information on specific
failures, see: https://wiki.yoctoproject.org/wiki/Patchtest. Thank
you!
Alexander Kanavin March 8, 2024, 6:09 p.m. UTC | #2
Please include an explanation of when the patch can be removed from
oe-core directly into the patch; it's not enough to say it's a revert
and thus inappropriate for upstream submission.

Alex

On Fri, 8 Mar 2024 at 17:47, Markus Volk <f_l_k@t-online.de> wrote:
>
> https://gitlab.freedesktop.org/mesa/mesa/-/commit/815a6647eb1383e9dc704ffcc266d85f3b13338a
> adds a regression and breaks opencl-spirv build.
>
> The next step in mesa will probably be to completely remove nir in favour of rusticl.
> https://gitlab.freedesktop.org/mesa/mesa/-/issues/10674
>
> Revert this commit to avoid that the lts version cannot use spirv
> because rusticl is not yet and opencl-spirv is no longer supported.
>
> Signed-off-by: Markus Volk <f_l_k@t-online.de>
> ---
>  ...-meson-do-not-pull-in-clc-for-clover.patch | 49 +++++++++++++++++++
>  meta/recipes-graphics/mesa/mesa.inc           |  1 +
>  2 files changed, 50 insertions(+)
>  create mode 100644 meta/recipes-graphics/mesa/files/0001-Revert-meson-do-not-pull-in-clc-for-clover.patch
>
> diff --git a/meta/recipes-graphics/mesa/files/0001-Revert-meson-do-not-pull-in-clc-for-clover.patch b/meta/recipes-graphics/mesa/files/0001-Revert-meson-do-not-pull-in-clc-for-clover.patch
> new file mode 100644
> index 0000000000..dffcc6feba
> --- /dev/null
> +++ b/meta/recipes-graphics/mesa/files/0001-Revert-meson-do-not-pull-in-clc-for-clover.patch
> @@ -0,0 +1,49 @@
> +From fe4600de549549fbb3033fc1b37904ba6b3fe2af Mon Sep 17 00:00:00 2001
> +From: Markus Volk <f_l_k@t-online.de>
> +Date: Fri, 8 Mar 2024 15:53:11 +0100
> +Subject: [PATCH] Revert "meson: do not pull in clc for clover"
> +
> +This reverts commit 815a6647eb1383e9dc704ffcc266d85f3b13338a.
> +Upstream-Status: Inappropriate
> +---
> + meson.build              | 3 ++-
> + src/compiler/meson.build | 2 +-
> + 2 files changed, 3 insertions(+), 2 deletions(-)
> +
> +diff --git a/meson.build b/meson.build
> +index 25e92ea5f95..3956e19c08f 100644
> +--- a/meson.build
> ++++ b/meson.build
> +@@ -818,6 +818,7 @@ if _opencl != 'disabled'
> +     error('The Clover OpenCL state tracker requires rtti')
> +   endif
> +
> ++  with_clc = true
> +   with_gallium_opencl = true
> +   with_opencl_icd = _opencl == 'icd'
> + else
> +@@ -842,7 +843,7 @@ if with_gallium_rusticl
> + endif
> +
> + dep_clc = null_dep
> +-if with_gallium_opencl or with_clc
> ++if with_clc
> +   dep_clc = dependency('libclc')
> + endif
> +
> +diff --git a/src/compiler/meson.build b/src/compiler/meson.build
> +index 8d73544c6d8..1dae56d1b2b 100644
> +--- a/src/compiler/meson.build
> ++++ b/src/compiler/meson.build
> +@@ -79,7 +79,7 @@ subdir('nir')
> +
> + subdir('spirv')
> +
> +-if with_clc
> ++if with_opencl_spirv
> +   subdir('clc')
> + endif
> + if with_gallium
> +--
> +2.44.0
> +
> diff --git a/meta/recipes-graphics/mesa/mesa.inc b/meta/recipes-graphics/mesa/mesa.inc
> index 12d7a18eb8..f5a6392d28 100644
> --- a/meta/recipes-graphics/mesa/mesa.inc
> +++ b/meta/recipes-graphics/mesa/mesa.inc
> @@ -20,6 +20,7 @@ SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
>             file://0001-gallium-Fix-build-with-llvm-17.patch \
>             file://0001-drisw-fix-build-without-dri3.patch \
>             file://0002-glxext-don-t-try-zink-if-not-enabled-in-mesa.patch \
> +           file://0001-Revert-meson-do-not-pull-in-clc-for-clover.patch \
>  "
>
>  SRC_URI[sha256sum] = "94e28a8edad06d8ed2b83eb53f253b9eb5aa62c3080f939702e1b3039b56c9e8"
> --
> 2.44.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#196857): https://lists.openembedded.org/g/openembedded-core/message/196857
> Mute This Topic: https://lists.openembedded.org/mt/104812320/1686489
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [alex.kanavin@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-graphics/mesa/files/0001-Revert-meson-do-not-pull-in-clc-for-clover.patch b/meta/recipes-graphics/mesa/files/0001-Revert-meson-do-not-pull-in-clc-for-clover.patch
new file mode 100644
index 0000000000..dffcc6feba
--- /dev/null
+++ b/meta/recipes-graphics/mesa/files/0001-Revert-meson-do-not-pull-in-clc-for-clover.patch
@@ -0,0 +1,49 @@ 
+From fe4600de549549fbb3033fc1b37904ba6b3fe2af Mon Sep 17 00:00:00 2001
+From: Markus Volk <f_l_k@t-online.de>
+Date: Fri, 8 Mar 2024 15:53:11 +0100
+Subject: [PATCH] Revert "meson: do not pull in clc for clover"
+
+This reverts commit 815a6647eb1383e9dc704ffcc266d85f3b13338a.
+Upstream-Status: Inappropriate
+---
+ meson.build              | 3 ++-
+ src/compiler/meson.build | 2 +-
+ 2 files changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index 25e92ea5f95..3956e19c08f 100644
+--- a/meson.build
++++ b/meson.build
+@@ -818,6 +818,7 @@ if _opencl != 'disabled'
+     error('The Clover OpenCL state tracker requires rtti')
+   endif
+ 
++  with_clc = true
+   with_gallium_opencl = true
+   with_opencl_icd = _opencl == 'icd'
+ else
+@@ -842,7 +843,7 @@ if with_gallium_rusticl
+ endif
+ 
+ dep_clc = null_dep
+-if with_gallium_opencl or with_clc
++if with_clc
+   dep_clc = dependency('libclc')
+ endif
+ 
+diff --git a/src/compiler/meson.build b/src/compiler/meson.build
+index 8d73544c6d8..1dae56d1b2b 100644
+--- a/src/compiler/meson.build
++++ b/src/compiler/meson.build
+@@ -79,7 +79,7 @@ subdir('nir')
+ 
+ subdir('spirv')
+ 
+-if with_clc
++if with_opencl_spirv
+   subdir('clc')
+ endif
+ if with_gallium
+-- 
+2.44.0
+
diff --git a/meta/recipes-graphics/mesa/mesa.inc b/meta/recipes-graphics/mesa/mesa.inc
index 12d7a18eb8..f5a6392d28 100644
--- a/meta/recipes-graphics/mesa/mesa.inc
+++ b/meta/recipes-graphics/mesa/mesa.inc
@@ -20,6 +20,7 @@  SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
            file://0001-gallium-Fix-build-with-llvm-17.patch \
            file://0001-drisw-fix-build-without-dri3.patch \
            file://0002-glxext-don-t-try-zink-if-not-enabled-in-mesa.patch \
+           file://0001-Revert-meson-do-not-pull-in-clc-for-clover.patch \
 "
 
 SRC_URI[sha256sum] = "94e28a8edad06d8ed2b83eb53f253b9eb5aa62c3080f939702e1b3039b56c9e8"