diff mbox series

[2/3] rust: Revert PGO to it's default

Message ID 20240229163242.1415066-2-Yash.Shinde@windriver.com
State Accepted, archived
Commit 83bd5e12e069a60a870a7c7ed046a2827eb777a1
Headers show
Series [1/3] rust: Upgrade 1.74.1 -> 1.75.0 | expand

Commit Message

Yash Shinde Feb. 29, 2024, 4:32 p.m. UTC
From: Yash Shinde <Yash.Shinde@windriver.com>

The rust profiler PGO (Profile-guided Optimization) options was disabled as a part rustdoc reproducibility fix.
https://git.yoctoproject.org/poky/commit/meta/recipes-devtools/rust?id=321aebfa281bd28e368c684ece57867f6bd0cbe7

But, other applications (such as to build chromium with poky) requires PGO enabled (https://github.com/OSSystems/meta-browser/issues/786).

For reproducibility issue fix only "rust-demangler" change is sufficient in commit#321aebfa281. The PGO is reverted to it's default.

Signed-off-by: Yash Shinde <Yash.Shinde@windriver.com>
---
 meta/recipes-devtools/rust/rust_1.75.0.bb | 4 ----
 1 file changed, 4 deletions(-)
diff mbox series

Patch

diff --git a/meta/recipes-devtools/rust/rust_1.75.0.bb b/meta/recipes-devtools/rust/rust_1.75.0.bb
index ee1ce9e050..76e1fe2d84 100644
--- a/meta/recipes-devtools/rust/rust_1.75.0.bb
+++ b/meta/recipes-devtools/rust/rust_1.75.0.bb
@@ -146,10 +146,6 @@  python do_configure() {
     rustc = d.expand("${WORKDIR}/rust-snapshot/bin/rustc")
     config.set("build", "rustc", e(rustc))
 
-    # Support for the profiler runtime to generate e.g. coverage report,
-    # PGO etc.
-    config.set("build", "profiler", e(False))
-
     cargo = d.expand("${WORKDIR}/rust-snapshot/bin/cargo")
     config.set("build", "cargo", e(cargo))