diff mbox series

python3: dont disable readline module for editline

Message ID 20240227215631.1593504-1-nick.owens@eero.com
State Accepted, archived
Commit e92d7dd55d16aa311a95c4e8bb4633e6ebb9900f
Headers show
Series python3: dont disable readline module for editline | expand

Commit Message

Nick Owens Feb. 27, 2024, 9:56 p.m. UTC
if we use editline, then the readline module must also be enabled for
python to build the readline module and link it against libedit.

Signed-off-by: Nick Owens <nick.owens@eero.com>
---
 meta/recipes-devtools/python/python3_3.12.1.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Khem Raj March 29, 2024, 2:39 p.m. UTC | #1
unfortunately this change regresses ptests on musl based systems. Similar to https://github.com/python/cpython/issues/87338
but that issue is fixed so enabling both must be triggering it again in some way. 

 ======================================================================
   FAIL: test_write_read_append (test.test_readline.TestHistoryManipulation.test_write_read_append)
   ----------------------------------------------------------------------
   Traceback (most recent call last):
     File "/usr/lib/python3.12/test/test_readline.py", line 96, in test_write_read_append
       self.assertEqual(readline.get_current_history_length(), 3)
   AssertionError: 4 != 3

   ----------------------------------------------------------------------
   Ran 9 tests in 0.178s

   FAILED (failures=1, skipped=1)
   test test_readline failed
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3_3.12.1.bb b/meta/recipes-devtools/python/python3_3.12.1.bb
index 771902cd2c..b4916d8cef 100644
--- a/meta/recipes-devtools/python/python3_3.12.1.bb
+++ b/meta/recipes-devtools/python/python3_3.12.1.bb
@@ -113,7 +113,7 @@  do_configure:prepend () {
     cat > ${B}/Modules/Setup.local << EOF
 *disabled*
 ${@bb.utils.contains('PACKAGECONFIG', 'gdbm', '', '_gdbm _dbm', d)}
-${@bb.utils.contains('PACKAGECONFIG', 'readline', '', 'readline', d)}
+${@bb.utils.contains_any('PACKAGECONFIG', 'readline editline', '', 'readline', d)}
 ${@bb.utils.contains('PACKAGECONFIG', 'tk', '', '_tkinter', d)}
 EOF
 }