diff mbox series

core-image-initramfs-boot: install all kernel modules

Message ID 20240226193848.3763932-1-ross.burton@arm.com
State New
Headers show
Series core-image-initramfs-boot: install all kernel modules | expand

Commit Message

Ross Burton Feb. 26, 2024, 7:38 p.m. UTC
From: Ross Burton <ross.burton@arm.com>

The point of a "just boot" initramfs is to contain the kernel modules so
that the kernel can find the real root filesystem, so explicitly add them.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta/recipes-core/images/core-image-initramfs-boot.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Richard Purdie Feb. 27, 2024, 10:42 a.m. UTC | #1
On Mon, 2024-02-26 at 19:38 +0000, Ross Burton wrote:
> From: Ross Burton <ross.burton@arm.com>
> 
> The point of a "just boot" initramfs is to contain the kernel modules so
> that the kernel can find the real root filesystem, so explicitly add them.
> 
> Signed-off-by: Ross Burton <ross.burton@arm.com>
> ---
>  meta/recipes-core/images/core-image-initramfs-boot.bb | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/meta/recipes-core/images/core-image-initramfs-boot.bb b/meta/recipes-core/images/core-image-initramfs-boot.bb
> index 72589447513..cb6837a43d6 100644
> --- a/meta/recipes-core/images/core-image-initramfs-boot.bb
> +++ b/meta/recipes-core/images/core-image-initramfs-boot.bb
> @@ -4,7 +4,7 @@ LICENSE = "MIT"
>  
>  INITRAMFS_SCRIPTS ?= "initramfs-framework-base initramfs-module-udev"
>  
> -PACKAGE_INSTALL = "${INITRAMFS_SCRIPTS} ${VIRTUAL-RUNTIME_base-utils} base-passwd"
> +PACKAGE_INSTALL = "${INITRAMFS_SCRIPTS} ${VIRTUAL-RUNTIME_base-utils} base-passwd kernel-modules"
>  
>  # Ensure the initramfs only contains the bare minimum
>  IMAGE_FEATURES = ""

We've managed this long without doing this and that is a pretty
horrible potentially large dependency to add in :(

Yes, the system may need some of the modules to load the rootfs but a
large majority will not be. 

I'd much prefer we had a list of things which should be promoted into
the initramfs if present.

I appreciate that isn't straigtforward to do but equally if I merge
this, we basically just give in and start to look like a desktop
distro, lets just put everything everywhere :(.

Cheers,

Richard
diff mbox series

Patch

diff --git a/meta/recipes-core/images/core-image-initramfs-boot.bb b/meta/recipes-core/images/core-image-initramfs-boot.bb
index 72589447513..cb6837a43d6 100644
--- a/meta/recipes-core/images/core-image-initramfs-boot.bb
+++ b/meta/recipes-core/images/core-image-initramfs-boot.bb
@@ -4,7 +4,7 @@  LICENSE = "MIT"
 
 INITRAMFS_SCRIPTS ?= "initramfs-framework-base initramfs-module-udev"
 
-PACKAGE_INSTALL = "${INITRAMFS_SCRIPTS} ${VIRTUAL-RUNTIME_base-utils} base-passwd"
+PACKAGE_INSTALL = "${INITRAMFS_SCRIPTS} ${VIRTUAL-RUNTIME_base-utils} base-passwd kernel-modules"
 
 # Ensure the initramfs only contains the bare minimum
 IMAGE_FEATURES = ""