diff mbox series

pixman: explicitly disable openmp in native builds

Message ID 20240226133151.2107307-1-martin.jansa@gmail.com
State New
Headers show
Series pixman: explicitly disable openmp in native builds | expand

Commit Message

Martin Jansa Feb. 26, 2024, 1:31 p.m. UTC
* on some hosts (e.g. on my gentoo after recent update) it detects OpenMP in do_configure:
  Run-time dependency OpenMP found: YES 4.5
  but then fails in do_compile as shown in:
  http://errors.yoctoproject.org/Errors/Details/754632/

  gcc  -o test/fetch-test test/fetch-test.p/fetch-test.c.o -LTOPDIR/tmp-glibc/work/x86_64-linux/pixman-native/0.42.2/recipe-sysroot-native/usr/lib -LTOPDIR/tmp-glibc/work/x86_64-linux/pixman-native/0.42.2/recipe-sysroot-native/lib -Wl,--as-needed -Wl,--no-undefined -Wl,--enable-new-dtags -Wl,-rpath-link,TOPDIR/tmp-glibc/work/x86_64-linux/pixman-native/0.42.2/recipe-sysroot-native/usr/lib -Wl,-rpath-link,TOPDIR/tmp-glibc/work/x86_64-linux/pixman-native/0.42.2/recipe-sysroot-native/lib -Wl,-rpath,TOPDIR/tmp-glibc/work/x86_64-linux/pixman-native/0.42.2/recipe-sysroot-native/usr/lib -Wl,-rpath,TOPDIR/tmp-glibc/work/x86_64-linux/pixman-native/0.42.2/recipe-sysroot-native/lib -Wl,-O1 '-Wl,-rpath,$ORIGIN/../pixman' -Wl,-rpath-link,TOPDIR/tmp-glibc/work/x86_64-linux/pixman-native/0.42.2/build/pixman -Wl,--start-group test/libtestutils.a pixman/libpixman-1.so.0.42.2 -pthread -fopenmp -fopenmp -lm -Wl,--end-group
  gcc: fatal error: cannot read spec file ‘libgomp.spec’: No such file or directory
  compilation terminated.

  it's only used in tests, so should be safe to disable for native builds

* the check in meson uses /usr/include/omp.h which is provided by libomp
  even when openmp support is disabled in native gcc in gentoo this happned
  after switching from 17.1 profile to 23.0 which doesn't include openmp
  USE flag by default, if you later run depclean it will uninstall libomp
  as well which will fix this conflict in meson's OpenMP autodetection

Signed-off-by: Martin Jansa <martin.jansa@gmail.com>
---
 meta/recipes-graphics/xorg-lib/pixman_0.42.2.bb | 2 ++
 1 file changed, 2 insertions(+)
diff mbox series

Patch

diff --git a/meta/recipes-graphics/xorg-lib/pixman_0.42.2.bb b/meta/recipes-graphics/xorg-lib/pixman_0.42.2.bb
index 8a93f8c0fe..23ae0cbb27 100644
--- a/meta/recipes-graphics/xorg-lib/pixman_0.42.2.bb
+++ b/meta/recipes-graphics/xorg-lib/pixman_0.42.2.bb
@@ -40,6 +40,8 @@  EXTRA_OEMESON:append:class-target:powerpc64le = " ${@bb.utils.contains("TUNE_FEA
 EXTRA_OEMESON:append:armv7a = "${@bb.utils.contains("TUNE_FEATURES","neon",""," -Dneon=disabled",d)}"
 EXTRA_OEMESON:append:armv7ve = "${@bb.utils.contains("TUNE_FEATURES","neon",""," -Dneon=disabled",d)}"
 
+EXTRA_OEMESON:append:class-native = " -Dopenmp=disabled"
+
 BBCLASSEXTEND = "native nativesdk"
 
 CVE_STATUS[CVE-2023-37769] = "not-applicable-config: stress-test is an uninstalled test"