diff mbox series

[RFC,03/10] bblayers/makesetup: include local repository paths in discovered layer repo data

Message ID 20240223120134.3713127-3-alex@linutronix.de
State New
Headers show
Series [RFC,01/10] scripts/oe-setup-build: write a build environment initialization one-liner into the build directory | expand

Commit Message

Alexander Kanavin Feb. 23, 2024, 12:01 p.m. UTC
This can be useful when the caller needs to know where the repos actually
are on local disk (for example to make a local copy of them or obtain
additional information about them).

This field however should be removed from the json output in oe-setup-layers
plugin, as it is host-specific and not part of the schema.

Signed-off-by: Alexander Kanavin <alex@linutronix.de>
---
 meta/lib/bblayers/makesetup.py                    | 1 +
 meta/lib/bblayers/setupwriters/oe-setup-layers.py | 2 ++
 2 files changed, 3 insertions(+)
diff mbox series

Patch

diff --git a/meta/lib/bblayers/makesetup.py b/meta/lib/bblayers/makesetup.py
index ecfa65adc7f..814cbb6357c 100644
--- a/meta/lib/bblayers/makesetup.py
+++ b/meta/lib/bblayers/makesetup.py
@@ -89,6 +89,7 @@  class MakeSetupPlugin(LayerPlugin):
             repos_nopaths[r_nopath] = repos[r]
             r_relpath = os.path.relpath(r, top_path)
             repos_nopaths[r_nopath]['path'] = r_relpath
+            repos_nopaths[r_nopath]['originpath'] = r
         return repos_nopaths
 
     def do_make_setup(self, args):
diff --git a/meta/lib/bblayers/setupwriters/oe-setup-layers.py b/meta/lib/bblayers/setupwriters/oe-setup-layers.py
index 59ca968ff33..56c929471e6 100644
--- a/meta/lib/bblayers/setupwriters/oe-setup-layers.py
+++ b/meta/lib/bblayers/setupwriters/oe-setup-layers.py
@@ -85,6 +85,8 @@  class OeSetupLayersWriter():
             if not os.path.exists(args.destdir):
                 os.makedirs(args.destdir)
             repos = parent.make_repo_config(args.destdir)
+            for r in repos.values():
+                del r['originpath']
             json = {"version":"1.0","sources":repos}
             if not repos:
                 err = "Could not determine layer sources"