diff mbox series

[2/2] python3-attrs: skip test failing with pytest-8

Message ID 20240216161553.3217554-3-tim.orling@konsulko.com
State Accepted, archived
Commit 5af87eda524bb0affe207c006f67b4191f6ce746
Headers show
Series Fix for python3-pytest 8.0.0 related failure | expand

Commit Message

Tim Orling Feb. 16, 2024, 4:15 p.m. UTC
tests/test_funcs.py test_unknown test case is failing with
pytest 8. Skip it for now until upstream has a fix.

https://github.com/python-attrs/attrs/issues/1233

Signed-off-by: Tim Orling <tim.orling@konsulko.com>
---
Tested with core-image-ptest-python3-attrs on qemux86-64.

 ...funcs-skip-test_unknown-for-pytest-8.patch | 30 +++++++++++++++++++
 .../python/python3-attrs_23.2.0.bb            |  1 +
 2 files changed, 31 insertions(+)
 create mode 100644 meta/recipes-devtools/python/python3-attrs/0001-test_funcs-skip-test_unknown-for-pytest-8.patch
diff mbox series

Patch

diff --git a/meta/recipes-devtools/python/python3-attrs/0001-test_funcs-skip-test_unknown-for-pytest-8.patch b/meta/recipes-devtools/python/python3-attrs/0001-test_funcs-skip-test_unknown-for-pytest-8.patch
new file mode 100644
index 00000000000..bb69c0f1573
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-attrs/0001-test_funcs-skip-test_unknown-for-pytest-8.patch
@@ -0,0 +1,30 @@ 
+From cbe95e1aa6d95195dce13406a6f0522b2964babc Mon Sep 17 00:00:00 2001
+From: Tim Orling <tim.orling@konsulko.com>
+Date: Fri, 16 Feb 2024 07:17:19 -0800
+Subject: [PATCH] test_funcs: skip test_unknown for pytest 8
+
+https://github.com/python-attrs/attrs/issues/1233
+
+Upstream-Status: Inappropriate [Test case needs to be properly fixed upstream]
+
+Signed-off-by: Tim Orling <tim.orling@konsulko.com>
+---
+ tests/test_funcs.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/test_funcs.py b/tests/test_funcs.py
+index 044aaab..0872c31 100644
+--- a/tests/test_funcs.py
++++ b/tests/test_funcs.py
+@@ -593,7 +593,7 @@ class TestAssoc:
+         for k, v in change_dict.items():
+             assert getattr(changed, k) == v
+ 
+-    @given(simple_classes())
++    @pytest.mark.skip('Broken with pytest 8. See https://github.com/python-attrs/attrs/issues/1233')
+     def test_unknown(self, C):
+         """
+         Wanting to change an unknown attribute raises an
+-- 
+2.34.1
+
diff --git a/meta/recipes-devtools/python/python3-attrs_23.2.0.bb b/meta/recipes-devtools/python/python3-attrs_23.2.0.bb
index 7b6a6bd94c9..cdd78c2bd9d 100644
--- a/meta/recipes-devtools/python/python3-attrs_23.2.0.bb
+++ b/meta/recipes-devtools/python/python3-attrs_23.2.0.bb
@@ -8,6 +8,7 @@  SRC_URI[sha256sum] = "935dc3b529c262f6cf76e50877d35a4bd3c1de194fd41f47a2b7ae8f19
 inherit pypi ptest python_hatchling
 
 SRC_URI += " \
+	file://0001-test_funcs-skip-test_unknown-for-pytest-8.patch \
 	file://run-ptest \
 "