diff mbox series

mesa: update 23.3.5 -> 24.0.0

Message ID 20240214181453.795654-1-f_l_k@t-online.de
State Accepted, archived
Commit 8975bf600de8a3faa8d222f50beb1e2b02fb2870
Headers show
Series mesa: update 23.3.5 -> 24.0.0 | expand

Commit Message

Markus Volk Feb. 14, 2024, 6:14 p.m. UTC
- refresh 0001-meson.build-check-for-all-linux-host_os-combinations.patch
- rework VIDEO_CODECS. mesa now provides options for 'all' and 'all_free'
  Adjust accordingly.
  Free codecs are built by default:
    Codecs                       : av1dec av1enc vp9dec
  If LICENSE_FLAGS_ACCEPTED contains 'commercial' all supported codecs are built:
    Codecs                       : vc1dec h264dec h264enc h265dec h265enc
                                   av1dec av1enc vp9dec

Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 ...ld-check-for-all-linux-host_os-combinations.patch | 12 ++++++------
 .../mesa/{mesa-gl_23.3.5.bb => mesa-gl_24.0.0.bb}    |  0
 meta/recipes-graphics/mesa/mesa.inc                  |  8 ++++----
 .../mesa/{mesa_23.3.5.bb => mesa_24.0.0.bb}          |  0
 4 files changed, 10 insertions(+), 10 deletions(-)
 rename meta/recipes-graphics/mesa/{mesa-gl_23.3.5.bb => mesa-gl_24.0.0.bb} (100%)
 rename meta/recipes-graphics/mesa/{mesa_23.3.5.bb => mesa_24.0.0.bb} (100%)

Comments

Ross Burton Feb. 15, 2024, 11:25 a.m. UTC | #1
Mesa 24.0.0 is - as clearly indicated on the web site - a development snapshot.  24.0.1 is now out, can you upgrade to that?

Ross

> On 14 Feb 2024, at 18:14, Markus Volk via lists.openembedded.org <f_l_k=t-online.de@lists.openembedded.org> wrote:
> 
> - refresh 0001-meson.build-check-for-all-linux-host_os-combinations.patch
> - rework VIDEO_CODECS. mesa now provides options for 'all' and 'all_free'
>  Adjust accordingly.
>  Free codecs are built by default:
>    Codecs                       : av1dec av1enc vp9dec
>  If LICENSE_FLAGS_ACCEPTED contains 'commercial' all supported codecs are built:
>    Codecs                       : vc1dec h264dec h264enc h265dec h265enc
>                                   av1dec av1enc vp9dec
> 
> Signed-off-by: Markus Volk <f_l_k@t-online.de>
> ---
> ...ld-check-for-all-linux-host_os-combinations.patch | 12 ++++++------
> .../mesa/{mesa-gl_23.3.5.bb => mesa-gl_24.0.0.bb}    |  0
> meta/recipes-graphics/mesa/mesa.inc                  |  8 ++++----
> .../mesa/{mesa_23.3.5.bb => mesa_24.0.0.bb}          |  0
> 4 files changed, 10 insertions(+), 10 deletions(-)
> rename meta/recipes-graphics/mesa/{mesa-gl_23.3.5.bb => mesa-gl_24.0.0.bb} (100%)
> rename meta/recipes-graphics/mesa/{mesa_23.3.5.bb => mesa_24.0.0.bb} (100%)
> 
> diff --git a/meta/recipes-graphics/mesa/files/0001-meson.build-check-for-all-linux-host_os-combinations.patch b/meta/recipes-graphics/mesa/files/0001-meson.build-check-for-all-linux-host_os-combinations.patch
> index fadd6ee201..b0be8d0feb 100644
> --- a/meta/recipes-graphics/mesa/files/0001-meson.build-check-for-all-linux-host_os-combinations.patch
> +++ b/meta/recipes-graphics/mesa/files/0001-meson.build-check-for-all-linux-host_os-combinations.patch
> @@ -23,21 +23,21 @@ diff --git a/meson.build b/meson.build
> index 35cc5f1..9a49c0d 100644
> --- a/meson.build
> +++ b/meson.build
> -@@ -121,7 +121,7 @@ with_any_opengl = with_opengl or with_gles1 or with_gles2
> +@@ -128,7 +128,7 @@
>  # Only build shared_glapi if at least one OpenGL API is enabled
>  with_shared_glapi = with_shared_glapi and with_any_opengl
> 
> --system_has_kms_drm = ['openbsd', 'netbsd', 'freebsd', 'gnu/kfreebsd', 'dragonfly', 'linux', 'sunos', 'android'].contains(host_machine.system())
> -+system_has_kms_drm = ['openbsd', 'netbsd', 'freebsd', 'gnu/kfreebsd', 'dragonfly', 'linux', 'sunos', 'android'].contains(host_machine.system()) or host_machine.system().startswith('linux')
> +-system_has_kms_drm = ['openbsd', 'netbsd', 'freebsd', 'gnu/kfreebsd', 'dragonfly', 'linux', 'sunos', 'android', 'managarm'].contains(host_machine.system())
> ++system_has_kms_drm = ['openbsd', 'netbsd', 'freebsd', 'gnu/kfreebsd', 'dragonfly', 'linux', 'sunos', 'android', 'managarm'].contains(host_machine.system()) or host_machine.system().startswith('linux')
> 
>  gallium_drivers = get_option('gallium-drivers')
>  if gallium_drivers.contains('auto')
> -@@ -956,7 +956,7 @@ if cc.has_function('fmemopen')
> +@@ -998,7 +998,7 @@
>  endif
> 
>  # TODO: this is very incomplete
> --if ['linux', 'cygwin', 'gnu', 'freebsd', 'gnu/kfreebsd', 'haiku', 'android'].contains(host_machine.system())
> -+if ['linux', 'cygwin', 'gnu', 'freebsd', 'gnu/kfreebsd', 'haiku'].contains(host_machine.system()) or host_machine.system().startswith('linux')
> +-if ['linux', 'cygwin', 'gnu', 'freebsd', 'gnu/kfreebsd', 'haiku', 'android', 'managarm'].contains(host_machine.system())
> ++if ['linux', 'cygwin', 'gnu', 'freebsd', 'gnu/kfreebsd', 'haiku', 'android', 'managarm'].contains(host_machine.system()) or host_machine.system().startswith('linux')
>    pre_args += '-D_GNU_SOURCE'
>  elif host_machine.system() == 'sunos'
>    pre_args += '-D__EXTENSIONS__'
> diff --git a/meta/recipes-graphics/mesa/mesa-gl_23.3.5.bb b/meta/recipes-graphics/mesa/mesa-gl_24.0.0.bb
> similarity index 100%
> rename from meta/recipes-graphics/mesa/mesa-gl_23.3.5.bb
> rename to meta/recipes-graphics/mesa/mesa-gl_24.0.0.bb
> diff --git a/meta/recipes-graphics/mesa/mesa.inc b/meta/recipes-graphics/mesa/mesa.inc
> index 3a7b91f637..fabc52f0e7 100644
> --- a/meta/recipes-graphics/mesa/mesa.inc
> +++ b/meta/recipes-graphics/mesa/mesa.inc
> @@ -20,7 +20,7 @@ SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
>            file://0001-gallium-Fix-build-with-llvm-17.patch \
> "
> 
> -SRC_URI[sha256sum] = "69ccb1278641ff5bad71ca0f866188aeb1a92aadc4dbb9d35f50aebec5b8b50f"
> +SRC_URI[sha256sum] = "dc7e8c077bc5884df95478263b34bdebb7e88e600689cb56fb07be2b8c304c36"
> 
> UPSTREAM_CHECK_GITTAGREGEX = "mesa-(?P<pver>\d+(\.\d+)+)"
> 
> @@ -81,12 +81,12 @@ def strip_comma(s):
> 
> PACKAGECONFIG = " \
> gallium \
> + video-codecs \
> ${@bb.utils.filter('DISTRO_FEATURES', 'x11 vulkan wayland', d)} \
> ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'opengl egl gles gbm virgl', '', d)} \
> ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'dri3', '', d)} \
> ${@bb.utils.contains('DISTRO_FEATURES', 'x11 vulkan', 'dri3', '', d)} \
> ${@bb.utils.contains('DISTRO_FEATURES', 'vulkan', 'zink', '', d)} \
> - ${@bb.utils.contains('LICENSE_FLAGS_ACCEPTED', 'commercial', 'video-codecs', '', d)} \
> "
> 
> PACKAGECONFIG:append:class-native = "gallium-llvm r600"
> @@ -203,8 +203,8 @@ PACKAGECONFIG[unwind] = "-Dlibunwind=enabled,-Dlibunwind=disabled,libunwind"
> 
> PACKAGECONFIG[lmsensors] = "-Dlmsensors=enabled,-Dlmsensors=disabled,lmsensors"
> 
> -VIDEO_CODECS = "vc1dec,h264dec,h264enc,h265dec,h265enc"
> -PACKAGECONFIG[video-codecs] = "-Dvideo-codecs=${@strip_comma('${VIDEO_CODECS}')}, -Dvideo-codecs=''"
> +VIDEO_CODECS ?= "${@bb.utils.contains('LICENSE_FLAGS_ACCEPTED', 'commercial', 'all', 'all_free', d)}"
> +PACKAGECONFIG[video-codecs] = "-Dvideo-codecs=${VIDEO_CODECS}, -Dvideo-codecs=''"
> 
> # llvmpipe is slow if compiled with -fomit-frame-pointer (e.g. -O2)
> FULL_OPTIMIZATION:append = " -fno-omit-frame-pointer"
> diff --git a/meta/recipes-graphics/mesa/mesa_23.3.5.bb b/meta/recipes-graphics/mesa/mesa_24.0.0.bb
> similarity index 100%
> rename from meta/recipes-graphics/mesa/mesa_23.3.5.bb
> rename to meta/recipes-graphics/mesa/mesa_24.0.0.bb
> -- 
> 2.43.0
> 
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#195492): https://lists.openembedded.org/g/openembedded-core/message/195492
> Mute This Topic: https://lists.openembedded.org/mt/104358245/6875888
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [ross.burton@arm.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Richard Purdie Feb. 15, 2024, 11:44 a.m. UTC | #2
On Thu, 2024-02-15 at 11:25 +0000, Ross Burton wrote:
> Mesa 24.0.0 is - as clearly indicated on the web site - a developmentĀ 
> snapshot.  24.0.1 is now out, can you upgrade to that?

FWIW I did take this knowing that it was a development snapshot and
they we'd be very likely to be able to update to the .1 before release!

The timing of this and the llvm release is always tricky.

Cheers,

Richard
Alexander Kanavin Feb. 15, 2024, 11:50 a.m. UTC | #3
On Thu, 15 Feb 2024 at 12:44, Richard Purdie
<richard.purdie@linuxfoundation.org> wrote:
> > Mesa 24.0.0 is - as clearly indicated on the web site - a development
> > snapshot.  24.0.1 is now out, can you upgrade to that?
>
> FWIW I did take this knowing that it was a development snapshot and
> they we'd be very likely to be able to update to the .1 before release!
>
> The timing of this and the llvm release is always tricky.

Mesa upstream does describe .0 releases this as 'development' in
release notes but that description isn't hand written and comes from a
template somewhere.

.0 are always preceded by multiple release candidates[1], and .1
always follows quickly. I don't think there's a real problem taking
.0.

[1] https://gitlab.freedesktop.org/mesa/mesa/-/tags

Alex
Markus Volk Feb. 15, 2024, 4:45 p.m. UTC | #4
On Thu, Feb 15 2024 at 11:25:24 AM +00:00:00, Ross Burton 
<Ross.Burton@arm.com> wrote:
> Mesa 24.0.0 is - as clearly indicated on the web site - a development 
> snapshot.  24.0.1 is now out, can you upgrade to that?

Thank you. I didn't see that mentioned in the gitlab tag. I sent the 
mesa-24.0.1 update as a follow up because 24.0.0 is already in master.
diff mbox series

Patch

diff --git a/meta/recipes-graphics/mesa/files/0001-meson.build-check-for-all-linux-host_os-combinations.patch b/meta/recipes-graphics/mesa/files/0001-meson.build-check-for-all-linux-host_os-combinations.patch
index fadd6ee201..b0be8d0feb 100644
--- a/meta/recipes-graphics/mesa/files/0001-meson.build-check-for-all-linux-host_os-combinations.patch
+++ b/meta/recipes-graphics/mesa/files/0001-meson.build-check-for-all-linux-host_os-combinations.patch
@@ -23,21 +23,21 @@  diff --git a/meson.build b/meson.build
 index 35cc5f1..9a49c0d 100644
 --- a/meson.build
 +++ b/meson.build
-@@ -121,7 +121,7 @@ with_any_opengl = with_opengl or with_gles1 or with_gles2
+@@ -128,7 +128,7 @@
  # Only build shared_glapi if at least one OpenGL API is enabled
  with_shared_glapi = with_shared_glapi and with_any_opengl
  
--system_has_kms_drm = ['openbsd', 'netbsd', 'freebsd', 'gnu/kfreebsd', 'dragonfly', 'linux', 'sunos', 'android'].contains(host_machine.system())
-+system_has_kms_drm = ['openbsd', 'netbsd', 'freebsd', 'gnu/kfreebsd', 'dragonfly', 'linux', 'sunos', 'android'].contains(host_machine.system()) or host_machine.system().startswith('linux')
+-system_has_kms_drm = ['openbsd', 'netbsd', 'freebsd', 'gnu/kfreebsd', 'dragonfly', 'linux', 'sunos', 'android', 'managarm'].contains(host_machine.system())
++system_has_kms_drm = ['openbsd', 'netbsd', 'freebsd', 'gnu/kfreebsd', 'dragonfly', 'linux', 'sunos', 'android', 'managarm'].contains(host_machine.system()) or host_machine.system().startswith('linux')
  
  gallium_drivers = get_option('gallium-drivers')
  if gallium_drivers.contains('auto')
-@@ -956,7 +956,7 @@ if cc.has_function('fmemopen')
+@@ -998,7 +998,7 @@
  endif
  
  # TODO: this is very incomplete
--if ['linux', 'cygwin', 'gnu', 'freebsd', 'gnu/kfreebsd', 'haiku', 'android'].contains(host_machine.system())
-+if ['linux', 'cygwin', 'gnu', 'freebsd', 'gnu/kfreebsd', 'haiku'].contains(host_machine.system()) or host_machine.system().startswith('linux')
+-if ['linux', 'cygwin', 'gnu', 'freebsd', 'gnu/kfreebsd', 'haiku', 'android', 'managarm'].contains(host_machine.system())
++if ['linux', 'cygwin', 'gnu', 'freebsd', 'gnu/kfreebsd', 'haiku', 'android', 'managarm'].contains(host_machine.system()) or host_machine.system().startswith('linux')
    pre_args += '-D_GNU_SOURCE'
  elif host_machine.system() == 'sunos'
    pre_args += '-D__EXTENSIONS__'
diff --git a/meta/recipes-graphics/mesa/mesa-gl_23.3.5.bb b/meta/recipes-graphics/mesa/mesa-gl_24.0.0.bb
similarity index 100%
rename from meta/recipes-graphics/mesa/mesa-gl_23.3.5.bb
rename to meta/recipes-graphics/mesa/mesa-gl_24.0.0.bb
diff --git a/meta/recipes-graphics/mesa/mesa.inc b/meta/recipes-graphics/mesa/mesa.inc
index 3a7b91f637..fabc52f0e7 100644
--- a/meta/recipes-graphics/mesa/mesa.inc
+++ b/meta/recipes-graphics/mesa/mesa.inc
@@ -20,7 +20,7 @@  SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
            file://0001-gallium-Fix-build-with-llvm-17.patch \
 "
 
-SRC_URI[sha256sum] = "69ccb1278641ff5bad71ca0f866188aeb1a92aadc4dbb9d35f50aebec5b8b50f"
+SRC_URI[sha256sum] = "dc7e8c077bc5884df95478263b34bdebb7e88e600689cb56fb07be2b8c304c36"
 
 UPSTREAM_CHECK_GITTAGREGEX = "mesa-(?P<pver>\d+(\.\d+)+)"
 
@@ -81,12 +81,12 @@  def strip_comma(s):
 
 PACKAGECONFIG = " \
 	gallium \
+	video-codecs \
 	${@bb.utils.filter('DISTRO_FEATURES', 'x11 vulkan wayland', d)} \
 	${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'opengl egl gles gbm virgl', '', d)} \
 	${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'dri3', '', d)} \
 	${@bb.utils.contains('DISTRO_FEATURES', 'x11 vulkan', 'dri3', '', d)} \
 	${@bb.utils.contains('DISTRO_FEATURES', 'vulkan', 'zink', '', d)} \
-	${@bb.utils.contains('LICENSE_FLAGS_ACCEPTED', 'commercial', 'video-codecs', '', d)} \
 "
 
 PACKAGECONFIG:append:class-native = "gallium-llvm r600"
@@ -203,8 +203,8 @@  PACKAGECONFIG[unwind] = "-Dlibunwind=enabled,-Dlibunwind=disabled,libunwind"
 
 PACKAGECONFIG[lmsensors] = "-Dlmsensors=enabled,-Dlmsensors=disabled,lmsensors"
 
-VIDEO_CODECS = "vc1dec,h264dec,h264enc,h265dec,h265enc"
-PACKAGECONFIG[video-codecs] = "-Dvideo-codecs=${@strip_comma('${VIDEO_CODECS}')}, -Dvideo-codecs=''"
+VIDEO_CODECS ?= "${@bb.utils.contains('LICENSE_FLAGS_ACCEPTED', 'commercial', 'all', 'all_free', d)}"
+PACKAGECONFIG[video-codecs] = "-Dvideo-codecs=${VIDEO_CODECS}, -Dvideo-codecs=''"
 
 # llvmpipe is slow if compiled with -fomit-frame-pointer (e.g. -O2)
 FULL_OPTIMIZATION:append = " -fno-omit-frame-pointer"
diff --git a/meta/recipes-graphics/mesa/mesa_23.3.5.bb b/meta/recipes-graphics/mesa/mesa_24.0.0.bb
similarity index 100%
rename from meta/recipes-graphics/mesa/mesa_23.3.5.bb
rename to meta/recipes-graphics/mesa/mesa_24.0.0.bb