diff mbox series

[3/3] valgrind: skip 14 ptests in 3.22

Message ID 20240212220501.3571864-3-Randy.MacLeod@windriver.com
State Accepted, archived
Commit 8203bfac493226c26f0d6db0f653868605433b6f
Headers show
Series [1/3] valgrind: make ptest depend on all components | expand

Commit Message

Randy MacLeod Feb. 12, 2024, 10:05 p.m. UTC
From: Randy MacLeod <Randy.MacLeod@windriver.com>

Sort the ptest depenencies into a somewhat alpahbetical order.
Add python3-compile for ptests.

Add softlinks for cachegrind to eliminate a warning seen in those tests.

The folowing tests fail after the 3.22 update:
   memcheck/tests/linux/dlclose_leak-no-keep
   memcheck/tests/linux/dlclose_leak
   memcheck/tests/wrap1
   memcheck/tests/wrap2
   ...
   memcheck/tests/wrap8
   cachegrind/tests/wrap5
   massif/tests/bug469146
   massif/tests/new-cpp
   massif/tests/overloaded-new

Omit these tests until they are fixed.
Tracked by: https://bugzilla.yoctoproject.org/show_bug.cgi?id=15399

=== Test Summary ===
TOTAL: 778
PASSED: 759
FAILED: 0
SKIPPED: 19

Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com>
---
 .../valgrind/valgrind/remove-for-all               | 14 ++++++++++++++
 meta/recipes-devtools/valgrind/valgrind_3.22.0.bb  | 14 ++++++++++++--
 2 files changed, 26 insertions(+), 2 deletions(-)

Comments

Richard Purdie Feb. 14, 2024, 1:51 p.m. UTC | #1
On Mon, 2024-02-12 at 14:05 -0800, Randy MacLeod via
lists.openembedded.org wrote:
> From: Randy MacLeod <Randy.MacLeod@windriver.com>
> 
> Sort the ptest depenencies into a somewhat alpahbetical order.
> Add python3-compile for ptests.
> 
> Add softlinks for cachegrind to eliminate a warning seen in those tests.
> 
> The folowing tests fail after the 3.22 update:
>    memcheck/tests/linux/dlclose_leak-no-keep
>    memcheck/tests/linux/dlclose_leak
>    memcheck/tests/wrap1
>    memcheck/tests/wrap2
>    ...
>    memcheck/tests/wrap8
>    cachegrind/tests/wrap5
>    massif/tests/bug469146
>    massif/tests/new-cpp
>    massif/tests/overloaded-new
> 
> Omit these tests until they are fixed.
> Tracked by: https://bugzilla.yoctoproject.org/show_bug.cgi?id=15399
> 
> === Test Summary ===
> TOTAL: 778
> PASSED: 759
> FAILED: 0
> SKIPPED: 19
> 
> Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com>
> ---
>  .../valgrind/valgrind/remove-for-all               | 14 ++++++++++++++
>  meta/recipes-devtools/valgrind/valgrind_3.22.0.bb  | 14 ++++++++++++--
>  2 files changed, 26 insertions(+), 2 deletions(-)
> 
> diff --git a/meta/recipes-devtools/valgrind/valgrind/remove-for-all b/meta/recipes-devtools/valgrind/valgrind/remove-for-all
> index e26088f3b1..004589a7ea 100644
> --- a/meta/recipes-devtools/valgrind/valgrind/remove-for-all
> +++ b/meta/recipes-devtools/valgrind/valgrind/remove-for-all
> @@ -1,6 +1,17 @@
> +cachegrind/tests/wrap5
>  none/tests/amd64/fb_test_amd64
>  gdbserver_tests/hginfo
> +memcheck/tests/linux/dlclose_leak-no-keep
> +memcheck/tests/linux/dlclose_leak
>  memcheck/tests/supp_unknown
> +memcheck/tests/wrap1
> +memcheck/tests/wrap2
> +memcheck/tests/wrap3
> +memcheck/tests/wrap4
> +memcheck/tests/wrap5
> +memcheck/tests/wrap6
> +memcheck/tests/wrap7
> +memcheck/tests/wrap8
>  helgrind/tests/tls_threads
>  helgrind/tests/pth_mempcpy_false_races
>  drd/tests/bar_bad
> @@ -9,3 +20,6 @@ drd/tests/pth_barrier_thr_cr
>  drd/tests/std_thread2
>  drd/tests/thread_name_xml
>  massif/tests/deep-D
> +massif/tests/bug469146
> +massif/tests/new-cpp
> +massif/tests/overloaded-new
> diff --git a/meta/recipes-devtools/valgrind/valgrind_3.22.0.bb b/meta/recipes-devtools/valgrind/valgrind_3.22.0.bb
> index dc00edb24e..74ac7ec9d5 100644
> --- a/meta/recipes-devtools/valgrind/valgrind_3.22.0.bb
> +++ b/meta/recipes-devtools/valgrind/valgrind_3.22.0.bb
> @@ -129,13 +129,18 @@ INHIBIT_PACKAGE_STRIP_FILES = "${PKGD}${libexecdir}/valgrind/vgpreload_memcheck-
>  RRECOMMENDS:${PN} += "${TCLIBC}-dbg"
>  
>  RDEPENDS:${PN}-ptest += " bash coreutils curl file \
> -   gdb libgomp \
> +   gdb \
> +   ${TCLIBC}-src gcc-runtime-dbg \
> +   libgomp \
>     perl \
>     perl-module-file-basename perl-module-file-glob perl-module-getopt-long \
>     perl-module-overloading perl-module-cwd perl-module-ipc-open3 \
>     perl-module-carp perl-module-symbol \
> -   procps sed ${PN}-dbg ${PN}-src ${TCLIBC}-src gcc-runtime-dbg \
> +   procps \
> +   python3-compile \
> +   sed \
>     util-linux-taskset \
> +   ${PN}-dbg ${PN}-src \
>     ${PN}-cachegrind ${PN}-massif ${PN}-callgrind \
>  "
>  RDEPENDS:${PN}-ptest:append:libc-glibc = " glibc-utils glibc-gconv-utf-32"
> @@ -225,6 +230,11 @@ do_install_ptest() {
>      sed -i s:@libexecdir@:${libexecdir}:g ${D}${PTEST_PATH}/run-ptest
>      sed -i s:@bindir@:${bindir}:g ${D}${PTEST_PATH}/run-ptest
>  
> +    # enable cachegrind ptests
> +    ln -s ${bindir}/cg_annotate ${D}/${PTEST_PATH}/cachegrind/cg_annotate
> +    ln -s ${bindir}/cg_diff ${D}/${PTEST_PATH}/cachegrind/cg_diff
> +    ln -s ${bindir}/cg_merge ${D}/${PTEST_PATH}/cachegrind/cg_merge
> +
>      # This test fails on the host as well, using both 3.15 and git master (as of Jan 24 2020)
>      # https://bugs.kde.org/show_bug.cgi?id=402833
>      rm ${D}${PTEST_PATH}/memcheck/tests/overlap.vgtest

There may be further failures on arm:

https://autobuilder.yoctoproject.org/typhoon/#/builders/82/builds/6086

Cheers,

Richard
Randy MacLeod Feb. 15, 2024, 1:40 a.m. UTC | #2
On 2024-02-14 8:51 a.m., Richard Purdie wrote:
> On Mon, 2024-02-12 at 14:05 -0800, Randy MacLeod via
> lists.openembedded.org wrote:
>> From: Randy MacLeod<Randy.MacLeod@windriver.com>
>>
>> Sort the ptest depenencies into a somewhat alpahbetical order.
>> Add python3-compile for ptests.
>>
>> Add softlinks for cachegrind to eliminate a warning seen in those tests.
>>
>> The folowing tests fail after the 3.22 update:
>>     memcheck/tests/linux/dlclose_leak-no-keep
>>     memcheck/tests/linux/dlclose_leak
>>     memcheck/tests/wrap1
>>     memcheck/tests/wrap2
>>     ...
>>     memcheck/tests/wrap8
>>     cachegrind/tests/wrap5
>>     massif/tests/bug469146
>>     massif/tests/new-cpp
>>     massif/tests/overloaded-new
>>
>> Omit these tests until they are fixed.
>> Tracked by:https://bugzilla.yoctoproject.org/show_bug.cgi?id=15399
>>
>> === Test Summary ===
>> TOTAL: 778
>> PASSED: 759
>> FAILED: 0
>> SKIPPED: 19
>>
>> Signed-off-by: Randy MacLeod<Randy.MacLeod@windriver.com>
>> ---
>>   .../valgrind/valgrind/remove-for-all               | 14 ++++++++++++++
>>   meta/recipes-devtools/valgrind/valgrind_3.22.0.bb  | 14 ++++++++++++--
>>   2 files changed, 26 insertions(+), 2 deletions(-)
>>
>> diff --git a/meta/recipes-devtools/valgrind/valgrind/remove-for-all b/meta/recipes-devtools/valgrind/valgrind/remove-for-all
>> index e26088f3b1..004589a7ea 100644
>> --- a/meta/recipes-devtools/valgrind/valgrind/remove-for-all
>> +++ b/meta/recipes-devtools/valgrind/valgrind/remove-for-all
>> @@ -1,6 +1,17 @@
>> +cachegrind/tests/wrap5
>>   none/tests/amd64/fb_test_amd64
>>   gdbserver_tests/hginfo
>> +memcheck/tests/linux/dlclose_leak-no-keep
>> +memcheck/tests/linux/dlclose_leak
>>   memcheck/tests/supp_unknown
>> +memcheck/tests/wrap1
>> +memcheck/tests/wrap2
>> +memcheck/tests/wrap3
>> +memcheck/tests/wrap4
>> +memcheck/tests/wrap5
>> +memcheck/tests/wrap6
>> +memcheck/tests/wrap7
>> +memcheck/tests/wrap8
>>   helgrind/tests/tls_threads
>>   helgrind/tests/pth_mempcpy_false_races
>>   drd/tests/bar_bad
>> @@ -9,3 +20,6 @@ drd/tests/pth_barrier_thr_cr
>>   drd/tests/std_thread2
>>   drd/tests/thread_name_xml
>>   massif/tests/deep-D
>> +massif/tests/bug469146
>> +massif/tests/new-cpp
>> +massif/tests/overloaded-new
>> diff --git a/meta/recipes-devtools/valgrind/valgrind_3.22.0.bb b/meta/recipes-devtools/valgrind/valgrind_3.22.0.bb
>> index dc00edb24e..74ac7ec9d5 100644
>> --- a/meta/recipes-devtools/valgrind/valgrind_3.22.0.bb
>> +++ b/meta/recipes-devtools/valgrind/valgrind_3.22.0.bb
>> @@ -129,13 +129,18 @@ INHIBIT_PACKAGE_STRIP_FILES = "${PKGD}${libexecdir}/valgrind/vgpreload_memcheck-
>>   RRECOMMENDS:${PN} += "${TCLIBC}-dbg"
>>   
>>   RDEPENDS:${PN}-ptest += " bash coreutils curl file \
>> -   gdb libgomp \
>> +   gdb \
>> +   ${TCLIBC}-src gcc-runtime-dbg \
>> +   libgomp \
>>      perl \
>>      perl-module-file-basename perl-module-file-glob perl-module-getopt-long \
>>      perl-module-overloading perl-module-cwd perl-module-ipc-open3 \
>>      perl-module-carp perl-module-symbol \
>> -   procps sed ${PN}-dbg ${PN}-src ${TCLIBC}-src gcc-runtime-dbg \
>> +   procps \
>> +   python3-compile \
>> +   sed \
>>      util-linux-taskset \
>> +   ${PN}-dbg ${PN}-src \
>>      ${PN}-cachegrind ${PN}-massif ${PN}-callgrind \
>>   "
>>   RDEPENDS:${PN}-ptest:append:libc-glibc = " glibc-utils glibc-gconv-utf-32"
>> @@ -225,6 +230,11 @@ do_install_ptest() {
>>       sed -i s:@libexecdir@:${libexecdir}:g ${D}${PTEST_PATH}/run-ptest
>>       sed -i s:@bindir@:${bindir}:g ${D}${PTEST_PATH}/run-ptest
>>   
>> +    # enable cachegrind ptests
>> +    ln -s ${bindir}/cg_annotate ${D}/${PTEST_PATH}/cachegrind/cg_annotate
>> +    ln -s ${bindir}/cg_diff ${D}/${PTEST_PATH}/cachegrind/cg_diff
>> +    ln -s ${bindir}/cg_merge ${D}/${PTEST_PATH}/cachegrind/cg_merge
>> +
>>       # This test fails on the host as well, using both 3.15 and git master (as of Jan 24 2020)
>>       #https://bugs.kde.org/show_bug.cgi?id=402833
>>       rm ${D}${PTEST_PATH}/memcheck/tests/overlap.vgtest
> There may be further failures on arm:
>
> https://autobuilder.yoctoproject.org/typhoon/#/builders/82/builds/6086
There are 22 more arm64 specific ptest failures.

I've skipped them as well and I'm doing a round of ssslllooowww testing 
(3 hours/run).

I'll send a commit to be added on top of this series once that's done
and we're back to ZERO ptest failures.

I'll try to make time to fix the regressions before 5.0 M4 but if anyone 
else is
interested, please let me know.

../Randy


>
> Cheers,
>
> Richard
>
>
diff mbox series

Patch

diff --git a/meta/recipes-devtools/valgrind/valgrind/remove-for-all b/meta/recipes-devtools/valgrind/valgrind/remove-for-all
index e26088f3b1..004589a7ea 100644
--- a/meta/recipes-devtools/valgrind/valgrind/remove-for-all
+++ b/meta/recipes-devtools/valgrind/valgrind/remove-for-all
@@ -1,6 +1,17 @@ 
+cachegrind/tests/wrap5
 none/tests/amd64/fb_test_amd64
 gdbserver_tests/hginfo
+memcheck/tests/linux/dlclose_leak-no-keep
+memcheck/tests/linux/dlclose_leak
 memcheck/tests/supp_unknown
+memcheck/tests/wrap1
+memcheck/tests/wrap2
+memcheck/tests/wrap3
+memcheck/tests/wrap4
+memcheck/tests/wrap5
+memcheck/tests/wrap6
+memcheck/tests/wrap7
+memcheck/tests/wrap8
 helgrind/tests/tls_threads
 helgrind/tests/pth_mempcpy_false_races
 drd/tests/bar_bad
@@ -9,3 +20,6 @@  drd/tests/pth_barrier_thr_cr
 drd/tests/std_thread2
 drd/tests/thread_name_xml
 massif/tests/deep-D
+massif/tests/bug469146
+massif/tests/new-cpp
+massif/tests/overloaded-new
diff --git a/meta/recipes-devtools/valgrind/valgrind_3.22.0.bb b/meta/recipes-devtools/valgrind/valgrind_3.22.0.bb
index dc00edb24e..74ac7ec9d5 100644
--- a/meta/recipes-devtools/valgrind/valgrind_3.22.0.bb
+++ b/meta/recipes-devtools/valgrind/valgrind_3.22.0.bb
@@ -129,13 +129,18 @@  INHIBIT_PACKAGE_STRIP_FILES = "${PKGD}${libexecdir}/valgrind/vgpreload_memcheck-
 RRECOMMENDS:${PN} += "${TCLIBC}-dbg"
 
 RDEPENDS:${PN}-ptest += " bash coreutils curl file \
-   gdb libgomp \
+   gdb \
+   ${TCLIBC}-src gcc-runtime-dbg \
+   libgomp \
    perl \
    perl-module-file-basename perl-module-file-glob perl-module-getopt-long \
    perl-module-overloading perl-module-cwd perl-module-ipc-open3 \
    perl-module-carp perl-module-symbol \
-   procps sed ${PN}-dbg ${PN}-src ${TCLIBC}-src gcc-runtime-dbg \
+   procps \
+   python3-compile \
+   sed \
    util-linux-taskset \
+   ${PN}-dbg ${PN}-src \
    ${PN}-cachegrind ${PN}-massif ${PN}-callgrind \
 "
 RDEPENDS:${PN}-ptest:append:libc-glibc = " glibc-utils glibc-gconv-utf-32"
@@ -225,6 +230,11 @@  do_install_ptest() {
     sed -i s:@libexecdir@:${libexecdir}:g ${D}${PTEST_PATH}/run-ptest
     sed -i s:@bindir@:${bindir}:g ${D}${PTEST_PATH}/run-ptest
 
+    # enable cachegrind ptests
+    ln -s ${bindir}/cg_annotate ${D}/${PTEST_PATH}/cachegrind/cg_annotate
+    ln -s ${bindir}/cg_diff ${D}/${PTEST_PATH}/cachegrind/cg_diff
+    ln -s ${bindir}/cg_merge ${D}/${PTEST_PATH}/cachegrind/cg_merge
+
     # This test fails on the host as well, using both 3.15 and git master (as of Jan 24 2020)
     # https://bugs.kde.org/show_bug.cgi?id=402833
     rm ${D}${PTEST_PATH}/memcheck/tests/overlap.vgtest