diff mbox series

rpm: depend on curl-native

Message ID 20240202122708.2167891-1-alex@linutronix.de
State Superseded, archived
Headers show
Series rpm: depend on curl-native | expand

Commit Message

Alexander Kanavin Feb. 2, 2024, 12:27 p.m. UTC
rpm is searching for curl executable at do_configure time
and result is non-deterministic without this dependency:
https://autobuilder.yocto.io/pub/repro-fail/oe-reproducible-20240201-8dcic6ea/packages/diff-html/

Signed-off-by: Alexander Kanavin <alex@linutronix.de>
---
 meta/recipes-devtools/rpm/rpm_4.19.1.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Richard Purdie Feb. 2, 2024, 1:10 p.m. UTC | #1
On Fri, 2024-02-02 at 13:27 +0100, Alexander Kanavin wrote:
> rpm is searching for curl executable at do_configure time
> and result is non-deterministic without this dependency:
> https://autobuilder.yocto.io/pub/repro-fail/oe-reproducible-20240201-8dcic6ea/packages/diff-html/
> 
> Signed-off-by: Alexander Kanavin <alex@linutronix.de>
> ---
>  meta/recipes-devtools/rpm/rpm_4.19.1.bb | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/meta/recipes-devtools/rpm/rpm_4.19.1.bb b/meta/recipes-devtools/rpm/rpm_4.19.1.bb
> index af11dec5ef3..f6d21cb6a4a 100644
> --- a/meta/recipes-devtools/rpm/rpm_4.19.1.bb
> +++ b/meta/recipes-devtools/rpm/rpm_4.19.1.bb
> @@ -48,7 +48,7 @@ SRCREV = "98b301ebb44fb5cabb56fc24bc3aaa437c47c038"
>  
>  S = "${WORKDIR}/git"
>  
> -DEPENDS = "lua libgcrypt file popt xz bzip2 elfutils python3 sqlite3 zstd"
> +DEPENDS = "lua libgcrypt file popt xz bzip2 elfutils python3 sqlite3 zstd curl-native"
>  DEPENDS:append:class-native = " file-replacement-native bzip2-replacement-native"
>  
>  EXTRA_OECMAKE:append:libc-musl = " -DENABLE_NLS=OFF -DENABLE_OPENMP=OFF"

Can we not just tell rpm it is "curl" or "/usr/bin/curl" explicitly?
Adding dependencies increases build times and we really don't want to
if we don't need to.

Cheers,

Richard
Alexander Kanavin Feb. 2, 2024, 1:24 p.m. UTC | #2
On Fri, 2 Feb 2024 at 14:10, Richard Purdie
<richard.purdie@linuxfoundation.org> wrote:
> Can we not just tell rpm it is "curl" or "/usr/bin/curl" explicitly?
> Adding dependencies increases build times and we really don't want to
> if we don't need to.

Yes, I've send a patch for that now.

Alex
diff mbox series

Patch

diff --git a/meta/recipes-devtools/rpm/rpm_4.19.1.bb b/meta/recipes-devtools/rpm/rpm_4.19.1.bb
index af11dec5ef3..f6d21cb6a4a 100644
--- a/meta/recipes-devtools/rpm/rpm_4.19.1.bb
+++ b/meta/recipes-devtools/rpm/rpm_4.19.1.bb
@@ -48,7 +48,7 @@  SRCREV = "98b301ebb44fb5cabb56fc24bc3aaa437c47c038"
 
 S = "${WORKDIR}/git"
 
-DEPENDS = "lua libgcrypt file popt xz bzip2 elfutils python3 sqlite3 zstd"
+DEPENDS = "lua libgcrypt file popt xz bzip2 elfutils python3 sqlite3 zstd curl-native"
 DEPENDS:append:class-native = " file-replacement-native bzip2-replacement-native"
 
 EXTRA_OECMAKE:append:libc-musl = " -DENABLE_NLS=OFF -DENABLE_OPENMP=OFF"