diff mbox series

[master] kernel-devsrc: fix RDEPENDS for make

Message ID 20240201142531.765590-1-claus.stovgaard@gmail.com
State Accepted, archived
Commit 711fc671012820458a7a28717ee0456fa850a523
Headers show
Series [master] kernel-devsrc: fix RDEPENDS for make | expand

Commit Message

Claus Stovgaard Feb. 1, 2024, 2:25 p.m. UTC
Since kernel version 6.6 the debian package rules has been split up into
a separate rules file, resulting in a runtime requirement for make.
See scripts/package/debian/rules

Remove the rules file, for not RDEPENDS on make for something we are
not using for building modules.

For reproducing the issue on a normal qemux86-64 machine, change to the
linux-yocto-dev kernel, add the kernel-devsrc to the toolchain target
task and disable ptest in distro features. (Notice ptest adds make as
RDEPENDS for other packages hiding the issue)

when populating sdk you will see dnf failing.

 Problem: conflicting requests
  - nothing provides /usr/bin/make needed by kernel-devsrc-1.0-r0.qemux86_64 from oe-repo

Signed-off-by: Claus Stovgaard <claus.stovgaard@gmail.com>
---
 meta/recipes-kernel/linux/kernel-devsrc.bb | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Bruce Ashfield Feb. 1, 2024, 2:49 p.m. UTC | #1
Thanks for the quick turnaround.

This looks good to me.

Bruce

On Thu, Feb 1, 2024 at 9:26 AM Claus Stovgaard
<claus.stovgaard@gmail.com> wrote:
>
> Since kernel version 6.6 the debian package rules has been split up into
> a separate rules file, resulting in a runtime requirement for make.
> See scripts/package/debian/rules
>
> Remove the rules file, for not RDEPENDS on make for something we are
> not using for building modules.
>
> For reproducing the issue on a normal qemux86-64 machine, change to the
> linux-yocto-dev kernel, add the kernel-devsrc to the toolchain target
> task and disable ptest in distro features. (Notice ptest adds make as
> RDEPENDS for other packages hiding the issue)
>
> when populating sdk you will see dnf failing.
>
>  Problem: conflicting requests
>   - nothing provides /usr/bin/make needed by kernel-devsrc-1.0-r0.qemux86_64 from oe-repo
>
> Signed-off-by: Claus Stovgaard <claus.stovgaard@gmail.com>
> ---
>  meta/recipes-kernel/linux/kernel-devsrc.bb | 4 ++++
>  1 file changed, 4 insertions(+)
>
> diff --git a/meta/recipes-kernel/linux/kernel-devsrc.bb b/meta/recipes-kernel/linux/kernel-devsrc.bb
> index ce5777fbe9..4ff751d9f0 100644
> --- a/meta/recipes-kernel/linux/kernel-devsrc.bb
> +++ b/meta/recipes-kernel/linux/kernel-devsrc.bb
> @@ -148,6 +148,10 @@ do_install() {
>         # for v6.1+ (otherwise we are missing multiple default targets)
>         cp -a --parents Kbuild $kerneldir/build 2>/dev/null || :
>
> +       # For v6.6+ the debian packing is moved out to seperate rules file
> +       # Remove as we else would ned to RDEPEND on make
> +       rm $kerneldir/build/scripts/package/debian/rules 2>/dev/null || :
> +
>         # if our build dir had objtool, it will also be rebuilt on target, so
>         # we copy what is required for that build
>         if [ -f ${B}/tools/objtool/objtool ]; then
> --
> 2.43.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#194590): https://lists.openembedded.org/g/openembedded-core/message/194590
> Mute This Topic: https://lists.openembedded.org/mt/104098238/1050810
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [bruce.ashfield@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-kernel/linux/kernel-devsrc.bb b/meta/recipes-kernel/linux/kernel-devsrc.bb
index ce5777fbe9..4ff751d9f0 100644
--- a/meta/recipes-kernel/linux/kernel-devsrc.bb
+++ b/meta/recipes-kernel/linux/kernel-devsrc.bb
@@ -148,6 +148,10 @@  do_install() {
 	# for v6.1+ (otherwise we are missing multiple default targets)
 	cp -a --parents Kbuild $kerneldir/build 2>/dev/null || :
 
+	# For v6.6+ the debian packing is moved out to seperate rules file
+	# Remove as we else would ned to RDEPEND on make
+	rm $kerneldir/build/scripts/package/debian/rules 2>/dev/null || :
+
 	# if our build dir had objtool, it will also be rebuilt on target, so
 	# we copy what is required for that build
 	if [ -f ${B}/tools/objtool/objtool ]; then