diff mbox series

opensbi: append LDFLAGS to TARGET_CC_ARCH

Message ID 20240130065944.604651-1-thomas.perrot@bootlin.com
State Accepted, archived
Commit b82e1e99feb8b0d70ff4c4bcac67336d562d2e53
Headers show
Series opensbi: append LDFLAGS to TARGET_CC_ARCH | expand

Commit Message

Thomas Perrot Jan. 30, 2024, 6:59 a.m. UTC
From: Thomas Perrot <thomas.perrot@bootlin.com>

To solve the following GNU_HASH error:
ERROR: opensbi-1.4-r0 do_package_qa: QA Issue: File /share/opensbi/lp64/generic/firmware/fw_dynamic.elf in package opensbi doesn't have GNU_HASH (didn't pass LDFLAGS?)
File /share/opensbi/lp64/generic/firmware/fw_payload.elf in package opensbi doesn't have GNU_HASH (didn't pass LDFLAGS?)
File /share/opensbi/lp64/generic/firmware/fw_jump.elf in package opensbi doesn't have GNU_HASH (didn't pass LDFLAGS?) [ldflags]

[YOCTO #15370] -- https://bugzilla.yoctoproject.org/show_bug.cgi?id=15370

Signed-off-by: Thomas Perrot <thomas.perrot@bootlin.com>
---
 meta/recipes-bsp/opensbi/opensbi_1.4.bb | 2 ++
 1 file changed, 2 insertions(+)
diff mbox series

Patch

diff --git a/meta/recipes-bsp/opensbi/opensbi_1.4.bb b/meta/recipes-bsp/opensbi/opensbi_1.4.bb
index fd18c03cfbc4..cf37a411766b 100644
--- a/meta/recipes-bsp/opensbi/opensbi_1.4.bb
+++ b/meta/recipes-bsp/opensbi/opensbi_1.4.bb
@@ -13,6 +13,8 @@  SRC_URI = "git://github.com/riscv/opensbi.git;branch=master;protocol=https"
 
 S = "${WORKDIR}/git"
 
+TARGET_CC_ARCH += "${LDFLAGS}"
+
 EXTRA_OEMAKE += "PLATFORM=${RISCV_SBI_PLAT} I=${D} FW_PIC=y CLANG_TARGET= "
 # If RISCV_SBI_PAYLOAD is set then include it as a payload
 EXTRA_OEMAKE:append = " ${@riscv_get_extra_oemake_image(d)}"