diff mbox series

opensbi: skip ldflags QA

Message ID 20240129100659.107901-1-thomas.perrot@bootlin.com
State Superseded, archived
Headers show
Series opensbi: skip ldflags QA | expand

Commit Message

Thomas Perrot Jan. 29, 2024, 10:06 a.m. UTC
From: Thomas Perrot <thomas.perrot@bootlin.com>

Quiet the following GNU_HASH error:
ERROR: opensbi-1.4-r0 do_package_qa: QA Issue: File /share/opensbi/lp64/generic/firmware/fw_dynamic.elf in package opensbi doesn't have GNU_HASH (didn't pass LDFLAGS?)
File /share/opensbi/lp64/generic/firmware/fw_payload.elf in package opensbi doesn't have GNU_HASH (didn't pass LDFLAGS?)
File /share/opensbi/lp64/generic/firmware/fw_jump.elf in package opensbi doesn't have GNU_HASH (didn't pass LDFLAGS?) [ldflags]

[YOCTO #15370] -- https://bugzilla.yoctoproject.org/show_bug.cgi?id=15370

Signed-off-by: Thomas Perrot <thomas.perrot@bootlin.com>
---
 meta/recipes-bsp/opensbi/opensbi_1.4.bb | 2 ++
 1 file changed, 2 insertions(+)

Comments

Khem Raj Jan. 29, 2024, 5:16 p.m. UTC | #1
On Mon, Jan 29, 2024 at 2:07 AM Thomas Perrot via
lists.openembedded.org
<thomas.perrot=bootlin.com@lists.openembedded.org> wrote:
>
> From: Thomas Perrot <thomas.perrot@bootlin.com>
>
> Quiet the following GNU_HASH error:
> ERROR: opensbi-1.4-r0 do_package_qa: QA Issue: File /share/opensbi/lp64/generic/firmware/fw_dynamic.elf in package opensbi doesn't have GNU_HASH (didn't pass LDFLAGS?)
> File /share/opensbi/lp64/generic/firmware/fw_payload.elf in package opensbi doesn't have GNU_HASH (didn't pass LDFLAGS?)
> File /share/opensbi/lp64/generic/firmware/fw_jump.elf in package opensbi doesn't have GNU_HASH (didn't pass LDFLAGS?) [ldflags]
>
> [YOCTO #15370] -- https://bugzilla.yoctoproject.org/show_bug.cgi?id=15370
>
> Signed-off-by: Thomas Perrot <thomas.perrot@bootlin.com>
> ---
>  meta/recipes-bsp/opensbi/opensbi_1.4.bb | 2 ++
>  1 file changed, 2 insertions(+)
>
> diff --git a/meta/recipes-bsp/opensbi/opensbi_1.4.bb b/meta/recipes-bsp/opensbi/opensbi_1.4.bb
> index fd18c03cfbc4..e36ada081428 100644
> --- a/meta/recipes-bsp/opensbi/opensbi_1.4.bb
> +++ b/meta/recipes-bsp/opensbi/opensbi_1.4.bb
> @@ -43,3 +43,5 @@ FILES:${PN} += "/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_dynamic.*"
>
>  COMPATIBLE_HOST = "(riscv64|riscv32).*"
>  INHIBIT_PACKAGE_STRIP = "1"
> +
> +INSANE_SKIP:${PN} = "ldflags"

hmmm I wonder if we should pass the OE ldflags, and test it out before
disabling this QA warning
try something like TARGET_CC_ARCH += "${LDFLAGS}"

> --
> 2.43.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#194454): https://lists.openembedded.org/g/openembedded-core/message/194454
> Mute This Topic: https://lists.openembedded.org/mt/104028517/1997914
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Thomas Perrot Jan. 30, 2024, 7 a.m. UTC | #2
Hello Khem,

On Mon, 2024-01-29 at 09:16 -0800, Khem Raj wrote:
> On Mon, Jan 29, 2024 at 2:07 AM Thomas Perrot via
> lists.openembedded.org
> <thomas.perrot=bootlin.com@lists.openembedded.org> wrote:
> > 
> > From: Thomas Perrot <thomas.perrot@bootlin.com>
> > 
> > Quiet the following GNU_HASH error:
> > ERROR: opensbi-1.4-r0 do_package_qa: QA Issue: File
> > /share/opensbi/lp64/generic/firmware/fw_dynamic.elf in package
> > opensbi doesn't have GNU_HASH (didn't pass LDFLAGS?)
> > File /share/opensbi/lp64/generic/firmware/fw_payload.elf in package
> > opensbi doesn't have GNU_HASH (didn't pass LDFLAGS?)
> > File /share/opensbi/lp64/generic/firmware/fw_jump.elf in package
> > opensbi doesn't have GNU_HASH (didn't pass LDFLAGS?) [ldflags]
> > 
> > [YOCTO #15370] --
> > https://bugzilla.yoctoproject.org/show_bug.cgi?id=15370
> > 
> > Signed-off-by: Thomas Perrot <thomas.perrot@bootlin.com>
> > ---
> >  meta/recipes-bsp/opensbi/opensbi_1.4.bb | 2 ++
> >  1 file changed, 2 insertions(+)
> > 
> > diff --git a/meta/recipes-bsp/opensbi/opensbi_1.4.bb
> > b/meta/recipes-bsp/opensbi/opensbi_1.4.bb
> > index fd18c03cfbc4..e36ada081428 100644
> > --- a/meta/recipes-bsp/opensbi/opensbi_1.4.bb
> > +++ b/meta/recipes-bsp/opensbi/opensbi_1.4.bb
> > @@ -43,3 +43,5 @@ FILES:${PN} +=
> > "/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_dynamic.*"
> > 
> >  COMPATIBLE_HOST = "(riscv64|riscv32).*"
> >  INHIBIT_PACKAGE_STRIP = "1"
> > +
> > +INSANE_SKIP:${PN} = "ldflags"
> 
> hmmm I wonder if we should pass the OE ldflags, and test it out
> before
> disabling this QA warning
> try something like TARGET_CC_ARCH += "${LDFLAGS}"

Thank you that solves the issue, I submitted another patch.

Kind regards,
Thomas Perrot

> 
> > --
> > 2.43.0
> > 
> > 
> > 
> > 
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#194469):
> https://lists.openembedded.org/g/openembedded-core/message/194469
> Mute This Topic: https://lists.openembedded.org/mt/104028517/5443093
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe:
> https://lists.openembedded.org/g/openembedded-core/unsub [
> thomas.perrot@bootlin.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta/recipes-bsp/opensbi/opensbi_1.4.bb b/meta/recipes-bsp/opensbi/opensbi_1.4.bb
index fd18c03cfbc4..e36ada081428 100644
--- a/meta/recipes-bsp/opensbi/opensbi_1.4.bb
+++ b/meta/recipes-bsp/opensbi/opensbi_1.4.bb
@@ -43,3 +43,5 @@  FILES:${PN} += "/share/opensbi/*/${RISCV_SBI_PLAT}/firmware/fw_dynamic.*"
 
 COMPATIBLE_HOST = "(riscv64|riscv32).*"
 INHIBIT_PACKAGE_STRIP = "1"
+
+INSANE_SKIP:${PN} = "ldflags"